Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Track numbers missing
13-01-2015, 19:03
Post: #1
Track numbers missing
After changing to the latest version, all albums in a particular folder have their track numbers missing. Also their are question marks all over the tracks display page. I have attached a screen shot. I stopped and restarted minimserver as well as rescanned, but no change. In the older version there was no such problem.

Thanks

best


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
13-01-2015, 20:03 (This post was last modified: 13-01-2015 20:04 by simoncn.)
Post: #2
RE: Track numbers missing
(13-01-2015 19:03)best Wrote:  After changing to the latest version, all albums in a particular folder have their track numbers missing. Also their are question marks all over the tracks display page. I have attached a screen shot. I stopped and restarted minimserver as well as rescanned, but no change. In the older version there was no such problem.

Thanks

best

Have you checked the MinimServer log for warning messages?

These problems are caused by illegal characters in your tag values. The log will contain messages giving full details.
Find all posts by this user
Quote this message in a reply
14-01-2015, 05:57
Post: #3
RE: Track numbers missing
(13-01-2015 20:03)simoncn Wrote:  
(13-01-2015 19:03)best Wrote:  After changing to the latest version, all albums in a particular folder have their track numbers missing. Also their are question marks all over the tracks display page. I have attached a screen shot. I stopped and restarted minimserver as well as rescanned, but no change. In the older version there was no such problem.

Thanks

best

Have you checked the MinimServer log for warning messages?

These problems are caused by illegal characters in your tag values. The log will contain messages giving full details.
Yes the log has numerous error messages in different tags saying 'unrecognised character 0x00'
I checked the tags in dbpoweramp batch converter, but did not find any different character therein.
This is all very strange, because until a few days back all the albums in this folder were being read perfectly.

best
Find all posts by this user
Quote this message in a reply
14-01-2015, 10:39 (This post was last modified: 14-01-2015 10:39 by simoncn.)
Post: #4
RE: Track numbers missing
(14-01-2015 05:57)best Wrote:  Yes the log has numerous error messages in different tags saying 'unrecognised character 0x00'
I checked the tags in dbpoweramp batch converter, but did not find any different character therein.
This is all very strange, because until a few days back all the albums in this folder were being read perfectly.

best

This problem can be difficult to fix because the NUL (0x00) character sometimes shows up as a space. You can see where these NUL characters are by looking at where the � appears in Kazoo. You should be able to fix the problem by editing the tags using Mp3tag and removing all the NUL characters.

Earlier versions of MinimServer ignored tag values containing illegal characters (with a warning message). This was changed recently to replace illegal characters with the � character when reading the tag value.
Find all posts by this user
Quote this message in a reply
26-01-2015, 12:01
Post: #5
RE: Track numbers missing
I have tried Mp3tag but I cannot find NUL characters. Also I have hundreds of wrong characters...so I don't see any real solution (if not switching back to previous behavior)

(14-01-2015 10:39)simoncn Wrote:  
(14-01-2015 05:57)best Wrote:  Yes the log has numerous error messages in different tags saying 'unrecognised character 0x00'
I checked the tags in dbpoweramp batch converter, but did not find any different character therein.
This is all very strange, because until a few days back all the albums in this folder were being read perfectly.

best

This problem can be difficult to fix because the NUL (0x00) character sometimes shows up as a space. You can see where these NUL characters are by looking at where the � appears in Kazoo. You should be able to fix the problem by editing the tags using Mp3tag and removing all the NUL characters.

Earlier versions of MinimServer ignored tag values containing illegal characters (with a warning message). This was changed recently to replace illegal characters with the � character when reading the tag value.
Find all posts by this user
Quote this message in a reply
26-01-2015, 12:41
Post: #6
RE: Track numbers missing
(26-01-2015 12:01)hifi25nl Wrote:  I have tried Mp3tag but I cannot find NUL characters. Also I have hundreds of wrong characters...so I don't see any real solution (if not switching back to previous behavior)

Were these tag values written by JRiver? If so, please see this post for the cause of the problem and a solution.
Find all posts by this user
Quote this message in a reply
16-10-2015, 02:39
Post: #7
RE: Track numbers missing
(26-01-2015 12:41)simoncn Wrote:  
(26-01-2015 12:01)hifi25nl Wrote:  I have tried Mp3tag but I cannot find NUL characters. Also I have hundreds of wrong characters...so I don't see any real solution (if not switching back to previous behavior)

Were these tag values written by JRiver? If so, please see this post for the cause of the problem and a solution.

Hello Simon!

I have the same problem but cannot see how it can be solved using the solution on the jrmc page...can you help?
Find all posts by this user
Quote this message in a reply
16-10-2015, 09:12
Post: #8
RE: Track numbers missing
(16-10-2015 02:39)mikejazz Wrote:  Hello Simon!

I have the same problem but cannot see how it can be solved using the solution on the jrmc page...can you help?

The simplest way to fix this is to update to a newer version of JRiver (if you haven't already done so) and rewrite all the tags in your files using "Update Tags (from library)" as described on this page.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)