Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New to Minim. Connot connect on linux, OS x fine
26-08-2014, 16:20
Post: #1
New to Minim. Connot connect on linux, OS x fine
Hi Folks,

I installed MinimServer on a Proxmox virtual machine.
Java reports:
Code:
root@bb-mnmsrv:/usr/local/minim/minimserver/data# java -version
java version "1.8.0_20"
Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b23, mixed mode)
Minimserver behaves like it startups fine,when looking in the minim server.log:
Code:
# cat minimserver.log | more
MinimServer 0.8.2 update 35, Copyright (c) 2012-2014 Simon Nash. All rights reserved.
Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b23, mixed mode)
Platform default charset is UTF-8
starting MinimServer
Language setting is 'eng'
MinimServer[bb-mnmsrv.cloud-connect.nl] is running
MinimServer: content directory is not valid: /mnt/nfs/bb14/iTunes/"iTunes Music"
MinimServer: content directory isn't absolute: "/mnt/nfs/bb14/iTunes/iTunes Music"
restarting MinimServer[bb-mnmsrv.cloud-connect.nl]
starting MinimServer[bb-mnmsrv.cloud-connect.nl]
Language setting is 'eng'
restarting MinimServer[bb-mnmsrv.cloud-connect.nl]
starting MinimServer[bb-mnmsrv.cloud-connect.nl]
Language setting is 'eng'
MinimServer[bb-mnmsrv.cloud-connect.nl] is running
restarting MinimServer[bb-mnmsrv.cloud-connect.nl]
starting MinimServer[bb-mnmsrv.cloud-connect.nl]
Language setting is 'eng'
MinimServer[bb-mnmsrv.cloud-connect.nl] is running
restarting MinimServer[bb-mnmsrv.cloud-connect.nl]
starting MinimServer[bb-mnmsrv.cloud-connect.nl]
Language setting is 'eng'
MinimServer[bb-mnmsrv.cloud-connect.nl] is running
However, MinimWatch does not see the server, and neither does Linn Kinsky.
As a test I installed the Mac OS X version on my macbook. That runs fine, and is seen by MinimWatch and by Kinsky.

The only slight difference I see between the Mac OS X logfile and the Linux logfile is that OS X shows this extra line:
Code:
Startup complete

Any suggestions to what the cause of this is, and how to solve it, would be highly appreciated!
Find all posts by this user
Quote this message in a reply
26-08-2014, 20:05
Post: #2
RE: New to Minim. Connot connect on linux, OS x fine
Found the root cause of this behavior:
The minim server instance runs on a virtual machine in a Proxmox environment. The minim server machine was defined as a VZ container in Proxmox. VZ containers do NOT pass multicast traffic through their venet interfaces. This can be solved by creating a virtual eth0 interface on the host machines bridge. Most of it can be done through the Proxmox web interface.
Find all posts by this user
Quote this message in a reply
26-08-2014, 22:10 (This post was last modified: 26-08-2014 22:12 by simoncn.)
Post: #3
RE: New to Minim. Connot connect on linux, OS x fine
(26-08-2014 16:20)pvds Wrote:  I installed MinimServer on a Proxmox virtual machine.

However, MinimWatch does not see the server, and neither does Linn Kinsky.
As a test I installed the Mac OS X version on my macbook. That runs fine, and is seen by MinimWatch and by Kinsky.

The only slight difference I see between the Mac OS X logfile and the Linux logfile is that OS X shows this extra line:
Code:
Startup complete

I am also seeing 'Startup complete' on Mac but not on Linux. I think this is because the Linux launcher uses the --noconsole option and the Mac launcher doesn't use this option. This isn't related to why you aren't seeing the Proxmox MinimServer instance from Kinsky or MinimWatch.

I think the problem is likely to be related to your networking subnet setup and how UPnP multicast discovery messages are routed. You might need to use the MinimServer ohnet.subnet property setting to make this work. Have you been able to run any other UPnP server in a Proxmox virtual machine and access it from Kinsky?

Edit: I just saw your follow-up post. I'm glad to hear you have solved the problem.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)