Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot read Minimserver music library
29-08-2013, 08:15
Post: #1
Cannot read Minimserver music library
I've installed the latest Lumin app (ver 1.2.5). Lumin app and minimserver works perfectly before that. However, the latest Lumin app cannot display any songs although it can detect the minimserver (ver 0.72 on by QNAP TS212). I've installed the correct arm-based Java and minimserver. One strange thing is that the minimserver (and all songs) can be detected and play through Linn Kinsky app.

When I try to connect Lumin to minimserver, it prompted "searching" and then "analysing" but after that there is no response.

I wonder there is any incompatibility between the latest Lumin app and minimserver 0.72.

Also the minimwatch showed that the server is running.

Thanks for your attention.
Find all posts by this user
Quote this message in a reply
29-08-2013, 17:09 (This post was last modified: 29-08-2013 18:10 by Peter@57m.)
Post: #2
RE: Cannot read Minimserver music library
Not sure I can help you but I have been having a similar issue.

I noticed last week, on Lumin 1.2.4, that it was showing (offline) next to the number of albums/artists. Also the artwork was a bit suspect. So I decided to reload the library.
Big mistake. I then had the same symptoms as you. Searching, Analysing and for an instant Initialising. But never successfully loaded any music. Also was having an issue with Kinsky seeing MinimServer and sometimes Twonky on the QNAP. Not sure how long this had been happening as I mostly used Lumin. Sometimes when you start Kinsky one or other is there, sometimes both, sometimes neither.
I was trying to think what I could have changed and realized I had upgraded my QNAP 459 to 4.0.2. So set it back to 3.8.3 but no luck, same issue with Lumin, Kinsky etc.
Unistalled Lumin and Kinsky on the iPad and re-installed but still happening. Also noticed windows Kinsky sometimes didn't pick up MinimServer on starting.
Went to an old version of Lumin I had on an iPad backup (1.2.2) no luck there.
So just kept on using Kinsky on the iPad doing frequent restarts when MinimServer disappeared.
Lumin 1.2.5 came out, so upgraded and tried it. Did a quick search, analyse and then started loading but stopped after 50 or so albums (out of 650). Tried reload - no luck. Tried uninstalling Lumin and reinstalling, this time loaded 150 albums and then hung. uninstalled and reinstalled and this time it loaded all 650.
Had to stop Lumin and restart a few times to get it to load all the artwork but eventually got there.

Now it sometimes shows the server as (offline) but it still lets you browse and select and add items to the queue. After a few minutes the offline diappears, sometimes it returns.
So seem to be something odd going on with either QNAP or my network. Not having any problems playing music and doing anything else, surfing, email etc.
So I have not found the cause.
All I can suggest it to try uninstalling Lumin and reinstalling it and persevere. Hopefully you'll get lucky and have it load.

Using iPad, KlimaxDSM, Windows PC, WRT610N Linksys wireless router, GS108 Netgear 8 port switch, QNAP 459Pro+

Peter
________________________________________________________
Linn Klimax DSM Katalyst & Solos, Wilson Benesch ACT C60s & Torus
Linn Klimax Renew DS/1, Klimax Twin & Wilson Benesch P1.0
Linn Klimax Renew DSM, Chord Mezzo 75, ProAc 1SCs
QNAP 559 ProII, Melco N1ZH, MinimServer, Lumin & Kazoo
Find all posts by this user
Quote this message in a reply
29-08-2013, 18:08
Post: #3
RE: Cannot read Minimserver music library
Thanks. At least I'm not alone. I'm located in HK and called Lumin support but they've no idea either. I'm also using QNAP (TS212) and recently upgraded to 4.0.2. I've better luck using Kinsky but can't load even 1 song or album using Lumin app. Similar to you, it did a quick search, then analyzing, and then stop without any prompt but nothing appeared in the Lumin display. I've checked my rather huge home network but everything works just fine. I also have an issue showing "offline status after several loading attempt.

I really like using Lumin app, stable so far before upgrading to 1.2.5 and reload the music library. Hope someone here can give us an insight.

Using QNAP TS212, Lumin Music Player, TP Link TL-4300 wireless routher and Mac Book Pro and Mac Mini, iPad Mini as controller.
Find all posts by this user
Quote this message in a reply
30-08-2013, 09:18 (This post was last modified: 30-08-2013 09:19 by bbrip.)
Post: #4
RE: Cannot read Minimserver music library
Hi,

the only trouble I had with LUIN 1.2.5 is that it has changed to a more consistent method of handling multitags in Artists, Genre etc. which means I had to change certain settings in Minimserver Properties to get it to work properly. Have a read thru the last couple posts i nthis thread for further detail: http://forums.linn.co.uk/bb/showthread.p...29&page=67

As a result of these handling changes, 1.2.5 may have to re-read the entire library which with sizable libraries can take a couple of minutes. Also with the earlier iPads, particular iPad 1, you may experience LUMIN shutting down in between. Just start it again and let it spin again.

I now have all my 8800 Albums loaded with (apart form a smaller bug) great multitag handling, resulting in very nice search capabilities within LUMIN.

good luck

bbrip
Find all posts by this user
Quote this message in a reply
30-08-2013, 11:57
Post: #5
RE: Cannot read Minimserver music library
Have you guys try to reinstall MinimServer after upgrade the firmware of QNAP?
When I upgrade from 3.8.1 to 4.0.2, QNAP App center said MinimServer started but it looks like it wasn't running at all.
Can't see with MinimWatch or Kinsky, so I reinstall MinimServer, restart it and everything work fine now.
I also disable those built-in server but I think reinstall does the it.
Find all posts by this user
Quote this message in a reply
31-08-2013, 16:08
Post: #6
RE: Cannot read Minimserver music library
I've tried reinstall Minimserver. it seems that the lumin app is able to scan the library but still can't displayed all songs. It somehow stopped reacting after reading a no. Of album, 20 albums for my first restart and reinstall only 5 after a 2nd restart and reinstall. Got frustrating! Would this suggest a crash between QNAP 4.0.2 firmware and the lumin app or Minimserver?
Find all posts by this user
Quote this message in a reply
01-09-2013, 11:18
Post: #7
RE: Cannot read Minimserver music library
Since successfully getting Lumin to load all my library, I added a new CD and after restarting MinimServer, Lumin reindexed and I ended up with only 27 out of 650.
Since then I tried reinstalling Lumin, 1.2.5 and 1.2.2, using 4.0.2 and 3.8.3 firmware on QNAP, shutting down entire network and only bringing up NAS, KDSM and iPad and everything else I can think of.
All to no avail, not managed to get even 1 album loaded to Lumin
Totally frustrated by this.
I suspect its some network issue or some software behaving badly on the network but I'm out of my depth now.
Reason I say this is that MinimServer and Twonky running on the NAS as well as some other sources appear erratically in both Lumin and Kinsky

Peter
________________________________________________________
Linn Klimax DSM Katalyst & Solos, Wilson Benesch ACT C60s & Torus
Linn Klimax Renew DS/1, Klimax Twin & Wilson Benesch P1.0
Linn Klimax Renew DSM, Chord Mezzo 75, ProAc 1SCs
QNAP 559 ProII, Melco N1ZH, MinimServer, Lumin & Kazoo
Find all posts by this user
Quote this message in a reply
01-09-2013, 17:59
Post: #8
RE: Cannot read Minimserver music library
I agree, I rarely encounter setup problem which cannot be resolved but the lumin app behavior (with Minimserver) is really unexplainable. Luckily I still got my Kinsky app working as a backup, though not the most familiar interface. I'm still having email contact with Lumin in HK and a helpful technician said his more experienced colleague will come back this Wednesday. See whether they can have this issue resolved.
Find all posts by this user
Quote this message in a reply
02-09-2013, 08:58
Post: #9
RE: Cannot read Minimserver music library
Peter@57m,
QNAP 459Pro+ have 2 port, did you use both of them? if you do, you might want to add ohnet.subnet setting for your MinimServer.
Find all posts by this user
Quote this message in a reply
02-09-2013, 09:26
Post: #10
RE: Cannot read Minimserver music library
Thanks for the suggestion.

I did try with only one port and with both ports connected, didn't make a difference unfortunately. Was one of the things I tried when messing around with the network (which hadn't been changed for some time prior to the problem occurring)

Ideas on any other things to try most welcome

(02-09-2013 08:58)siuwang Wrote:  Peter@57m,
QNAP 459Pro+ have 2 port, did you use both of them? if you do, you might want to add ohnet.subnet setting for your MinimServer.

Peter
________________________________________________________
Linn Klimax DSM Katalyst & Solos, Wilson Benesch ACT C60s & Torus
Linn Klimax Renew DS/1, Klimax Twin & Wilson Benesch P1.0
Linn Klimax Renew DSM, Chord Mezzo 75, ProAc 1SCs
QNAP 559 ProII, Melco N1ZH, MinimServer, Lumin & Kazoo
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)