Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gapless (groan) with RoPieee and BubbleUpnp
02-10-2023, 16:16
Post: #1
Gapless (groan) with RoPieee and BubbleUpnp
The gapless thing refuses to go away :-( but first let me say this:

Whoever thought of and designed MinimServer needs a sainthood,a knighthood, a MBE and whatever else is going... it's a godsend!!!

OK.. I spent years using Clunky Twonky on a WD NAS - and then quite by chance I found minim - proper tagging for classical music - clearly somebody actually gives a shit about a minority interest and thank god they do. Thus far I've not played around with it much - just using the 'group' tag (which is just so brilliant)... will have to find a way of operationalizing the trial period from CLI. Well worth £28 I think.

Anyway I have this running on a Dell Optiplex 7010 which then feeds a Raspberry Pi 4 with RoPiee - I tried Volumio and its slow its just unusable - nor does it seem classical music friendly.

The problem I have is this: mConnect + RoPieee is gapless - yet BubbleUpnp is not (half second gap more or less) - and Bubble is much better at classical than mconnect. I'm thinking of trying UpMPDcli on the Pi4 with Bubble in the hope that problem may be solved.

Has anyone found a gapless renderer solution for RPi using BubbleUpnp as control on Android? Or a linux based renderer that could run on a Pi or thin client PC?
Find all posts by this user
Quote this message in a reply
02-10-2023, 16:46 (This post was last modified: 02-10-2023 16:59 by simbun.)
Post: #2
RE: Gapless (groan) with RoPieee and BubbleUpnp
Have you enabled Gapless control in the RoPiee renderer settings (within BubbleUPnP)? I'd be very surprised if mconnect was gapless but BubbleUPnP wasn't.

I have a DigiOne around here somewhere that I could use to try out RoPieee.
Find all posts by this user
Quote this message in a reply
02-10-2023, 16:51
Post: #3
RE: Gapless (groan) with RoPieee and BubbleUpnp
RoPieee is definitely gapless, UPnP is very well implemented, and I’m using it since 3, maybe 4, years without any issue (with Lumïn app and Bubbleupnpserver)
I’m on idevice (iPhone and iPad) therefore I haven’t tried Bubbleupnp but I think that there is some configuration to be done to let it work gapless. I’ve some friends using it with Minimserver and RoPieee and they don’t have any gapless issue
Find all posts by this user
Quote this message in a reply
02-10-2023, 18:00
Post: #4
RE: Gapless (groan) with RoPieee and BubbleUpnp
(02-10-2023 16:46)simbun Wrote:  Have you enabled Gapless control in the RoPiee renderer settings (within BubbleUPnP)? I'd be very surprised if mconnect was gapless but BubbleUPnP wasn't.

I have a DigiOne around here somewhere that I could use to try out RoPieee.

I've been right through the Bubble menu system and yes, the gapless box is ticked.
Find all posts by this user
Quote this message in a reply
02-10-2023, 18:03
Post: #5
RE: Gapless (groan) with RoPieee and BubbleUpnp
(02-10-2023 16:51)stefano_mbp Wrote:  RoPieee is definitely gapless, UPnP is very well implemented, and I’m using it since 3, maybe 4, years without any issue (with Lumïn app and Bubbleupnpserver)
I’m on idevice (iPhone and iPad) therefore I haven’t tried Bubbleupnp but I think that there is some configuration to be done to let it work gapless. I’ve some friends using it with Minimserver and RoPieee and they don’t have any gapless issue

RoPieee is definitely gapless with mconnect but not with bubbleupnp - which is why I find it odd.

I'm hopefully trying out UpMPDcli with a headless Raspian this evening as I've heard that combination (meaning with Bubbleupnp) is gapless.
Find all posts by this user
Quote this message in a reply
02-10-2023, 20:25
Post: #6
RE: Gapless (groan) with RoPieee and BubbleUpnp
I just tried Ropieee and gapless playback was fine with BubbleUPnP, having configured 'Gapless control' in the settings, otherwise there was a small gap.

As a more thorough (and quicker) test I use sox to cut a song into smaller chunks.
BubbleUPnP didn't manage the queue of 3 second tracks but it successfully played the 8 five second tracks gaplessly.
If I enabled OpenHome support (which you'd probably want to do unless you're already using BubbleUPnP Server for that) in Ropieee the 3 second tracks played flawlessly too.

I'm sure you checked the right place, but just in case:
Menu > Settings > Renderer Settings: ropieee > Gapless control.
Find all posts by this user
Quote this message in a reply
02-10-2023, 20:57
Post: #7
RE: Gapless (groan) with RoPieee and BubbleUpnp
(02-10-2023 20:25)simbun Wrote:  I just tried Ropieee and gapless playback was fine with BubbleUPnP, having configured 'Gapless control' in the settings, otherwise there was a small gap.

As a more thorough (and quicker) test I use sox to cut a song into smaller chunks.
BubbleUPnP didn't manage the queue of 3 second tracks but it successfully played the 8 five second tracks gaplessly.
If I enabled OpenHome support (which you'd probably want to do unless you're already using BubbleUPnP Server for that) in Ropieee the 3 second tracks played flawlessly too.

I'm sure you checked the right place, but just in case:
Menu > Settings > Renderer Settings: ropieee > Gapless control.

Curious.. thankyou for going to the trouble to split tracks into tiny chunks. The only difference between your arrangement and mine would appear to be either BubbleUPnp server (which I've not installed) or enabling openhome support in Ropieee.

I'll try the latter first as it's a quick check.

Thanks again for your help.
Find all posts by this user
Quote this message in a reply
02-10-2023, 21:22
Post: #8
RE: Gapless (groan) with RoPieee and BubbleUpnp
(02-10-2023 20:57)dartmoor Wrote:  thankyou for going to the trouble to split tracks into tiny chunks.
I've been using them to test a WiiM Pro so it was no bother.
Code:
sox 01.01.flac output.flac trim 0 5 : newfile : restart
Just a thought, I assume you're playing FLAC files?

(02-10-2023 20:57)dartmoor Wrote:  The only difference between your arrangement and mine would appear to be either BubbleUPnp server (which I've not installed) or enabling openhome support in Ropieee.
I wasn't using BubbleUPnP Server in any of the tests, just the BubbleUPnP app with the 'Gapless control' setting enabled, and then with OpenHome enabled in Ropieee.

Assuming you have Gapless control enabled I can't think what it could be, as BubbleUPnP was playing gaplessly to the WiiM long before mconnect of Hi-Fi Cast were (a fix for the WiiM addressed this).

With OpenHome, the playback queue and the responsibility for advancing it is held on the renderer (Ropieee) rather than in the control point (BubbleUPnP), a much better solution all round.
Find all posts by this user
Quote this message in a reply
03-10-2023, 09:11
Post: #9
RE: Gapless (groan) with RoPieee and BubbleUpnp
(02-10-2023 21:22)simbun Wrote:  
(02-10-2023 20:57)dartmoor Wrote:  thankyou for going to the trouble to split tracks into tiny chunks.
I've been using them to test a WiiM Pro so it was no bother.
Code:
sox 01.01.flac output.flac trim 0 5 : newfile : restart
Just a thought, I assume you're playing FLAC files?

(02-10-2023 20:57)dartmoor Wrote:  The only difference between your arrangement and mine would appear to be either BubbleUPnp server (which I've not installed) or enabling openhome support in Ropieee.
I wasn't using BubbleUPnP Server in any of the tests, just the BubbleUPnP app with the 'Gapless control' setting enabled, and then with OpenHome enabled in Ropieee.

Assuming you have Gapless control enabled I can't think what it could be, as BubbleUPnP was playing gaplessly to the WiiM long before mconnect of Hi-Fi Cast were (a fix for the WiiM addressed this).

With OpenHome, the playback queue and the responsibility for advancing it is held on the renderer (Ropieee) rather than in the control point (BubbleUPnP), a much better solution all round.

Sadly there was only a marginal difference with the RoPieee Openhome checkbox enabled. mconnect was as before - gapless. BubbleUpnp may have reduced the gap (difficult to tell) - but it's still there with a click between each track. I installed and tried HiFiCast as well - the gap was huge - a good second.

I'm wondering if the Openhome player might prove better? I'm not familiar with it yet I see from their website that the Pi player requires 16MB memory??? A typo surely? I wasn't aware that such a thing existed.
Find all posts by this user
Quote this message in a reply
03-10-2023, 10:07 (This post was last modified: 03-10-2023 10:07 by stefano_mbp.)
Post: #10
RE: Gapless (groan) with RoPieee and BubbleUpnp
“16MB ram” (megabytes) is not a lot, rpi4 has 2GB (gigabytes) at least (4 and 8 GB available too)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)