Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Album art different than it should be
19-11-2022, 17:10
Post: #11
RE: Album art different than it should be
I close the app completely and restart it.
Find all posts by this user
Quote this message in a reply
19-11-2022, 17:59 (This post was last modified: 19-11-2022 17:59 by simoncn.)
Post: #12
RE: Album art different than it should be
Thanks for this. Does the album art go wrong after adding albums and doing a MinimServer rescan? If so, the problem is caused by incorrect album art caching in mconnect.

A MinimServer rescan can cause UPnP container IDs to change. If the control point is caching album art based on container IDs before the rescan, some of the cache entries will be wrong after the rescan.

The control point can detect this has happened because the next time it browses the [folder view] container, it will get different container IDs for the album folders. It seems that mconnect is not checking for this and is not reloading its album art cache when it happens. Closing mconnect and restarting it clears the mconnect album art cache and album art is then OK until the next MinimServer rescan.

There is nothing MinimServer can do to fix this mconnect problem. If you try using BubbleUPnP instead of mconnect, you should see correct album art after a MinimServer rescan.
Find all posts by this user
Quote this message in a reply
20-11-2022, 14:17
Post: #13
RE: Album art different than it should be
In addition to mconnect, I also use StreamMagic that come with my Cambridge Audio CXN-v2
Find all posts by this user
Quote this message in a reply
20-11-2022, 15:30
Post: #14
RE: Album art different than it should be
What causes the problem to occur? Is it adding albums and doing a MinimServer rescan?
Find all posts by this user
Quote this message in a reply
20-11-2022, 16:54 (This post was last modified: 20-11-2022 16:56 by Peter StreamMagic.)
Post: #15
RE: Album art different than it should be
I tried this with mconnect and I see no artwork at all. MinimServer is sending the artwork but mconnect is not displaying it.

Hello Simon,

I tried mcconnect on both iPhone and iPad and I can see artwork in Folder View.
Some art is missing in Folder View and I can not figure out why this is happening.
All artwork is showing correctly if browsing by tags in my case
I hardly use Folder View , but it intrigues me why this is happening.
I know the controlpoint can cause √°rtwork not showing up, the Cambridge Connect app is an example.
       

StreamMagic app some Folder View art missing
       

Kazoo app some Folder View art missing
       

MConnect app some Folder View art missing
       

No problems with artwork not corresponding though
Find all posts by this user
Quote this message in a reply
20-11-2022, 17:46 (This post was last modified: 20-11-2022 17:48 by simoncn.)
Post: #16
RE: Album art different than it should be
@Peter StreamMagic:

mconnect on my iPad is showing album art in folder view. It is only mconnect on my Android phone that does not show it.

It looks like it is the same two folders that are missing folder art with all your control points. This suggests there is some problem with the contents of these folders.
Find all posts by this user
Quote this message in a reply
20-11-2022, 18:40 (This post was last modified: 20-11-2022 18:41 by Peter StreamMagic.)
Post: #17
RE: Album art different than it should be
You were right!
Big Head Todd & The Monsters in Index artwork doesn't correspond with Big Head Todd and The Monsters. They did not show up in both Folder View and Artist.
Ben l'Oncle Soul did show up in Artist and not in Folder View caused by naming the folder Ben L'Oncle Soul,tagged as Ben l'Oncle SoulAngry
Small differences but wrong!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)