Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problems with Artist.displayFormat
03-03-2022, 16:21
Post: #21
RE: problems with Artist.displayFormat
(03-03-2022 15:51)simbun Wrote:  Just in case you didn't see my previous post, could you respond to the below questions and upload a file somewhere for us to look at?

I saw your post, but it takes a little time ...

The version 2.1 with the problems is running on a Synology DS-218 and DSM 6.x (latest).
Actually I did a completet new installation of the old 0.8.5.3 on my older Synology DS-212j, also running the lastest DSM 6.x, which is a backup-NAS for the DS-218, therefor it has exactly the same files. Because I have a lot of music it scans the tags there for the first time and this will take a while.

I will be back later doing some other tests with the combination of possible strings at version 2.1 ...
Find all posts by this user
Quote this message in a reply
03-03-2022, 16:24
Post: #22
RE: problems with Artist.displayFormat
(03-03-2022 16:21)Alhifi Wrote:  The version 2.1 with the problems is running on a Synology DS-218 and DSM 6.x (latest).
Actually I did a completet new installation of the old 0.8.5.3 on my older Synology DS-212j, also running the lastest DSM 6.x, which is a backup-NAS for the DS-218, therefor it has exactly the same files. Because I have a lot of music it scans the tags there for the first time and this will take a while.

I will be back later doing some other tests with the combination of possible strings at version 2.1 ...
I've already tested with '& something' for composer on an mp3 with a custom delimiter (the one in your first post) and it worked as expected, so there's nothing we can really do without a sample file.

You still haven't answered if it's happening to all your files with artist and composer?
Find all posts by this user
Quote this message in a reply
03-03-2022, 16:41
Post: #23
RE: problems with Artist.displayFormat
… just try to remove it …
Find all posts by this user
Quote this message in a reply
03-03-2022, 16:43
Post: #24
RE: problems with Artist.displayFormat
… just try to remove it …
You should start with the simplest configuration, if it works then add some customization, one at a time, and go on ..
Find all posts by this user
Quote this message in a reply
03-03-2022, 16:57
Post: #25
RE: problems with Artist.displayFormat
… anyway it works using & and {$artist$composer^^^_}


Attached File(s) Thumbnail(s)
       
Find all posts by this user
Quote this message in a reply
03-03-2022, 17:32 (This post was last modified: 03-03-2022 17:44 by simoncn.)
Post: #26
RE: problems with Artist.displayFormat
Is the problem happening only with VLC Media Player? This has known bugs with some "special" characters (see this issue, still unfixed after 4 years). The current problem isn't exactly the same but it would be worth trying this with a different control point.

Also, if you can upload this file to my FTP server, I will test it with your exact configuration. I will send you a PM with the server details.
Find all posts by this user
Quote this message in a reply
03-03-2022, 20:21
Post: #27
RE: problems with Artist.displayFormat
Ok, back again ...

As I wrote above in this thread I have installed the old 0.8.5.3 on my other Synology NAS, copy the configuration from 2.1 to this one (manually using the properties-GUIs of both versions, start it and the scan finished now.

I open again VLC and search for the new server, open the same album and the same track and as I expected:

[Image: minim09.jpg]

Now I changed the configuration of the 2.1 version and delete the complete "Artist.displayFormat" entry and restart the server ...

... and it shows the value of $composer as artist in VLC ... ???

Then I add the entry again, but only as "Artist.displayFormat={$artist}", restart ...

... and it shows the value of $composer as artist in VLC ... ???

Now I changed it to "Artist.displayFormat={$date$title^^^-}"

... and it shows the value of $composer as artist in VLC ... ???

I have not found an option that VLC chaches such entries.

I changed it back to the first configuration Artist.displayFormat={$artist$composer^^^ } ... and of course VLC shows ...

... but BubbleUPnP now shows it correct!

Now I tried the Roku Soundbridges ... with minimserver 0.8.5.3 everything is fine, with the 2.1-0600 it's still not working.

So what's wrong here in the installation of the new version???

@simonnc

I will deinstall the actual version of the 2.1-0600 using the packet deinstallation GUI of Synologys DSM 6.x! In the past you told me that minimserver has no own database and everything is handled in RAM, is this also the same in 2.1?
Or are there some files already in the file system?

Why is the version-number at Synologys Packagecenter lower than on your website?

What about the licence, will the new installation on the same NAS be counted as a 2nd possible?

kind regards
Alhifi
Find all posts by this user
Quote this message in a reply
03-03-2022, 22:48
Post: #28
RE: problems with Artist.displayFormat
MinimServer keeps cache files, configuration files and profile files in the file system.

If you choose the option to uninstall MinimServer 2.1 completely, all MinimServer files in the file system will be removed. This includes configuration files and profile files, so you should export your profile before you uninstall and import your profile after you reinstall.

Before uninstallng MinimServer 2, you must deactivate your full license. When you reinstall MinimServer 2 and reactivate your license, this will not create an additional license activation.

The MinimServer version number in the Package Center is lower because it takes Synology a long time to test and publish new versions.

I am interested to hear that BubbleUPnP is working correctly. This suggests that the problems you are seeing might be related to the control points you are using.
Find all posts by this user
Quote this message in a reply
03-03-2022, 22:51 (This post was last modified: 03-03-2022 22:53 by Alhifi.)
Post: #29
RE: problems with Artist.displayFormat
I have reinstalled the version 2.1-0600, activated the licence again and also installed minimstreamer ... after the rescan with the exact same configuration and of course music files it's still the same, only the composer is shown ...

Then I deinstalled licence and version 2.1-0600 and did a new install with the package which was listed within the DSM package center, it's version 2.0.18-1005 and did not install the minimserver just to check ... but it's still the same, new scan, after restart only composer is shown, no combination of artist and composer (this time again tested with Roku Soundbridge).

So what's different between the old 0.8.5.3, which as you see above works really fine, and the newer 2.x versions ... ?!
Find all posts by this user
Quote this message in a reply
03-03-2022, 23:30
Post: #30
RE: problems with Artist.displayFormat
Thanks for uploading the test file. I will test MinimServer 2.1 tomorrow with this file and your profile using BubbleUPnP and let you know what happens.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)