Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Minimserver unable to deal with accented characters
09-11-2021, 11:03
Post: #1
Minimserver unable to deal with accented characters
Hi, It seems MinimServer cannot deal with music files which have accented characters? for example I am getting lots of these in the log file:
Error: couldn't access file /media/music/original/St�phane Pompougnac 2/Paris Lounge_ Paris By Night (Disc 2)/14 PNC Aux Portes.mp3

Any suggestions?
thanks
Find all posts by this user
Quote this message in a reply
09-11-2021, 11:33 (This post was last modified: 09-11-2021 11:34 by simoncn.)
Post: #2
RE: Minimserver unable to deal with accented characters
MinimServer does support accented characters in filenames if the system running MinimServer is configured correctly.

What device are you using to run MinimServer?

In the MinimServer log, near the start, MinimServer shows the platform default charset. What is shown for this?
Find all posts by this user
Quote this message in a reply
09-11-2021, 12:03
Post: #3
RE: Minimserver unable to deal with accented characters
Thanks Simon, I guess I have missed something in the configuration then.
I'm using an RPI4.
Log file says:
OpenJDK Runtime Environment (build 11.0.12+7-post-Raspbian-2deb10u1)
OpenJDK Server VM (build 11.0.12+7-post-Raspbian-2deb10u1, mixed mode)
Platform default charset is UTF-8
System platform is linux-armhf
Using platform default language English (en-US)
Find all posts by this user
Quote this message in a reply
09-11-2021, 12:23 (This post was last modified: 09-11-2021 12:24 by simoncn.)
Post: #4
RE: Minimserver unable to deal with accented characters
These settings should be OK. Were these files copied from some other system that doesn't use UTF-8 for filenames (for example, Windows)?
Find all posts by this user
Quote this message in a reply
09-11-2021, 12:34 (This post was last modified: 09-11-2021 12:35 by mikej.)
Post: #5
RE: Minimserver unable to deal with accented characters
Hi, yes it is quite possible the files were copied from a system that didn't support UTF-8 - much of my early collection was ripped on a Windows machine many years ago before moving to Linux. I also noticed some odd inconsistencies in the accented characters which i don't understand, so for example in the below log entry, the first accent (in the directory) is displayed correctly, but the one in the file name itself isn't.
Error: couldn't access file /media/music/next/Naná Vasconcelos/Chegada/06 - Nan� Vasconcelos - Sou do Bem.mp3
BTW the files all live on an ext4 USB drive
Find all posts by this user
Quote this message in a reply
09-11-2021, 14:11
Post: #6
RE: Minimserver unable to deal with accented characters
This can be tricky to sort out. The convmv utility can fix this if the encoding is consistent and you know the charset that was used initially to encode the filenames. I don't know what would happen if you use convmv on a file with some accented characters that are valid UTF-8 and other characters that aren't valid.

You could create a new test folder with copies of a few problem files and try using convmv on this test folder to see if it produces valid filenames.
Find all posts by this user
Quote this message in a reply
09-11-2021, 14:22
Post: #7
RE: Minimserver unable to deal with accented characters
Please check if the mp3-files themselves contain any data. I've seen this before and discovered that in my case these kind of files contained 0 bytes.
Find all posts by this user
Quote this message in a reply
09-11-2021, 19:16
Post: #8
RE: Minimserver unable to deal with accented characters
Ah, thanks much for the advice, and good point about zero length files, that was the case in a couple of instances, but there are many more that are valid files. I may try convmv, but i have just tried 'detox', which appears to work easily, although i'm not sure the default settings are doing the correct file name conversion
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)