Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues following synology dsm7 upgrade
24-10-2021, 08:14
Post: #1
Issues following synology dsm7 upgrade
The most immediate thing I noticed was that some of the ratings changed with ‘100, 80 60’ as rating values where they did not exist under dsm6. I was using the latest version of minim2 under dsm6 and I assumed this is the same version available under dsm7.

I’ve had issues before on rating, because I didn’t understand the logic but this has happened without any changes to tagging.

Any ideas?
Thank you
Find all posts by this user
Quote this message in a reply
24-10-2021, 09:37
Post: #2
RE: Issues following synology dsm7 upgrade
The current versions of MinimServer 2 for DSM 6 and DSM 7 (with the latest update 201 applied) are functionally identical.
Find all posts by this user
Quote this message in a reply
25-10-2021, 15:05
Post: #3
RE: Issues following synology dsm7 upgrade
When you updated to DSM 7, it is possible you might have lost some MinimServer configuration settings you had applied to your DSM 6 installation of MinimServer. This might affect the way ratings are presented.
Find all posts by this user
Quote this message in a reply
25-10-2021, 22:15
Post: #4
RE: Issues following synology dsm7 upgrade
(25-10-2021 15:05)simoncn Wrote:  When you updated to DSM 7, it is possible you might have lost some MinimServer configuration settings you had applied to your DSM 6 installation of MinimServer. This might affect the way ratings are presented.


Thank you for the reply.

I did check my config settings and they look the same, but I can't be 100% sure.

However, I have narrowed down what's happening. The issue is only with FLAC files - as always Smile

Some time ago I was using my own tag of 'rate', but then moved to using the standard tag of 'Rating' for both WAV and FLAC.

I use Kid3; the 'Rating' tag is shown as 0-5 stars, however if you use edit against that tag for vorbis files it shows the tag setting as 100 (for 5 stars), 80 (for 4 stars) etc. I only use 5, 4 & 3 stars.

When running on DSM6, I had also changed all the FLAC files from using 'rate' to 'Rating' and that worked fine.
Under DSM7, instead of the FLAC tracks appearing in the grouping for 5, 4 or 3 stars (I variously use the Naim & Linn apps), they now show up in new rating groups labelled 100, 80, 60.

If I add the tag 'rate' and add the value of 5,4,or 3 and delete the value in the 'Rating' tag, this moves the tracks to the appropriate group - 5,4, or 3 stars. In the config file I have 'rate:Rating'.

So the problem is fixed, although I have a few hundred tracks to update and I would prefer to use 'Rating' also for the FLAC files that I want to rate.

Any help to understand what is happening is very welcome, but not particularly important as I know how to get back to correctly rated tracks in the control point apps.

Thanks again, Marinko
Find all posts by this user
Quote this message in a reply
26-10-2021, 10:20
Post: #5
RE: Issues following synology dsm7 upgrade
I checked the previous thread where we discussed this issue. You were using the tagUpdate property to adjust the ratings for your FLAC files. Perhaps the change in behaviour with DSM 7 is related to your tagUpdate setting or the location of your tag update file.
Find all posts by this user
Quote this message in a reply
27-10-2021, 23:20
Post: #6
RE: Issues following synology dsm7 upgrade
(26-10-2021 10:20)simoncn Wrote:  I checked the previous thread where we discussed this issue. You were using the tagUpdate property to adjust the ratings for your FLAC files. Perhaps the change in behaviour with DSM 7 is related to your tagUpdate setting or the location of your tag update file.

Yes of course and on re=installing minimserver it would not have the tag update file. apologies, I had totally forgotten about that.

thank you, Marinko
Find all posts by this user
Quote this message in a reply
28-10-2021, 09:30 (This post was last modified: 28-10-2021 09:30 by simoncn.)
Post: #7
RE: Issues following synology dsm7 upgrade
If you try to start MinimServer with the tagUpdate property set to a filename that doesn't exist, MinimServer doesn't start and produces an error message. Did you remove the tagUpdate setting from your MinimServer configuration when you reinstalled MinimServer after the DSM 7 update?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)