Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Transcoding only multichannel dsf files
19-06-2021, 02:40
Post: #1
Transcoding only multichannel dsf files
Hi Simon,

Would it be possible to restrict dsf:wav24;176 transcoding only to multichannel files, and if so, how?

Thanks,
Jacob
Find all posts by this user
Quote this message in a reply
19-06-2021, 09:48
Post: #2
RE: Transcoding only multichannel dsf files
You can enable selective transcoding by stream type, sample rate and bit depth but not by the number of channels.
Find all posts by this user
Quote this message in a reply
21-06-2021, 11:54
Post: #3
RE: Transcoding only multichannel dsf files
Thank you, Simon. Either way, I am chuffed about discovering the transcoding option and that it works at all. I have a related question, so I will follow-up here.

In my setup I have a universal disc player which correctly recognizes 4- and 5-channel files, both from discs and streaming over home network. My AVR correctly recognizes 5 channel files, but sees 4 channel ones as stereo. This is a common issue, so SACD manufacturers typically add silent channels to multichannel mixes to make the files 5.0 or 5.1. I have some 4.0 SACDs encoded as 5.0 with silent centre channel. I can play them just fine from disc, but when streaming dsf files ripped from them with transcoding to wav, I am getting stereo only. Could it be that transcoding drops silent channels on the fly? If so, is there any way to prevent this from happening.
Find all posts by this user
Quote this message in a reply
21-06-2021, 13:29
Post: #4
RE: Transcoding only multichannel dsf files
MinimStreamer uses FFmpeg for transcoding, so this is controlled by how FFmpeg handles this situation. If FFmpeg is dropping the silent channel by default, there might be an FFmpeg option to preserve the silent channel. You can specify FFmpeg options in MinimStreamer using the stream.options property.

From a quick look at the FFmpeg documentation, it seems the -map_channel option (see this section) might enable you to control this. The description of -map_channel mentions using "-l" to map a muted channel.

I have no experience with multichannel audio and no equipment that can play these files, so it would be difficult for me to try experiments to find the correct -map_channel setting for your situation. I hope this pointer will enable you to make some progress.
Find all posts by this user
Quote this message in a reply
21-06-2021, 15:39
Post: #5
RE: Transcoding only multichannel dsf files
Thank you, Simon. From the examples it seems like it's about muting an existing non-silent channel. Either way, the chances of me succeeding in setting it up are too slim to pursue this, so I will be using flac conversions for these files.
Find all posts by this user
Quote this message in a reply
21-06-2021, 19:35
Post: #6
RE: Transcoding only multichannel dsf files
It is possible the following might work:

ffmpeg -i INPUT -map_channel 0.0.0 -map_channel 0.0.1? -map_channel 0.0.2? -map_channel 0.0.3? -map_channel 0.0.4? OUTPUT

assuming FFmpeg recognizes five channels in the input, or perhaps

ffmpeg -i INPUT -map_channel 0.0.0 -map_channel 0.0.1? -1 -map_channel 0.0.2? -map_channel 0.0.3? OUTPUT


if FFmpeg only recognizes four channels in the input.

In stream.options, these would be:

convOut=-map_channel 0.0.0 -map_channel 0.0.1? -map_channel 0.0.2? -map_channel 0.0.3? -map_channel 0.0.4?

convOut=-map_channel 0.0.0 -map_channel 0.0.1? -map_channel -1 -map_channel 0.0.2? -map_channel 0.0.3?
Find all posts by this user
Quote this message in a reply
21-06-2021, 20:23
Post: #7
RE: Transcoding only multichannel dsf files
Thank you very much, Simon. I understand that this is more of a me-problem with ffmpeg than anything else, and I do appreciate the follow up.

Unfortunately, I am getting an error message: 'convOut' option incorrect for converter; correct highlighted value and retry. I googled around, found your advice on installing ffmpeg from the SynoCommunity, did so, restarted MinimServer, but to no avail.
Find all posts by this user
Quote this message in a reply
21-06-2021, 21:41
Post: #8
RE: Transcoding only multichannel dsf files
After installing the ffmpeg package, you need to set the MinimStreamer stream.converter property to /var/packages/ffmpeg/target/bin/ffmpeg. After you have done this, the settings I posted should work. I have confirmed this on my DS118.
Find all posts by this user
Quote this message in a reply
24-06-2021, 02:05
Post: #9
RE: Transcoding only multichannel dsf files
Thank you, Simon. I got the ffmpeg package to work, but unfortunately the map_channel solution does nothing to solve the issue and adds some white noise.

I suspect that the problem may lie in not respecting the channel layout during transcoding or inability to read it correctly from dsf files. LFE needs to be skipped with 5 channel files. I think it may not be, which would make 5 channel files get transcoded to 4.1 with the side/back right speaker getting omitted. In support of this, 5.1 dsf files with silent centre and LFE get transcoded just fine.

I tried experimenting with the channelmap and pan options, always ending up with a syntax error. I would be grateful if you could please provide some pointers on how to incorporate these in Minimstreamer.
Find all posts by this user
Quote this message in a reply
24-06-2021, 10:20
Post: #10
RE: Transcoding only multichannel dsf files
Please post the option strings that gave a syntax error. Any option string containing a comma needs to be enclosed in double-quote characters, as described in this section.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)