Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update 192 problem?/ Version 2.0.18
07-04-2021, 15:11 (This post was last modified: 22-04-2021 11:42 by MarmiteSandwich.)
Post: #1
Update 192 problem?/ Version 2.0.18
Minimserver 2 crashed updating to 192. Does not start after reboot. Monit has attempted to restart it, but it stops again.

Ras Pi 3B+, Buster

First few lines of crash log look like this:-

Code:
MinimServer crash dump, produced at 20210407-134559.559

Error reading input stream for resource libohNet.so

java.util.zip.ZipException: ZIP_Read: error reading zip file
    at java.util.zip.ZipFile.read(Native Method)
Two other devices with similar setups updated without any problem.
Regards,
Marmite

Server :: RaspberryPi3B+>Minimserver
Control : Android>BubbleUPnP / W10>Upplay / W10>Kazoo / iPhone>Kazoo
Renderer: RaspberryPi3>upmpdcli>mpd>DACMagic
Find all posts by this user
Quote this message in a reply
07-04-2021, 16:52
Post: #2
RE: Update 192 problem?
It looks like there was an error while downloading one of the files in update 192. To download update 192 again, do the following:

1) Open the Packages tab of the Properties page
2) Select minimserver-update-192 and click Remove
3) In the "Other package" field, type minimserver-update-192 and click Install
4) Follow the prompts to install update 192
5) When the package has been installed successfully, click Relaunch
Find all posts by this user
Quote this message in a reply
07-04-2021, 17:00 (This post was last modified: 07-04-2021 18:40 by MarmiteSandwich.)
Post: #3
RE: Update 192 problem?
(07-04-2021 16:52)simoncn Wrote:  It looks like there was an error while downloading one of the files in update 192. To download update 192 again, do the following:

1) Open the Packages tab of the Properties page
2) Select minimserver-update-192 and click Remove
3) In the "Other package" field, type minimserver-update-192 and click Install
4) Follow the prompts to install update 192
5) When the package has been installed successfully, click Relaunch

But doesn't that require MinimServer to be running in order to open Properties? I can't get it to run at all.
EDIT: I managed to do the above via the MS console, and I got:
Code:
>updates
The following updates are available for installation:
minimserver-update-192
>install minimserver-update-192
Installing package 'minimserver-update-192' will remove package 'minimserver-update-191'. Do you want to do this (y/n)?
#y
Package minimserver-update-192 will be activated at the next relaunch
>relaunch
MinimServer 2.0.16 update 192, Copyright (c) 2012-2021 Simon Nash. All rights reserved.
MinimStreamer 2.0.8, Copyright (c) 2012-2021 Simon Nash. All rights reserved.
Error reading input stream for resource libohNet.so (see crash file for stack trace)
MinimServer error: now stopped, use 'restart' or 'exit'
Enter command (? for help):
So, removing 192 and reinstalling it doesn't seem to do the trick.

Server :: RaspberryPi3B+>Minimserver
Control : Android>BubbleUPnP / W10>Upplay / W10>Kazoo / iPhone>Kazoo
Renderer: RaspberryPi3>upmpdcli>mpd>DACMagic
Find all posts by this user
Quote this message in a reply
07-04-2021, 20:59
Post: #4
RE: Update 192 problem?
I have successfully downloaded and installed update 192 on a Pi4 running Buster. I think this means your MinimServer installation on this device has become corrupt in some way.

Please post the output from the following commands:

Code:
ls -l minimserver/tmp/native
ls -l minimserver/libext
ls -lL minimserver/lib
Find all posts by this user
Quote this message in a reply
07-04-2021, 21:08
Post: #5
RE: Update 192 problem?
Code:
root@RasPiFaircross:/home/pi# ls -l minimserver/tmp/native
total 952
-rw-r--r-- 1 root root 974848 Apr  7 18:34 libohNet.so.tmp
root@RasPiFaircross:/home/pi# ls -l minimserver/libext
total 2016
-rw-r--r-- 1 pi   pi    97760 Dec 13 23:03  jflac-1.3-minim-102.zip
-rw-r--r-- 1 pi   pi   564388 Mar 20 15:11  jminim-2.0.137.jar
-rw-r--r-- 1 pi   pi    70804 Mar 20 15:11  minimreader-2.0.109.jar
-rw-r--r-- 1 root root   7716 Apr  7 18:27 'minimscript$-2.0.104.jar'
-rw-r--r-- 1 root root 613557 Apr  7 18:34  minimserver-2.0.150.jar
-rw-r--r-- 1 root root    528 Apr  7 18:34  minimserver-update-192.jmpkg
-rw-r--r-- 1 pi   pi   317667 Apr  7 13:43  minimstreamer-2.0.110.jar
-rw-r--r-- 1 pi   pi     3425 Apr  7 13:43  minimstreamer-2.0.8.jmpkg
-rw-r--r-- 1 root root 376717 Apr  7 18:27  minimui-2.0.125.jar
root@RasPiFaircross:/home/pi# ls -lL minimserver/lib
total 2276
-rw-r--r-- 1 pi pi 474902 Sep 24  2020  jminim-2.0.132.jar
-rw-r--r-- 1 pi pi  12759 Mar 18  2020  minim.jar
-rw-r--r-- 1 pi pi  26118 Apr  4  2020 'minimlaunch$-2.0.103.jar'
-rw-r--r-- 1 pi pi  70783 Jun  6  2020  minimreader-2.0.107.jar
-rw-r--r-- 1 pi pi   7644 Aug  3  2020 'minimscript$-2.0.103.jar'
-rw-r--r-- 1 pi pi 584709 Sep 30  2020  minimserver-2.0.132.jar
-rw-r--r-- 1 pi pi   2963 Sep 24  2020  minimserver-2.0.16.jmpkg
-rw-r--r-- 1 pi pi 360868 Aug 28  2020  minimui-2.0.120.jar
-rw-r--r-- 1 pi pi   4222 Mar 18  2020  mscript.jar
-rw-r--r-- 1 pi pi   3405 May 15  2020  mserver.jar
-rw-r--r-- 1 pi pi 757782 Aug 14  2020 'ohnet(linux-armhf)-1.30.3937.zip'

Server :: RaspberryPi3B+>Minimserver
Control : Android>BubbleUPnP / W10>Upplay / W10>Kazoo / iPhone>Kazoo
Renderer: RaspberryPi3>upmpdcli>mpd>DACMagic
Find all posts by this user
Quote this message in a reply
07-04-2021, 21:30
Post: #6
RE: Update 192 problem?
You have a mixture of files owned by pi and root. When installing or updating MinimServer, you must do everything as the 'pi' user.

To recover from this, use sudo to remove the entire minimserver directory and all its subdirectories, then start again from scratch.
Find all posts by this user
Quote this message in a reply
07-04-2021, 21:34
Post: #7
RE: Update 192 problem?
(07-04-2021 21:30)simoncn Wrote:  You have a mixture of files owned by pi and root. When installing or updating MinimServer, you must do everything as the 'pi' user.

To recover from this, use sudo to remove the entire minimserver directory and all its subdirectories, then start again from scratch.
OK, many thanks. I will reinstall totally. I have had many unexplained glitches with MinimServer (and/or mpd/upmpdcli). Maybe this is why.
Cheers,
Marmite.

Server :: RaspberryPi3B+>Minimserver
Control : Android>BubbleUPnP / W10>Upplay / W10>Kazoo / iPhone>Kazoo
Renderer: RaspberryPi3>upmpdcli>mpd>DACMagic
Find all posts by this user
Quote this message in a reply
07-04-2021, 21:43
Post: #8
RE: Update 192 problem?
Also, you must use the 'pi' user to run MinimServer. If at any stage MinimServer needs root privilege, it will obtain this automatically.
Find all posts by this user
Quote this message in a reply
22-04-2021, 10:40
Post: #9
RE: Update 192 problem?/Update 2.0.18?
(07-04-2021 21:43)simoncn Wrote:  Also, you must use the 'pi' user to run MinimServer. If at any stage MinimServer needs root privilege, it will obtain this automatically.
Many thanks for all of the above advice - Minimserver reinstalled satisfactorily. Used up one more license, but I still have 1 left, so not a problem unless I have to do it repeatedly. However, I have just installed update 193, as advised by MinimWatch and via MinimWatch, which was fine, but I got an advisory to update to MinimServer 2.0.18. Following Properties>Packages in MinimWatch, I don't see this version as being available. Am I missing something?

Server :: RaspberryPi3B+>Minimserver
Control : Android>BubbleUPnP / W10>Upplay / W10>Kazoo / iPhone>Kazoo
Renderer: RaspberryPi3>upmpdcli>mpd>DACMagic
Find all posts by this user
Quote this message in a reply
22-04-2021, 13:37
Post: #10
RE: Update 192 problem?/ Version 2.0.18
2.0.18 is not an online update. It must be downloaded and installed as you have just done for 2.0.16. This should not use an additional license activation and I am not sure why this happened after your previous install.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)