Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Convolution help needed
03-01-2021, 11:12
Post: #1
Convolution help needed
Hi!

Can you pls tell me what i'm doing wrong?

Wanna try a room correction via convolution. Before buying the mike I wanna try to apply sample convolution to my system. For this:
1. In the REW i've made a EQ with just one filter - 1KHz and 12db and exported filter impulse response as wav file. Checked it in Audition - looks correct for me. [Image: 4ZwB2Pl.png]
2. Made an stream.options adjustment with
convOut=-i /volume1/MinimServer/conv/w1k12db.wav -lavfi afir
switch. I'm using Synology DS419+ as an server for minimserver, at first it was telling an error - after reading the forum i've downloaded i686 ffmpeg from https://johnvansickle.com/ffmpeg/ (DS419+ uses Celeron) into opt/bin, extracted only ffmpeg executable and put it into the folder, corrected the stream.converter switch. Tried to play some 16/44 FLACs - it plays but I can't hear the difference, so convolution doesn't work.
3. Tried to read the https://minimstreamer.com/userguide.html - there's a sentence about the trancoding, so I applied flac:wav; switch to the stream.transcode - it doesn't help either.
At this moment my minimserver properties looks like this - [Image: jcDpmCJ.png].

What am i doing wrong?
Find all posts by this user
Quote this message in a reply
03-01-2021, 12:45
Post: #2
RE: Convolution help needed
Your settings look correct. FYI, the recommended value for stream.converter is opt/bin/ffmpeg (without /volume1/MinimServer) but this isn't related to the problem. It you leave the stream.converter field blank, MinimStreamer will check the opt/bin folder and set stream.converter to opt/bin/ffmpeg if it finds an ffmpeg executable there.

After changing your stream.transcode settings, you need to refresh the control point's view of the library. The way to do this depends on which control point you are using. This is because the transcode setting is encoded in the stream URL. If you didn't do this refresh after adding the semicolon to flac:wav, you will still be using flac:wav instead of flac:wav;
Find all posts by this user
Quote this message in a reply
04-01-2021, 11:16
Post: #3
RE: Convolution help needed
Thank you very much! It's working and I suspect that yesterday is worked too, just my sample curve was not so audible Smile Today I used not my ears, but REW RTA - and it clearly shows frequensy response changes Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)