Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Playlist problem - plays each station on list in turn for few seconds
15-02-2020, 21:12
Post: #11
RE: Playlist problem - plays each station on list in turn for few seconds
Thanks for this. The Devialet is having a problem playing the ADTS stream sent by MinimStreamer. I suggest you try transcoding the stream by setting stream.transcode to either aac:L16 or aac:wav. After changing the value of stream.transcode, you should restart MinimServer.
Find all posts by this user
Quote this message in a reply
18-02-2020, 11:14
Post: #12
RE: Playlist problem - plays each station on list in turn for few seconds
(15-02-2020 21:12)simoncn Wrote:  Thanks for this. The Devialet is having a problem playing the ADTS stream sent by MinimStreamer. I suggest you try transcoding the stream by setting stream.transcode to either aac:L16 or aac:wav. After changing the value of stream.transcode, you should restart MinimServer.


Hi simoncn - thanks for the information, aac:wav works fine with the Devialets. L16 doesn't though - but I have a solution that works which is BRILLIANT.

I'm just trying to get this to work with Classic FM which outputs mp3 and I can't get mp3:wav to work - I thought it was working the first time I tried it but now mconnect reports the stream as still mp3 and not wav and only plays a few seconds. Any pointers would be helpful - I'm going to have another look today.

kantblue
Find all posts by this user
Quote this message in a reply
18-02-2020, 11:39
Post: #13
RE: Playlist problem - plays each station on list in turn for few seconds
What is your exact playlist entry for the Classic FM station?
Find all posts by this user
Quote this message in a reply
18-02-2020, 14:25
Post: #14
RE: Playlist problem - plays each station on list in turn for few seconds
(18-02-2020 11:39)simoncn Wrote:  What is your exact playlist entry for the Classic FM station?

It just has the one line:
http://media-ice.musicradio.com:80/ClassicFMMP3

I guessing its not working because some information is missing?
It plays OK for a few seconds and then just stops, its coming into mconnect as:

mp3 16 bit 44.1khz 128kbps

kantblue
Find all posts by this user
Quote this message in a reply
18-02-2020, 15:40 (This post was last modified: 18-02-2020 15:41 by simoncn.)
Post: #15
RE: Playlist problem - plays each station on list in turn for few seconds
Try adding this line before the line you already have:

#EXTINF:-1,[ClassicFM;mp3] Classic FM

You might also need mp3:wav in stream.transcode but it is possible that just doing the above will be enough. You need to do a rescan after changing the playlist contents.
Find all posts by this user
Quote this message in a reply
18-02-2020, 16:05
Post: #16
RE: Playlist problem - plays each station on list in turn for few seconds
(18-02-2020 15:40)simoncn Wrote:  Try adding this line before the line you already have:

#EXTINF:-1,[ClassicFM;mp3] Classic FM

You might also need mp3:wav in stream.transcode but it is possible that just doing the above will be enough. You need to do a rescan after changing the playlist contents.

Hi Simoncn - really pleased to say the above did the trick - all working fine with the mp3:wav setting now so thank you very much!

kantblue
Find all posts by this user
Quote this message in a reply
18-02-2020, 16:37
Post: #17
RE: Playlist problem - plays each station on list in turn for few seconds
The problem might be caused by embedded "Icy" metadata in the stream. This contains information about what song is playing now and occurs every few seconds. Some players don't expect this, so they think the stream is corrupt and stop playing the stream after a few seconds when they encounter the first or second chunk of metadata.

When you add the extra line (with or without transcoding), MinimStreamer filters the stream and removes the "Icy" metadata, so the player is happy.
Find all posts by this user
Quote this message in a reply
18-02-2020, 19:02
Post: #18
RE: Playlist problem - plays each station on list in turn for few seconds
(18-02-2020 16:37)simoncn Wrote:  The problem might be caused by embedded "Icy" metadata in the stream. This contains information about what song is playing now and occurs every few seconds. Some players don't expect this, so they think the stream is corrupt and stop playing the stream after a few seconds when they encounter the first or second chunk of metadata.

When you add the extra line (with or without transcoding), MinimStreamer filters the stream and removes the "Icy" metadata, so the player is happy.
y

Hi Simoncn - thanks for the information.

For your information - without the transcoding mp3:wav line the Devialet Phantom only plays a few seconds and then moves on to the next playlist item. Not sure how this helps but thought it might be useful information for any other Minimstreamer/Devialet users.

kantblue
Find all posts by this user
Quote this message in a reply
18-02-2020, 22:25
Post: #19
RE: Playlist problem - plays each station on list in turn for few seconds
Thanks for confirming this. I think this means the problem isn't "Icy" metadata but the lack of a fixed length for the stream in the original MP3 version.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)