Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Questions on Groups
05-02-2020, 11:13
Post: #1
Questions on Groups
I've just started with minimServer and like it. Running on a QNAP NAS with Naim app as control point.

As suggested, I've put movements from individual works into groups and this seems to work well for the most part. However, I've noticed that sometimes the groups are presented as though they are tracks, with no option to drill down to the movements/actual tracks. This consistently happens when drilling down from the albums folder at the top level, but it happens elsewhere as well. Is this intended behaviour? It doesn't seem right.

Also, what is the best way of playing a group in its entirety? The only way I've found to do this is to go to the first movement and choose to 'play from this track'. If I try to play from group level the tracks are queued in the wrong order with the first track at the end, thus playing just that track.

I appreciate both these may be problems with the Naim app, but I wondered if they were known issues with any workarounds? Many thanks.
Find all posts by this user
Quote this message in a reply
05-02-2020, 13:03 (This post was last modified: 05-02-2020 13:04 by simoncn.)
Post: #2
RE: Questions on Groups
Welcome to the MinimServer forum!

I am not seeing these problems with the Naim app.

From the top-level list of albums, I select an album containing Beethoven Symphonies 5 and 7. This shows two items, one for Symphony 5 and one for Symphony 7. Touching Symphony 5 opens a window showing all its movements and likewise for Symphony 7.

To play Symphony 5 (all movements), I touch the 3-dots symbol for Symphony 5 and select Play. A message appears at the bottom of the screen saying "4 tracks were added". The tracks are queued in the correct order.

To play all tracks of the album, I touch the 3-dots symbol for the album and select Play. A message appears at the bottom of the screen saying "4 tracks were added" followed by another message saying "8 tracks were added". Looking at the playing queue shows that all 8 tracks of the album have been enqueued in the correct order.

Do you by any chance have A-Z enabled in the Naim app? This might be the reason why tracks are being enqueued in the wrong order. The A-Z setting is hard to find. There are instructions in this post. You need to disable A-Z for MinimServer to work properly.
Find all posts by this user
Quote this message in a reply
05-02-2020, 15:21
Post: #3
RE: Questions on Groups
Thanks Simon. I had A-Z enabled but disabling it has not helped.

Here are some screenshots. I have an album of 4 Bach violin concertos. Here it is under the top-level list of composers:
   
Here it is under the top-level list of albums. The groups are listed as tracks:
   

From the first screen above, tapping on the 3 dots by the 1st concerto gives:
   
And then tapping on 'Play' results in a queue like this:
   
The 1st movement is playing but it's queued after the other 2 movements, which never get played.
Find all posts by this user
Quote this message in a reply
05-02-2020, 22:02
Post: #4
RE: Questions on Groups
(05-02-2020 15:21)Michael Wrote:  Thanks Simon. I had A-Z enabled but disabling it has not helped.

Here are some screenshots. I have an album of 4 Bach violin concertos. Here it is under the top-level list of composers:

This looks like an iPhone. I use the Naim app on an iPad, so the screen layout is a bit different. I don't know if this accounts for the other differences you are seeing.

Quote:Here it is under the top-level list of albums. The groups are listed as tracks:

I am also seeing the groups looking like tracks. Tapping on any of the groups opens the actual tracks. Is this the same for you and are the tracks in the correct order?

Quote:From the first screen above, tapping on the 3 dots by the 1st concerto gives:

I see a pop-up rather than a new page but it has the same selections.

Quote:And then tapping on 'Play' results in a queue like this:

The 1st movement is playing but it's queued after the other 2 movements, which never get played.

I have tried this on a number of groups and they are always queued in the correct order.
Find all posts by this user
Quote this message in a reply
06-02-2020, 17:56
Post: #5
RE: Questions on Groups
The screenshots are from a Pixel 4, so Android. I experienced similar problems with an Android tablet.

However, I've solved the first issue (groups listed as tracks). I think it was caused by me editing the music files and confusing the app. If I clear down and reset the app it goes away.

The queuing problem remains, but I'm struggling to see any consistency to it. Sometimes it works ok, mostly it doesn't. It's not just groups either, I've seen it go wrong when playing a whole album (if the album doesn't contain groups - I don't know if that's relevant).

It seems a bit like it starts playing the 1st track, then for some reason queues the other tracks ahead of it (so they don't get played). The 'tracks added' count is always 1 less than the number of tracks in the group/album.

I guess this may be an issue with the Android app. I'll continue to monitor to see if I can discern any patterns.
Find all posts by this user
Quote this message in a reply
07-02-2020, 10:10
Post: #6
RE: Questions on Groups
I have installed the Naim app on my Android phone (Samsung Galaxy A5) to try this. Unlike when I do this on the iPad, the number of tracks enqueued is one less than the number expected (same as you are seeing) but all tracks are added and appear in the correct order. I have tried this with an album containing multiple groups as well as with individual groups and it works correctly in both cases.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)