Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
minimserver start error after update 130
22-11-2019, 18:05
Post: #1
minimserver start error after update 130
Hi,
I run minimserver on my synology D710+ since years without problems.
But after the last update 130 minimserver stopped with the following error message:

Minimserver start error: java.lang.UnsupportedClassVersionError: com/minimserver/ServerLauncher : Unsupported major.minor version 52.0

Attached you find the minimserver-crash-report and the current versions on my DS710+.

Any ideas?

For a quick fix: Could you provide me an installation package without update 130?

Many thanks
Marc


Attached File(s) Thumbnail(s)
   

.log  minimserver-crash-20191120-184705.log (Size: 4.02 KB / Downloads: 2)
Find all posts by this user
Quote this message in a reply
22-11-2019, 21:11
Post: #2
RE: minimserver start error after update 130
Thanks for letting me know about this.

The quick fix is update 131 (now available). Smile

Update 130 was unintentionally compiled using Java 8. Java 8 was released in 2014 and has replaced Java 7 on almost all platforms, including Synology DSM 6.0 and later. As the DS710+ is limited to DSM 5.2, it is also limited to Java 7 and this is why you are getting this error with update 130. Update 131 has been compiled using Java 7 and should work correctly on the DS710+ and all other supported platforms.
Find all posts by this user
Quote this message in a reply
03-12-2019, 19:46
Post: #3
RE: minimserver start error after update 130
Hello Simon,

My minimserver failed with the same symptom as reported in this thread, but it happened on november 20 after 0.8.5.3 update 129.

The exception is "java.lang.UnsupportedClassVersionError: com/minimserver/ServerLauncher : Unsupported major.minor version 52.0"

I'm running a linuxppc version of minimserver on a WD my book live; please could you tell me where to find update 131 to try the fix?

Thanks and Regards, Tim
Find all posts by this user
Quote this message in a reply
03-12-2019, 21:44
Post: #4
RE: minimserver start error after update 130
Hello Tim,
I think this must have been triggered by update 130, which was released on 19th November. Update 129 was released on 8th June and would have been compiled using Java 7.

Update 131 should install automatically when you reboot the machine unless you have disabled automatic updates by setting the MinimServer .autoUpdate property to false. Alternatively, you can apply the update from MinimWatch by selecting About, then clicking the Show updates button.

This should get you going for now but it is likely that at some point in the fairly near future, MinimServer will require Java 8. There is a very early version of Oracle Java SE 8 Embedded that supports PowerPC, downloadable from this page. Are you able to try installing this to see whether it works with your hardware?

Best regards,
Simon
Find all posts by this user
Quote this message in a reply
04-12-2019, 14:09
Post: #5
RE: minimserver start error after update 130
Hello Simon,

The autoupdate wasn't working on reboot or from minimwatch (because minimserver crashed at startup?). Anyway, I did install Java 8 [ppc classic floating point ejdk-8u6-fcs-b23-linux-ppc-12_jun_2014.tar.gz] and edited minimserver/etc/minimstart.conf to contain
java=/shares/Public/Java/ejdk1.8.0_06/linux_ppc/jre/bin/java

Then, all is well:
MyBookLive:/shares/Minim/MinimM4a/minimserver# bin/startc
MinimServer 0.8.5.3 update 130, Copyright © 2012-2019 Simon Nash. All rights reserved.
autoUpdate: installed package 'minimserver-0.8-update-131' replacing 'minimserver-0.8-update-130'
Enter command (? for help):
autoUpdate: relaunching
>MinimServer 0.8.5.3 update 131, Copyright © 2012-2019 Simon Nash. All rights reserved.
starting MinimServer[m4a]
Enter command (? for help):
MinimServer[m4a] is running
>


So that works for update 130 (I must have been confused by log messages earlier in the thread) and update 131

Smile Many Thanks. Enjoy your Christmas. Tim.
Find all posts by this user
Quote this message in a reply
04-12-2019, 14:16
Post: #6
RE: minimserver start error after update 130
PS & BTW:

The WD my book live seems to use the AppliedMicro APM82181 processor and has a double precision Floating Point Unit, but I took the less adventurous path (for the moment).

Regards, Tim.
Find all posts by this user
Quote this message in a reply
06-12-2019, 12:34 (This post was last modified: 06-12-2019 12:38 by simoncn.)
Post: #7
RE: minimserver start error after update 130
Thanks very much for confirming that this is working. From my best understanding of the various models of PowerPC processors, I think you are using the correct ejdk download and the other one would not work.

The "catch 22" situation of installing an update that produces an error before the autoupdate stage of startup is unfortunate. I am glad you were able to find a fairly simple workaround. The other option would be to uninstall MinimServer and then reinstall. Uninstalling would remove the faulty update 130 and reinstalling would install the fixed update 131.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)