Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Log Showing Some Convolution File Used
30-07-2019, 13:34
Post: #1
Log Showing Some Convolution File Used
Minor bug? Log set to verbose, shows convolution files loaded:
Convolution file for sample rate 44100 is /media/music/pa/convolve/L_44_R_44.wav
Convolution file for sample rate 176400 is /media/music/pa/convolve/L_176_R_176.wav
Convolution file for sample rate 48000 is /media/music/pa/convolve/L_48_R_48.wav
Convolution file for sample rate 88200 is /media/music/pa/convolve/L_88_R_88.wav
Convolution file for sample rate 192000 is /media/music/pa/convolve/L_192_R_192.wav
Convolution file for sample rate 96000 is /media/music/pa/convolve/L_96_R_96.wav

When playing track, will show convolution file used for 24/176.4 and 24/196 but not the others. Does not show 16/44.1, 24/96. Did not test 24/48, 24/88.2

Using convolution file /media/music/pa/convolve/L_192_R_192.wav for sample rate 192000
Using convolution file /media/music/pa/convolve/L_176_R_176.wav for sample rate 176400
Find all posts by this user
Quote this message in a reply
30-07-2019, 17:55
Post: #2
RE: Log Showing Some Convolution File Used
When playing a track, only the convolution file needed to play the track is used. What are your settings for stream.transcode and stream.options?
Find all posts by this user
Quote this message in a reply
30-07-2019, 23:16
Post: #3
RE: Log Showing Some Convolution File Used
stream.options: convOut= -i /media/music/pa/convolve/L_*.wav -lavfi afir=gtype=gn
stream.transcode: flac:wav,wav:wav24

When I switch from tracks with different bit rates, the log should be indicating the new convolution file being used. It only shows the 192 and 176.4 messages. No message for 44.1, 96 tracks.
Find all posts by this user
Quote this message in a reply
31-07-2019, 08:37 (This post was last modified: 31-07-2019 08:59 by simoncn.)
Post: #4
RE: Log Showing Some Convolution File Used
This setting for stream.transcode does not apply convolution to FLAC files, only to WAV files. To apply convolution to FLAC files as well, you need

stream.transcode: flac:wav;,wav:wav24

The semicolon after flac:wav forces the use of FFmpeg for transcoding instead of using MinimStreamer's internal converter.
Find all posts by this user
Quote this message in a reply
31-07-2019, 13:09
Post: #5
RE: Log Showing Some Convolution File Used
Thank you. That fixed it...
Find all posts by this user
Quote this message in a reply
31-07-2019, 22:40
Post: #6
RE: Log Showing Some Convolution File Used
(31-07-2019 08:37)simoncn Wrote:  This setting for stream.transcode does not apply convolution to FLAC files, only to WAV files. To apply convolution to FLAC files as well, you need

stream.transcode: flac:wav;,wav:wav24

The semicolon after flac:wav forces the use of FFmpeg for transcoding instead of using MinimStreamer's internal converter.
Suggest adding the above to the documentation?
Find all posts by this user
Quote this message in a reply
31-07-2019, 23:08
Post: #7
RE: Log Showing Some Convolution File Used
(31-07-2019 22:40)Snoopy08 Wrote:  
(31-07-2019 08:37)simoncn Wrote:  This setting for stream.transcode does not apply convolution to FLAC files, only to WAV files. To apply convolution to FLAC files as well, you need

stream.transcode: flac:wav;,wav:wav24

The semicolon after flac:wav forces the use of FFmpeg for transcoding instead of using MinimStreamer's internal converter.
Suggest adding the above to the documentation?

You mean this documentation?


Convolution Filtering section

To use convolution filtering, the stream.transcode property must be set to a value that transcodes the audio file or network stream using FFmpeg as the stream converter. See the Transcoding section for details of how to do this.

Transcoding section

Input type

Flac
FLAC files. Valid for local files served by MinimServer (.flac) only. The output type must be L16, L24, wav, wav24 or wav16. By default, a stream converter program is not required. If you want MinimStreamer to perform transcoding using a stream converter program, you can specify this by adding a semicolon after the output type.


Output type

wav
PCM audio encoded in WAV format, preserving the original sample bit depth. Valid for local files and network streams. If the input type isn't flac or if the output type is followed by a semicolon, a stream converter program is required.
If the input type is dsf, the output sample bit depth is 32 by default. You can override this default value by specifying wav16 or wav24 for the output type.
Find all posts by this user
Quote this message in a reply
31-07-2019, 23:58
Post: #8
RE: Log Showing Some Convolution File Used
(31-07-2019 23:08)Alandbush Wrote:  
(31-07-2019 22:40)Snoopy08 Wrote:  
(31-07-2019 08:37)simoncn Wrote:  This setting for stream.transcode does not apply convolution to FLAC files, only to WAV files. To apply convolution to FLAC files as well, you need

stream.transcode: flac:wav;,wav:wav24

The semicolon after flac:wav forces the use of FFmpeg for transcoding instead of using MinimStreamer's internal converter.
Suggest adding the above to the documentation?

You mean this documentation?


Convolution Filtering section

To use convolution filtering, the stream.transcode property must be set to a value that transcodes the audio file or network stream using FFmpeg as the stream converter. See the Transcoding section for details of how to do this.

Transcoding section

Input type

Flac
FLAC files. Valid for local files served by MinimServer (.flac) only. The output type must be L16, L24, wav, wav24 or wav16. By default, a stream converter program is not required. If you want MinimStreamer to perform transcoding using a stream converter program, you can specify this by adding a semicolon after the output type.


Output type

wav
PCM audio encoded in WAV format, preserving the original sample bit depth. Valid for local files and network streams. If the input type isn't flac or if the output type is followed by a semicolon, a stream converter program is required.
If the input type is dsf, the output sample bit depth is 32 by default. You can override this default value by specifying wav16 or wav24 for the output type.
Thank you. I was suggesting adding something to the Convolution section because it is not obvious when reading there.
Find all posts by this user
Quote this message in a reply
01-08-2019, 11:45 (This post was last modified: 01-08-2019 11:45 by simoncn.)
Post: #9
RE: Log Showing Some Convolution File Used
I have added a Note: in the Convolution section with a specific warning about this issue.
Find all posts by this user
Quote this message in a reply
01-08-2019, 11:58
Post: #10
RE: Log Showing Some Convolution File Used
Thank you...
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)