Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Room correction with convolution per sample rate
08-02-2019, 06:41
Post: #51
RE: Room correction with convolution per sample rate
Wow! Thanks for generating a custom ffmpeg build for the Melco.

I followed your instruction and:
  • update MinimServer to minimserver-0.8.5.4, minimserver-0.8-update-128
  • updated MinimStreamer to minimstreamer-0.7.12
  • installed the package ffmpeg-4.1-melco-0.1 package

After restarting MinimServer," System:stream.converter" had the value "libext/*/ffmpeg"

I tested the system with:

Quote:stream.options:
convOut=-i /mnt/disk1/share/MinimServer/convolution/Cor1S*.wav -lavfi afir=gtype=gn

stream.transcode:
flac:wav;, dsf:wav24;352

I tested all sample rates from 16/44.1 to DSDx2. I was curious if the custom ffmpeg for the Melco was more efficient, and could handle 24/352, 24/384, DSD, or DSDx2. All sample rates up to 24/196 worked fine. Unfortunately higher sample rates still had stutter, so no change there.

I ended up with:

Quote:stream.transcode:
flac(<352):wav;

and all seems to work well with the Melco server. No convolution is performed on sample rates above 24/196 (or DSD).
Find all posts by this user
Quote this message in a reply
08-02-2019, 09:56
Post: #52
RE: Room correction with convolution per sample rate
Thanks very much for trying this. The custom build is subsetted in functionality (for example, the video encoders and decoders are removed) but there are no changes that would make it more efficient than a full build.
Find all posts by this user
Quote this message in a reply
12-12-2022, 20:40
Post: #53
RE: Room correction with convolution per sample rate
Good evening
Since my question is related to the topic, I add it here to this old thread. I have Minimserver installed on my Melco N100, and I wish to create a profile with convolution filters. These are test filters, if they work I will purchase the real filters for the Raal Sr1a headphone. I run the latest version of Minimserver and have an active full license. Installed packages are: ffmpeg-4.1-melco-2.0, minimjre-14.0.1, minimserver-2.1, minimserver-update-220, minimstreamer-2.0.9
My set of convolution filters is stored on the Melco. When I access the files from my Mac, the directories are n-36a3/Logs/MinimServer/convolution/HF_Rolloff_65536_taps*.wav with
* referring to the different files in this folder for the different frequencies (441, 882, 96 etc.)
Now, I understand that i create a new profile, go to Properties, System and in the stream.options I enter:
convOut=-i /mnt/disk1/share/Logs/MinimServer/convolution/HF_Rolloff_65536_taps*.wav-lavfi afir=gtype=gn
But the entry is not accepted.
Something seems wrong. I would appreciate your help, Simon. Thank you so muzch.
Find all posts by this user
Quote this message in a reply
12-12-2022, 20:59
Post: #54
RE: Room correction with convolution per sample rate
The Logs shared folder is not intended for storing files created by the user. Can you put these files in the /mnt/disk1/share (Internal) shared folder instead?
Find all posts by this user
Quote this message in a reply
08-04-2024, 19:25 (This post was last modified: 08-04-2024 19:35 by tony22.)
Post: #55
RE: Room correction with convolution per sample rate
I'm resurrecting this thread as I'm having problems. I read through all the posts, but when I enter my stream.options, which is

convOut=-i /share/MinimServer/conv/Apr7EQs*.wav -lavfi afir=gtype=gn

I get this error

'convOut' option incorrect for converter; correct highlighted value and retry

My absolute path is correct, and there is no misspelling anywhere. But I cannot figure out what is incorrect. I'm running the latest MinimServer and MinimStreamer on my Qnap TS-459ProPlus NAS. I installed ffmpeg last November from the official ffmpeg site. Is it possible it's the wrong one?
Find all posts by this user
Quote this message in a reply
08-04-2024, 19:52
Post: #56
RE: Room correction with convolution per sample rate
The current instructions for installing FFmpeg on a QNAP NAS are in Note 2 of this section. Did you install the MyQNAP package? Also, what is your setting for the stream.converter property?
Find all posts by this user
Quote this message in a reply
08-04-2024, 20:01
Post: #57
RE: Room correction with convolution per sample rate
(08-04-2024 19:52)simoncn Wrote:  The current instructions for installing FFmpeg on a QNAP NAS are in Note 2 of this section. Did you install the MyQNAP package? Also, what is your setting for the stream.converter property?

Thank you Simon! That was it. I had the wrong ffmpeg.
Find all posts by this user
Quote this message in a reply
08-04-2024, 20:27
Post: #58
RE: Room correction with convolution per sample rate
(08-04-2024 19:52)simoncn Wrote:  The current instructions for installing FFmpeg on a QNAP NAS are in Note 2 of this section. Did you install the MyQNAP package? Also, what is your setting for the stream.converter property?

And... apparently now there's a new problem.

stream.converter is /opt/ffmpeg/ffmpeg, which by all indications has been accepted as a valid path. My app widget on Qnap says it is installed. When I restarted my NAS I get this on the MinimServer page

MinimStreamer: converter not installed

I installed the x86 version which is expected to be correct for my NAS, but using Putty and checking, it seems it is not running.
Find all posts by this user
Quote this message in a reply
08-04-2024, 21:53 (This post was last modified: 08-04-2024 21:54 by simoncn.)
Post: #59
RE: Room correction with convolution per sample rate
To check you have the correct version of ffmpeg in the correct location, login to the NAS using SSH (use the putty program if you have a Windows PC) and enter these commands:

Code:
ls -l /opt/ffmpeg
/opt/ffmpeg/ffmpeg

What is the output from these command?
Find all posts by this user
Quote this message in a reply
09-04-2024, 00:26
Post: #60
RE: Room correction with convolution per sample rate
(08-04-2024 21:53)simoncn Wrote:  To check you have the correct version of ffmpeg in the correct location, login to the NAS using SSH (use the putty program if you have a Windows PC) and enter these commands:

Code:
ls -l /opt/ffmpeg
/opt/ffmpeg/ffmpeg

What is the output from these command?

Oh, it shows ffmpeg in the /opt/ffmpeg folder, but when I do

ps -ef|grep ffmpeg

it is not shown as running
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)