Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
convolution with acourate fir filter
09-12-2018, 10:28
Post: #31
RE: convolution with acourate fir filter
Please don't post the same question to multiple threads. This makes the discussion much harder to follow. I have deleted your duplicate post.
Find all posts by this user
Quote this message in a reply
09-12-2018, 10:36
Post: #32
RE: convolution with acourate fir filter
I am very sorry Dodgy Had too many windows open.

While browsing through the QNAP using WinSCP I have figured out that

/share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg

seems to be the newly installed 4.x FFMPEG version.

NOW, it saves without an error, BUT it still doesn't convolute the file Sad
Find all posts by this user
Quote this message in a reply
09-12-2018, 13:52
Post: #33
RE: convolution with acourate fir filter
(09-12-2018 10:36)SMSWAP Wrote:  /share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg

seems to be the newly installed 4.x FFMPEG version.

NOW, it saves without an error, BUT it still doesn't convolute the file Sad

This is how stream.options currently looks like:
convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Echo44.wav

You can definitively confirm the version of ffmpeg being invoked by use of the following command.

-version

Your convout command should also be suffixed with the following to invoke convolution.

-lavfi afir

You might find this Ffmpeg documentation page useful as well.

Having said all of that, convolution can have a subtle effect on the audio file and you have not hinted at the type of convolution that you are applying. Perhaps, to remove any doubt, you could generate a convolution filter with an obvious effect, e.g. extreme high pass or low pass.
Find all posts by this user
Quote this message in a reply
09-12-2018, 14:42
Post: #34
RE: convolution with acourate fir filter
(09-12-2018 13:52)Alandbush Wrote:  
(09-12-2018 10:36)SMSWAP Wrote:  /share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg

seems to be the newly installed 4.x FFMPEG version.

NOW, it saves without an error, BUT it still doesn't convolute the file Sad

This is how stream.options currently looks like:
convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Echo44.wav

You can definitively confirm the version of ffmpeg being invoked by use of the following command.

-version

Your convout command should also be suffixed with the following to invoke convolution.

-lavfi afir

You might find this Ffmpeg documentation page useful as well.

Having said all of that, convolution can have a subtle effect on the audio file and you have not hinted at the type of convolution that you are applying. Perhaps, to remove any doubt, you could generate a convolution filter with an obvious effect, e.g. extreme high pass or low pass.

Hi Alan,

I am currently using the following command:

convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Echo44.wav -lavfi afir

So in that respect this should work as expected. The version is confirmed, but maybe the QKPG one doesn't work properly. However, I am lost finding the right FFMPEG to install manually in the default folder /mnt/ext/opt/ffmpeg/usr/bin/ffmpeg.

The should actually introduce a very audible echo, which it doesn't... You are right, I could try it with a more drastic example like high pass or low pass.
Find all posts by this user
Quote this message in a reply
09-12-2018, 15:07
Post: #35
RE: convolution with acourate fir filter
To add:

[~] # /share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg -version
ffmpeg version 4.1-static https://johnvansickle.com/ffmpeg/ Copyright © 2000-2018 the FFmpeg developers

That should do it...
Find all posts by this user
Quote this message in a reply
09-12-2018, 15:17
Post: #36
RE: convolution with acourate fir filter
What is your stream.transcode setting? The convOut setting is used only if transcoding is enabled in stream.transcode.
Find all posts by this user
Quote this message in a reply
09-12-2018, 15:30 (This post was last modified: 09-12-2018 15:30 by simoncn.)
Post: #37
RE: convolution with acourate fir filter
(09-12-2018 08:10)SMSWAP Wrote:  in the meantime, I have been able to install the ffmpeg_4.1.0_x86.qpkg and have rebooted the NAS.

For your NAS and the current version of QTS, you should use ffmpeg_4.1.0_x86_64.qpkg. This will give better performance but won't affect whether or not convolution is happening (see my previous post).
Find all posts by this user
Quote this message in a reply
09-12-2018, 15:34
Post: #38
RE: convolution with acourate fir filter
(09-12-2018 14:42)SMSWAP Wrote:  However, I am lost finding the right FFMPEG to install manually in the default folder /mnt/ext/opt/ffmpeg/usr/bin/ffmpeg.

It isn't a good idea to overwrite the default version that QTS has installed in this location. Instead, you should use the stream.converter property to specify the correct path to the .qpkg version that you have installed.
Find all posts by this user
Quote this message in a reply
09-12-2018, 15:44
Post: #39
RE: convolution with acourate fir filter
(09-12-2018 15:34)simoncn Wrote:  
(09-12-2018 14:42)SMSWAP Wrote:  However, I am lost finding the right FFMPEG to install manually in the default folder /mnt/ext/opt/ffmpeg/usr/bin/ffmpeg.

It isn't a good idea to overwrite the default version that QTS has installed in this location. Instead, you should use the stream.converter property to specify the correct path to the .qpkg version that you have installed.

This is why I am using this one in stream.converter:

/share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg

It is version 4.1 of FFMEPG
Find all posts by this user
Quote this message in a reply
09-12-2018, 16:56
Post: #40
RE: convolution with acourate fir filter
(09-12-2018 15:07)SMSWAP Wrote:  To add:

[~] # /share/CACHEDEV1_DATA/.qpkg/ffmpeg/ffmpeg -version
ffmpeg version 4.1-static https://johnvansickle.com/ffmpeg/ Copyright © 2000-2018 the FFmpeg developers

That should do it...

Excellent.

However, I had meant you to use the -version option as part of the convout command.

This would prove that the stream.options, stream.converter and stream.transcode parameter values are correct by invoking the convout command by displaying the version of ffmpeg being invoked in the Minimserver log file.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)