Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
convolution with acourate fir filter
20-06-2018, 21:52
Post: #11
RE: convolution with acourate fir filter
(20-06-2018 07:27)simoncn Wrote:  This feature can be used only when FFmpeg transcoding is in effect and this is supported only for the filetypes shown as input types in this section. Because wav isn't one of these input types, you can't use this feature with music stored in .wav files. You can use it for any other filetype that can be transcoded to wav.

Simon, please accept my apologies for my earlier very poorly worded reply.
I’ll attempt to be succinct with this one.

Are you able to provide a way to invoke ffmpeg with a wav file?
Find all posts by this user
Quote this message in a reply
20-06-2018, 22:03
Post: #12
RE: convolution with acourate fir filter
I understood your question but my reply was perhaps unclear. This is not possible in the current version of MinimStreamer.
Find all posts by this user
Quote this message in a reply
08-11-2018, 18:22
Post: #13
RE: convolution with acourate fir filter
Hi Simon,

is it possible to use a .dbl file instead of a .wav as filter-file?

Thanks

Claas
Find all posts by this user
Quote this message in a reply
08-11-2018, 18:27
Post: #14
RE: convolution with acourate fir filter
I don't know what a .dbl file is. The best way to find out if it works is to try it.
Find all posts by this user
Quote this message in a reply
08-11-2018, 18:35
Post: #15
RE: convolution with acourate fir filter
(08-11-2018 18:27)simoncn Wrote:  I don't know what a .dbl file is. The best way to find out if it works is to try it.

A .dbl file is a filter file used by Brutefir as far as I understood.

I tried this one in stream.options
Code:
convOut=-i /volume1/music/FHR-44.1.dbl -lavfi afir

and got an error
convOut incorrect for converter
or sth. like this.
Find all posts by this user
Quote this message in a reply
09-11-2018, 15:10
Post: #16
RE: convolution with acourate fir filter
Hi Simon,

I could convert the dbl to wav using Sox.
If I now enter

Quote:convOut=-i /volume1/music/FHR-44.1.wav -lavfi afir

into stream.options I still get the error message.
Is there a special location (the one I'm using is on my Synology where MinimServer is running) where the wav filter files need to be saved to make them accessible to MinimStreamer?

Thanks for a hint

Claas
Find all posts by this user
Quote this message in a reply
09-11-2018, 18:16
Post: #17
RE: convolution with acourate fir filter
You might be using a version of FFmpeg that doesn't support these convOut options. As stated in post #8, you must be using FFmpeg 3.4.0 or later.
Find all posts by this user
Quote this message in a reply
09-11-2018, 18:32
Post: #18
RE: convolution with acourate fir filter
(09-11-2018 18:16)simoncn Wrote:  You might be using a version of FFmpeg that doesn't support these convOut options. As stated in post #8, you must be using FFmpeg 3.4.0 or later.

Silly me. I just expected that the newest DSM has it.
Sorry having bothered you. I installed FFmpeg from the Synology Community now, changed the path in MinimWatch and do not get an error anymore.

Do I need to restart the server after having changed the stream.properties?
Because I don't hear a difference even if I wait 40 seconds (AFAIK that's the RAM cache of a Linn streamer?)

How can I control if the filter is really applied?
Anything I can search for in the Trace-level log?
Find all posts by this user
Quote this message in a reply
09-11-2018, 22:57
Post: #19
RE: convolution with acourate fir filter
Perhaps the file you are playing isn't being transcoded by FFmpeg. What type of file is this and what setting do you have for the stream.transcode property?
Find all posts by this user
Quote this message in a reply
10-11-2018, 10:40
Post: #20
RE: convolution with acourate fir filter
(09-11-2018 22:57)simoncn Wrote:  Perhaps the file you are playing isn't being transcoded by FFmpeg. What type of file is this and what setting do you have for the stream.transcode property?

It's a mono filter as wav file.
Someone pointed me to the fact that it should only be applied to files being encoded in M/S format (mid-side). But I'm unsure if FFmpeg can detect this and thus doesn't do anything.
Maybe I'll try a different (DRC) filter first.

My settings are:
alac:wav, dsf:wav24
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)