Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MinimServer for QNAP
04-04-2012, 05:17
Post: #1
MinimServer for QNAP
Simon
You may remember that you tried to help me, over on the Linn Forum, install 0.31 via the command line.

I haven't tried to load the latest version yet so I may well be needing more help but I thought that I would just thank you for your previous efforts.

Despite your best efforts, and time spent in front of an online Linux tutorial, I never got 0.31 to work although I now know a whole lot more than I did about the "command line", SSH and Linux.

As a matter of interest I found that the version of MinimServer that I had apparently installed and enabled on my TS 219 PII never showed any sign of life on the command line. It never featured in the running applications despite the fact that it would dutifully change colour when enabled and disabled. This probably explains why MinimWatch seemed completely passive.

Anyway hopefully your newest effort will solve all that for me! I will let you know.
Thanks a million.

Craig
Find all posts by this user
Quote this message in a reply
04-04-2012, 13:14 (This post was last modified: 04-04-2012 13:21 by Craiga.)
Post: #2
RE: MinimServer for QNAP
Simon
It's installed and working!!
Looks great.
Many thanks

Craig
simon
Just thought for your installation instructions.
One of the many problems that had me stopped in my tracks was that when downloading the archive file from Oracle. Safari both downloaded and unzipped the file.

The solution I discovered was to simply rename the file extension from .tar to .tar.gz.
May save others much frustration.

Regards
Craig
Find all posts by this user
Quote this message in a reply
04-04-2012, 15:02
Post: #3
RE: MinimServer for QNAP
(04-04-2012 13:14)Craiga Wrote:  Simon
It's installed and working!!
Looks great.
Many thanks

Craig

I'm very pleased to hear this. I think it's possible for the QPKG icon state (green vs. gray) to get out of sync with the MinimServer running status, and the simplest solution if this happens is to disable/enable the QPKG or stop and restart the QNAP. You should never need to use the command line.

Quote:simon
Just thought for your installation instructions.
One of the many problems that had me stopped in my tracks was that when downloading the archive file from Oracle. Safari both downloaded and unzipped the file.

The solution I discovered was to simply rename the file extension from .tar to .tar.gz.
May save others much frustration.

Regards
Craig

Do you mean that you left the file in .tar format (as unpacked by Safari) and copied it to the Public share using the name .tar.gz, but still in .tar format?

After some experimentation, I found that a "right" click in Safari (two-fingered on my MacBook) downloads the file correctly as .tar.gz. I'll recommend this on the MinimServer website, as it seems simpler.
Find all posts by this user
Quote this message in a reply
04-04-2012, 22:50
Post: #4
RE: MinimServer for QNAP
Simon
I originally just copied it into the Public folder because I did not realise that Safari was being so "helpful"...
After not being able to install the .qpkg file because it "could not find the archive file in /share/Public folder" and after more research I understood the problem.

So i simply renamed the file and it worked...

The point I'm making is to point out what Safari does with the file. I had no idea. Once I understood what was happening I stood a chance of fixing it.

The icon thing is an issue. My MinimWatch is a solid grey on the Mac. Don't know why and don't care now I am a Command line user. I just defaulted to the Linux instructions...

Craig
Find all posts by this user
Quote this message in a reply
05-04-2012, 15:12
Post: #5
RE: MinimServer for QNAP
(04-04-2012 22:50)Craiga Wrote:  The icon thing is an issue. My MinimWatch is a solid grey on the Mac. Don't know why and don't care now I am a Command line user. I just defaulted to the Linux instructions...

Craig

Do you have MinimServer installed and enabled on the QPKG page (green icon)? This is important as it means that MinimServer will start automatically when the QNAP is restarted. If you're starting MinimServer by typing on the comand line, you'll have to login and do that every time you restart the QNAP.

Would you mind trying the following?
1) Check the QPKG page to see if MinimServer is enabled with a green icon. If not, press Enable to enable it.
2) Restart the QNAP.
3) Login via SSH and use the ps command to see whether the automatic startup of MinimServer was successful.

Many thanks!
Simon
Find all posts by this user
Quote this message in a reply
06-04-2012, 03:15
Post: #6
RE: MinimServer for QNAP
Simon
I am talking about the MinimWatch icon on my Mac. It does none of the things it should but no matter. MinimServer is installed and working fine.

I have noticed that since I started MinimServer via Kinsky some of the Kinsky icons are also effected. For example the volume display will work - that is I can increase and decrease my system volume from Kinsky but the "display" does not show the change? Same with the run and pause icon...Strange but Kinsky is temperamental at that best of times. I don't know if this has come up before on the Linn forum.

Bottom line is that after all the effort I'm content to have it working and work it does. Thank you

Craig
Find all posts by this user
Quote this message in a reply
06-04-2012, 09:23
Post: #7
RE: MinimServer for QNAP
(06-04-2012 03:15)Craiga Wrote:  Simon
I am talking about the MinimWatch icon on my Mac. It does none of the things it should but no matter. MinimServer is installed and working fine.

I have noticed that since I started MinimServer via Kinsky some of the Kinsky icons are also effected. For example the volume display will work - that is I can increase and decrease my system volume from Kinsky but the "display" does not show the change? Same with the run and pause icon...Strange but Kinsky is temperamental at that best of times. I don't know if this has come up before on the Linn forum.

Bottom line is that after all the effort I'm content to have it working and work it does. Thank you

Craig

This sounds like a problem with your wireless network setup that's preventing volume update messages sent by the DS from being received by Kinsky. MinimServer isn't involved in this message exchange, so it shouldn't be causing or contributing to this problem.

The problem with MinimWatch also suggests a wireless network issue that's preventing messages sent by MinimServer from being received by MinimWatch. A simple test to confirm this is to try connecting the computer running MinimWatch using a wired connection. If MinimWatch works with a wired connection, this confirms that there's a wireless network issue.

If you're interested in getting these problems resolved, I'd be willing to help. Please send me a PM if you'd like to pursue this further.
Find all posts by this user
Quote this message in a reply
14-04-2012, 09:14
Post: #8
RE: MinimServer for QNAP
Sinom
Sorry wasn't ignoring you. Been busy with something else...
Don't worry. Kinsky seems to be getting more and more flakey everyday. I have two machines one which is permanently hardwired and I really don't see any difference. From the Linn forum it seems to be a Mac thing. I'm not really worried. It's irritating but not fatal. Now it's properly installed MinimServer works just fine.

Regards
Craig
Find all posts by this user
Quote this message in a reply
25-04-2012, 20:53
Post: #9
RE: MinimServer for QNAP
Hi Simon

I am having problems with minimserver on a QNAP 439 turbo pro. I have installed via the QKPG with java runtime etc, the server is enabled via the admin page and is displayed as green icon, minimwatch is installed on a desk top computer it seems to find the qnap as minimwatch will start then turn yellow, i have a large music library so i have left it running for circa 12 hours and the icon on the desktop still remains yellow and nothing for the server shows up in Kinsky on my ipad, am I doing anything wrong? The directory path in the minimwatch config section is /Share/Qmultimedia/Music none of the other suggested paths in previous posts were accepted. Help please.
Find all posts by this user
Quote this message in a reply
25-04-2012, 21:29
Post: #10
RE: MinimServer for QNAP
(25-04-2012 20:53)oldmucker Wrote:  Hi Simon

I am having problems with minimserver on a QNAP 439 turbo pro. I have installed via the QKPG with java runtime etc, the server is enabled via the admin page and is displayed as green icon, minimwatch is installed on a desk top computer it seems to find the qnap as minimwatch will start then turn yellow, i have a large music library so i have left it running for circa 12 hours and the icon on the desktop still remains yellow and nothing for the server shows up in Kinsky on my ipad, am I doing anything wrong? The directory path in the minimwatch config section is /Share/Qmultimedia/Music none of the other suggested paths in previous posts were accepted. Help please.

It definitely shouldn't take 12 hours for MinimServer to scan your files, no matter how large your library is!

I haven't come across this before. To start with, I'd suggest powering the NAS off and on (with MinimServer enabled on the QPKG page). This will do a "cold start" of MinimServer. If you get the same problem again, you'll need to go a bit deeper into problem determination.

The first place to look for clues is the MinimServer log file. If you're comfortable using SSH or SCP to access the QNAP, the log file is named minimserver.log and it's in the directory /share/MD0_DATA/.qpkg/MinimServer/data or /share/HDA_DATA/.qpkg/MinimServer/data (this varies according to the model of QNAP).

If you don't see any useful information in the log, you can increase the amount of logged information by enabling the --debug or --trace option. (You'll get more log output from --trace than from --debug, which might be a good thing or a bad thing.) To run with full tracing, which can produce a very large log file, you should do the following:

1) Edit the minimserver.config file (in the same directory as minimserver.log) to add the line
Code:
.options = --trace

2) Stop and restart MinimServer. You can do this by disabling and enabling MinimServer from the QPKG plugin page, or by powering the NAS off and on (with MinimServer enabled on the QPKG page).

3) Look at the log file. If you're not sure how to interpret the information there, please attach it to a forum post and I'll take a look.

I'm sorry that this process is a bit complicated. The next release of MinimServer will have a much more convenient user interface for viewing the log information and changing the logging level.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)