Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MinimStreamer with avconv on Ubuntu server
09-07-2016, 10:52
Post: #1
MinimStreamer with avconv on Ubuntu server
I have implemented the transcoding bundle avconv on my Ubuntu 14.04 server.
Having set up a playlist with various German radio stations I wanted to transcode the radio streams to wav (stream transcode: *:wav) using the avconv bundle. MinimStreamer recognized avconf after I used stream.converter: /usr/bin/avconv.
Sometimes I succeed, but very often I get errors while invoking a radio station.
Any ideas what's going wrong?
I have added a log and my sytem preferences below

Rainer


.txt  error log.txt (Size: 68.63 KB / Downloads: 2)
   
Find all posts by this user
Quote this message in a reply
09-07-2016, 17:17
Post: #2
RE: MinimStreamer with avconv on Ubuntu server
I can see some I/O errors in the log when MinimStreamer starts sending the transcoded stream to the renderer. This means there is some problem either with the renderer or with the network. MinimStreamer and MinimServer are working correctly.
Find all posts by this user
Quote this message in a reply
10-07-2016, 10:45
Post: #3
RE: MinimStreamer with avconv on Ubuntu server
Hi Simon,

thanks for your analysis.
To be honest I installed avconv on my Ubuntu-server (ffmpeg is not recommended for Ubuntu 14.04) without really knowing what I did; maybe something went wrong. I will probably purge avconv again from my server.

Regards Rainer
Find all posts by this user
Quote this message in a reply
10-07-2016, 21:44
Post: #4
RE: MinimStreamer with avconv on Ubuntu server
I don't think the problem is related to avconv. If it were, I would expect to see some error message from avconv in the log.

You said that you succeed sometimes in playing radio stations. Do some stations always succeed and other stations always fail, or does a station succeed on some attempts and fail on other attempts?
Find all posts by this user
Quote this message in a reply
11-07-2016, 09:06
Post: #5
RE: MinimStreamer with avconv on Ubuntu server
Everything seems to work properly now with avconv.
I deleted the stream.converter and stream.transcode input out of System Properties, restarted minimserver. Then I filled stream.transcode with "*:wav" and stream.converter was automatically filled with "avconv". I restarted minimserver again.
Now everything works as expected.... miracle, miracle.

Thanks again for your input.

Rainer
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)