Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem..
07-05-2016, 22:43
Post: #11
RE: Problem..
The device is the Roberts Radio Stream 93i. I have noticed that on occasion album art does show on the renderer, but more often it doesnt. I put that down to the size of the album art.

This is strange as I've been using this renderer for some time. I have two and they both seem to have the same effect. Some files have more issues than others but that is what I was playing tonight.

I could try the 93i as a dlna renderer in Kinsky and see if its the same. I like the openhome renderer as it allows the playlist to be sent and the control point to shut down. Kinsky seems to handle renderers differently. I have some other options I can try tomorrow such as Bubbleupnp on an Android phone to see if its different.

Streaming from a Synology 1511+ to a Cyrus Stream XP2 QX, 2x Roberts 93i, A Revo Superconnect, a Mede8er 600 3D and a few Squeezeboxes thrown in!
Find all posts by this user
Quote this message in a reply
08-05-2016, 08:45
Post: #12
RE: Problem..
Morning Simon

This morning I've tried running the Stream 93i as a dlna renderer and controlled by Kinsky rather than Kazoo. Seems to be working fine.

I switched logging into debug for a short while and hopefully the log will tell you if we have a different situation. Certainly there have been no crashes as yet.
.zip  minimserverdlna.zip (Size: 20.29 KB / Downloads: 3)

Rob

Streaming from a Synology 1511+ to a Cyrus Stream XP2 QX, 2x Roberts 93i, A Revo Superconnect, a Mede8er 600 3D and a few Squeezeboxes thrown in!
Find all posts by this user
Quote this message in a reply
08-05-2016, 10:12
Post: #13
RE: Problem..
Update. Still crashing. Ive tried using LMS as the server and with this particular album it even seemed to stop playing at a similar point although LMS didnt crash.

Now trying a different album with LMS to see if I have similar issues..

Streaming from a Synology 1511+ to a Cyrus Stream XP2 QX, 2x Roberts 93i, A Revo Superconnect, a Mede8er 600 3D and a few Squeezeboxes thrown in!
Find all posts by this user
Quote this message in a reply
08-05-2016, 17:10
Post: #14
RE: Problem..
(08-05-2016 08:45)robt Wrote:  Morning Simon

This morning I've tried running the Stream 93i as a dlna renderer and controlled by Kinsky rather than Kazoo. Seems to be working fine.

I switched logging into debug for a short while and hopefully the log will tell you if we have a different situation. Certainly there have been no crashes as yet.

Rob

This log shows the same problem with the same embedded album art image. Perhaps there is something about this image that is causing the 93i to malfunction in this way.
Find all posts by this user
Quote this message in a reply
09-05-2016, 20:21 (This post was last modified: 09-05-2016 20:22 by robt.)
Post: #15
RE: Problem..
Ok. This isnt the only track / album that has caused crashes so I will try and play a variety of tracks and log whats going on in debug mode.

I'll upload it and see if there is a similar problem with other files.

Rob

Streaming from a Synology 1511+ to a Cyrus Stream XP2 QX, 2x Roberts 93i, A Revo Superconnect, a Mede8er 600 3D and a few Squeezeboxes thrown in!
Find all posts by this user
Quote this message in a reply
11-05-2016, 17:39 (This post was last modified: 11-05-2016 19:17 by robt.)
Post: #16
RE: Problem..
I have tried some other tracks and had the same result. Attached another log file which appears to show the same problem.

I dont understand what has happened as I have been using this renderer with Minimserver for over a year without issue. It seems to have started with DSM 6 and the upgrade to minimserver. Any ideas anyone?


.zip  minimserver (1).zip (Size: 115.88 KB / Downloads: 1)

And heres another log when streaming to my other Stream 93i. It appears to be doing the same thing although it didnt crash minimserver. Simon, if you have a moment can you confirm that its doing the same thing?


.zip  minimserver (2).zip (Size: 302.42 KB / Downloads: 1)

Streaming from a Synology 1511+ to a Cyrus Stream XP2 QX, 2x Roberts 93i, A Revo Superconnect, a Mede8er 600 3D and a few Squeezeboxes thrown in!
Find all posts by this user
Quote this message in a reply
12-05-2016, 21:16
Post: #17
RE: Problem..
In the first log, the 93i with IP address 192.168.0.20 is continually requesting the album art from the file Lossless music/Dire Straits/Communique (remastered)/01 - Once Upon A Time In The West.flac.

In the second log, the device with IP address 192.168.0.10 (apparently another 93i) is continually requesting the album art from the file Lossless music/Steely Dan/Then and Now - The Best of/03. Steely Dan - Peg (-77) (Then & Now - The Best Of Steely Dan - Remastered).flac (the same file as in the previous logs).

There have been no recent changes to MinimServer that would affect how embedded album art images are streamed.
Find all posts by this user
Quote this message in a reply
12-05-2016, 21:48
Post: #18
RE: Problem..
Thanks for that. The 93i uses the Frontier Silicon Venice 6.5 chipset, as do many other streamers such as the Ruark R2 Mk3. I wonder if anyone else is seeing similar activity? The only slightly interesting difference I am seeing is that one of my 93is crashes minimserver and the other one doesnt, or at least not so consistently.

Is there any obvious reason why the request for the album art isnt successful that you can think of? All my files have embedded art and also folder or cover.jpgs. I dont have access to my Cyrus streamer at the moment due to a house move but I shall soon have it running and will be able to do some more comparisons.

This is a really frustrating situation but it seems there is a definite incompatibility with the 93i.

Streaming from a Synology 1511+ to a Cyrus Stream XP2 QX, 2x Roberts 93i, A Revo Superconnect, a Mede8er 600 3D and a few Squeezeboxes thrown in!
Find all posts by this user
Quote this message in a reply
12-05-2016, 22:22
Post: #19
RE: Problem..
If your files have embedded artwork, any folder.jpg or cover.jpg file is ignored by MinimServer. Can you look at the embedded artwork for the albums that are causing this problem to see if there is a difference? For example, is the artwork resolution too high for the renderer?
Find all posts by this user
Quote this message in a reply
06-07-2016, 17:37
Post: #20
RE: Problem..
I have been quiet on this one for some time but haven't been able to resolve this issue. There have been two firmware updates to the Stream 93is and another version of minimserver and I can still cause it to crash. It does just seem to be an incompatibility between the two items as I can stream via the Synology media server without issue. The supplied server does show album art whereas Minimserver does not. All my files have embedded art of various sizes and the size doesnt seem to be the issue. The last file I tried had embedded artwork of just 32kb and it caused MS to crash in less than two minutes.
I do have my Cyrus Stream XP back up and running and it works without issue, although of course it doesnt have the ability to show artwork so I guess thats not a surprise!
Simon, if you are interested in resolving this I am happy to keep working with you on this. I'm amazed no one else seems to have come across this issue as there are many Frontier Silicon based streamers out there and it seems to be a basic incompatibility between that chip set and MS.
Really dont want to give up on this as MS is so much better than any other server I have tried in terms of configuration options.

Regards

Rob

Streaming from a Synology 1511+ to a Cyrus Stream XP2 QX, 2x Roberts 93i, A Revo Superconnect, a Mede8er 600 3D and a few Squeezeboxes thrown in!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)