Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Synology DS415+ With DSM 6.0
30-03-2016, 17:37
Post: #1
Synology DS415+ With DSM 6.0
Hi

I have installed DSM 6.0 on the DS415+ with the Java 8 package from Synology.

When I install MinimServer-0.8.3.4-x64.spk I get an error message:

"install configure file fail! (/var(packages/MinimServer/target/etc/MinimServer.sc)

(See attached Screenshot)

However the packages is installed after selecting the ok button. I can also start the minimserver and everythings looks good. However would be good to know if there is an impact on the server.

Any ideas why this message pop's up?

Thanks


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
30-03-2016, 22:13 (This post was last modified: 04-04-2016 15:12 by simoncn.)
Post: #2
RE: Synology DS415+ With DSM 6.0
This can happen if you have a problem with Java while you are installing an update to MinimServer. It will be fixed in the next version of the MinimServer install package.

To recover from this on DSM 6.0, you need to do the following:

1) Use SSH to login to the NAS as user 'admin'

2) Enter the command (note: edited to correct typo):

sudo /usr/syno/bin/servicetool --remove-configure-file --package MinimServer.sc

3) Enter your admin password when prompted for this

After doing this, you should be able to install MinimServer.
Find all posts by this user
Quote this message in a reply
31-03-2016, 10:36
Post: #3
RE: Synology DS415+ With DSM 6.0
I now have upgraded my DS213+ (with power pc CPU e500v to DSM6. Just as information:

After rebooting the NAS DSM did show the status for minimserver 0.8.3 that it had to be uninstalled and updated because it was not compatible to DSM6. So I uninstalled it, downloaded the most recent ppc-version 0.8.3.4 and was able to install it. Currently it is scanning the whole music library from scratch that is taking quite long, but the most important thing is: it is running.

But I saw this requester "install configure file fail! (/var(packages/MinimServer/target/etc/MinimServer.sc)", too. Nevertheless the configs seem to completely restored. The music path was set correctly and the properties seem to be recovered, too. Do I have to run the "servicetool" in this case?

BubbleUPnPServer is not startable anymore because there maybe is a conflict with the installed java version. So I looked for a more recent java8 version for PPC. Sad to see that java is no longer published for this platform. You have to choose the last version java8u6 from 12th June 2014.

As I am looking for a second backup NAS I now wonder which CPU type is best to choose to be most compatible to java and minimserver, etc., in future? Is an intel CPU the best? Also is synology or qnap better for minimserver or does it make no difference for this?
Find all posts by this user
Quote this message in a reply
31-03-2016, 14:44 (This post was last modified: 31-03-2016 14:44 by simoncn.)
Post: #4
RE: Synology DS415+ With DSM 6.0
(31-03-2016 10:36)tarnkappe Wrote:  I now have upgraded my DS213+ (with power pc CPU e500v to DSM6. Just as information:

After rebooting the NAS DSM did show the status for minimserver 0.8.3 that it had to be uninstalled and updated because it was not compatible to DSM6. So I uninstalled it, downloaded the most recent ppc-version 0.8.3.4 and was able to install it. Currently it is scanning the whole music library from scratch that is taking quite long, but the most important thing is: it is running.

You are getting the complete rescan because you uninstalled the previous version. This deletes the MinimServer cache, which now needs to be recreated.

Quote:But I saw this requester "install configure file fail! (/var(packages/MinimServer/target/etc/MinimServer.sc)", too. Nevertheless the configs seem to completely restored. The music path was set correctly and the properties seem to be recovered, too. Do I have to run the "servicetool" in this case?

Whenever I have seen this, it has prevented MinimServer from installing. I am not sure how it could occur with a successful installation.

Quote:BubbleUPnPServer is not startable anymore because there maybe is a conflict with the installed java version. So I looked for a more recent java8 version for PPC. Sad to see that java is no longer published for this platform. You have to choose the last version java8u6 from 12th June 2014.

I am surprised that BubbleUPnP Server cannot run with this version of Java. Have you asked on the BubbleUPnP forum about this?

Quote:As I am looking for a second backup NAS I now wonder which CPU type is best to choose to be most compatible to java and minimserver, etc., in future? Is an intel CPU the best? Also is synology or qnap better for minimserver or does it make no difference for this?

Any ARM or Intel model from QNAP or Synology will be fine.
Find all posts by this user
Quote this message in a reply
31-03-2016, 16:54
Post: #5
RE: Synology DS415+ With DSM 6.0
(31-03-2016 14:44)simoncn Wrote:  You are getting the complete rescan because you uninstalled the previous version. This deletes the MinimServer cache, which now needs to be recreated.

Yes, ok. After finishing the scan everything seems to work again.

Quote:Whenever I have seen this, it has prevented MinimServer from installing. I am not sure how it could occur with a successful installation.

I keep it like it is as long it is working fine. Otherwise it had to rescan everything again. (I just hope to remember this issue if an error occurs some time later.)

Quote:I am surprised that BubbleUPnP Server cannot run with this version of Java. Have you asked on the BubbleUPnP forum about this?

I do not know what the problem was. I have uninstalled the package, downloaded the most recent version and installed it again. Now it is running again ok. (I had to reboot the NAS before reinstallation because the port still was blocked. Maybe the service was still running even with the uninstalled package.)

Quote:
Quote:As I am looking for a second backup NAS I now wonder which CPU type is best to choose to be most compatible to java and minimserver, etc., in future? Is an intel CPU the best? Also is synology or qnap better for minimserver or does it make no difference for this?

Any ARM or Intel model from QNAP or Synology will be fine.

Intel seems more comfortable because of the openjava problem with ARM7 that has to be replaced manually by the closed source oracle java. But ARM does use less energy? Well, this becomes off topic here. I will do some research...
Find all posts by this user
Quote this message in a reply
31-03-2016, 17:14
Post: #6
RE: Synology DS415+ With DSM 6.0
Hi

I tried to delelete the file as per instruction:

sudo usr/syno/bin/servicetool --remove-configure-file --package MinimServer.sc

However I got an error athough i put the correct password as followig:

sudo usr/syno/bin/servicetool --remove-configure-file --package MinimServer.sc
Password:
remove configure file fail! file=MinimServer.sc error=
[0x0700 service_conf_remove.c:100]admin@NAS-3:/$


The new installation of the minimServer package provided same error. However even with the error the Minimserver can be successfully installed and is running.

What do you suggest?
Find all posts by this user
Quote this message in a reply
31-03-2016, 17:23
Post: #7
RE: Synology DS415+ With DSM 6.0
Quick update:

Was just able to remove the configure file.

However after deinstalling the package and reinstalling I got still same error. But as written although I got an Error the server is running and all seems to work.
Find all posts by this user
Quote this message in a reply
31-03-2016, 18:13
Post: #8
RE: Synology DS415+ With DSM 6.0
(31-03-2016 17:23)planet Wrote:  Quick update:

Was just able to remove the configure file.

However after deinstalling the package and reinstalling I got still same error. But as written although I got an Error the server is running and all seems to work.

I think you might need to reboot the NAS after removing the configure file. Can you try this now and let me know whether MinimServer starts without the error message?
Find all posts by this user
Quote this message in a reply
31-03-2016, 18:49
Post: #9
RE: Synology DS415+ With DSM 6.0
The error only comes during the installation process, but not when I do a rescan or a stop and start of the minimserver
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)