Post Reply 
 
Thread Rating:
  • 3 Vote(s) - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Tutorial] Installing MinimServer on FreeNAS or FreeBSD
29-01-2020, 17:52
Post: #47
RE: [Tutorial] Installing MinimServer on FreeNAS or FreeBSD
(29-01-2020 11:07)airflow Wrote:  
(29-01-2020 04:17)imush Wrote:  Followed instructions, minimserver server works on a new FreeNAS in a jail. Sort of, there are a couple issues:

1. The startup script does not work for some reason at restart of jail. If I run it manually (either startd or the script itself, e.g. service minimserver start), it does, but when the jail is just starting up the server dies, and I could not find any useful diagnostic information. The script is, of course, not very compliant as it does not take stop or restart args

2. Should it be really running as [jail] r[/code]oot?

3. For some reason it becomes invisible to clients / control points after an hour or two of being idle. The server is alive, and the URL is working, but the bubbleDS and hi-fi cast apps show it "offline" and cannot reconnect. Also my Oppo BDB-105 player does not see it. If I restart it manually, it works again (but not "reload" or "rescan" from the web interface).

1. The startup script really is very primitive and not taking arguments, that's correct - usually for me it is sufficient, because I never have the need to stop the server. I could/should improve this in the future...

2. Yes it does, as the software is confined in a jail (with no other software/data installed in the same jail), to my mind that's OK.

3. This is a pity and should not be the case. I cannot confirm this behaviour. Which version of FreeNAS do you use? These days 11.3 STABLE was released, it's brand-new. I have used the RC for the last two weeks to migrate my jails to 11.3 kernel, and had no problem so far. You could start minimserver manually and check the logs if you see anything suspicious.

Yeah, I am fine with [jail] root too, I just thought that maybe that has something to do with the rc.conf problem.

For some reason, it fails to start up on its own, and I see no error in logs. rc.conf and your script seem to be correct (well, at least to start the service), especially since if I later run 'service minimserver start', it works.

I have a brand new FreeNAS mini with 11.3 jails. I have other services in jails (dns, ldap) and they all seem to be working fine. I also tried a miniDLNA server, and it also runs with no issues; but, of course, I have a large classical collection, so minimserver seems to be the only good option.

I'll look into my networking setup further and report if I find the problem.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: [Tutorial] Installing MinimServer on FreeNAS or FreeBSD - imush - 29-01-2020 17:52

Forum Jump:


User(s) browsing this thread: 2 Guest(s)