Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Minimwatch not starting
03-06-2015, 19:20
Post: #31
RE: Minimwatch not starting
I tried to relaunch MinimWatch today, having not needed it for a while, and it would not launch from the icon.

The only way to make it work was to enter

cd "C:\Program Files (x86)\MinimWatch\lib"
javaw -jar mwatch.jar

From the command prompt.

What is the simplest thing I can do to avoid the need to do this each time?
Find all posts by this user
Quote this message in a reply
03-06-2015, 19:52
Post: #32
RE: Minimwatch not starting
(03-06-2015 19:20)Hungryhalibut Wrote:  I tried to relaunch MinimWatch today, having not needed it for a while, and it would not launch from the icon.

The only way to make it work was to enter

cd "C:\Program Files (x86)\MinimWatch\lib"
javaw -jar mwatch.jar

From the command prompt.

What is the simplest thing I can do to avoid the need to do this each time?

Does Default Programs in Control Panel show "JAR file" or "Executable Jar File" for the .jar file extension?
Find all posts by this user
Quote this message in a reply
03-06-2015, 20:47 (This post was last modified: 03-06-2015 20:48 by Hungryhalibut.)
Post: #33
RE: Minimwatch not starting
The default shown is Java™ Platform SE binary. Under the description it simply says java.
Find all posts by this user
Quote this message in a reply
03-06-2015, 21:00 (This post was last modified: 03-06-2015 21:03 by simoncn.)
Post: #34
RE: Minimwatch not starting
(03-06-2015 20:47)Hungryhalibut Wrote:  The default shown is Java™ Platform SE binary. Under the description it simply says java.

The "java" seems wrong and I'm not sure how this could have happened. Perhaps at some point you installed some other software that created an unusual association for the .jar file extension.

You can launch MinimWatch from the desktop launch icon by changing the properties of this icon. On the Shortcut tab, change the Target field from:

"C:\Program Files (x86)\MinimWatch\lib\mwatch.jar"

to:

javaw -jar "C:\Program Files (x86)\MinimWatch\lib\mwatch.jar"

and click OK followed by Continue.
Find all posts by this user
Quote this message in a reply
03-06-2015, 21:23 (This post was last modified: 03-06-2015 21:30 by Hungryhalibut.)
Post: #35
RE: Minimwatch not starting
I did that and it comes up with a box to choose the program to use. I click on the Java TM platform SE binary option and nothing happens. I then look at the target and it has changed to

C:\ProgramData\Oracle\Java\javapath\javaw.exe -jar "C:\Program Files (x86)\MinimWatch\lib\mwatch.jar"

Most baffling.

And even worse, since doing this I can no longer get the black cmd command prompt, so I can't start MinimWatch that way either.
Find all posts by this user
Quote this message in a reply
03-06-2015, 21:48
Post: #36
RE: Minimwatch not starting
(03-06-2015 21:23)Hungryhalibut Wrote:  I did that and it comes up with a box to choose the program to use. I click on the Java TM platform SE binary option and nothing happens. I then look at the target and it has changed to

C:\ProgramData\Oracle\Java\javapath\javaw.exe -jar "C:\Program Files (x86)\MinimWatch\lib\mwatch.jar"

Most baffling.

And even worse, since doing this I can no longer get the black cmd command prompt, so I can't start MinimWatch that way either.

I don't get a box to choose the program to use. Which version of Windows are you using?

This value for Target should be correct. Did you click OK followed by Continue to save this change? If so, what happens when you double-click the launch icon?

You should be able to open a black command prompt window from the Start menu. Updating the shortcut won't make any difference to this.
Find all posts by this user
Quote this message in a reply
03-06-2015, 21:54 (This post was last modified: 03-06-2015 21:58 by Hungryhalibut.)
Post: #37
RE: Minimwatch not starting
When I double click I get the Open With box. The recommended programme is Java ™ Platform SE binary.

I'm using windows 7.

Until I made this change I could get the black cmd prompt. Now it has gone. None of my shortcuts on the bottom bar will work and my shortcuts on the desktop just show the Java logo instead of the original logos. None of my programs will work from the shortcuts or the start menu. All this was triggered by the change to the Minim shortcut - it was working fine before.
Find all posts by this user
Quote this message in a reply
03-06-2015, 22:22
Post: #38
RE: Minimwatch not starting
(03-06-2015 21:54)Hungryhalibut Wrote:  When I double click I get the Open With box. The recommended programme is Java ™ Platform SE binary.

I'm using windows 7.

Until I made this change I could get the black cmd prompt. Now it has gone. None of my shortcuts on the bottom bar will work and my shortcuts on the desktop just show the Java logo instead of the original logos. None of my programs will work from the shortcuts or the start menu. All this was triggered by the change to the Minim shortcut - it was working fine before.

I have tested this shortcut change on Windows 7 and I didn't get anything like what you are describing.

Can you get back to where you were previously by changing the MinimWatch shortcut back to its original value?

If this doesn't work, try uninstalling MinimWatch. This will delete the MinimWatch shortcut icon.
Find all posts by this user
Quote this message in a reply
03-06-2015, 22:38
Post: #39
RE: Minimwatch not starting
Somehow the computer was changed so that Java was linked to every shortcut, so nothing opened. We managed to fix that.

I then removed MW and reinstalled it. I made the change to the target, but once again the box asking which program to use pops up. As soon as I select Java SE binary all my shortcuts stop again!

I think the next step is to reinstall Java. I'll leave that till tomorrow. Thanks for the help so far. I will not be defeated!
Find all posts by this user
Quote this message in a reply
04-06-2015, 09:39
Post: #40
RE: Minimwatch not starting
(03-06-2015 22:38)Hungryhalibut Wrote:  Somehow the computer was changed so that Java was linked to every shortcut, so nothing opened. We managed to fix that.

I then removed MW and reinstalled it. I made the change to the target, but once again the box asking which program to use pops up. As soon as I select Java SE binary all my shortcuts stop again!

I think the next step is to reinstall Java. I'll leave that till tomorrow. Thanks for the help so far. I will not be defeated!

In the Shortcut tab of the MinimWatch icon properties, what is shown as the Target type? Mine says "Executable Jar File". For a normal (non-Java) shortcut, the Target type is "Application". Perhaps when you select a program to use, you are doing this for all shortcuts with the same Target type.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)