Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Composer.displayRole={artist}
26-03-2015, 10:55
Post: #1
Composer.displayRole={artist}
Hello,

I only want to see the Composer tag in the composer index, not the artist name.

I tried to remove this setting from the custom tag:
Composer.displayRole={artist}

and I also tried:
Composer.displayRole={}

but none of them worked. The control point stills shows the artists and composers.

I there a way to force the control point to only show the composer tag and ignore the artist ? I'm using 0.8.3 on a QNAP x86.
Find all posts by this user
Quote this message in a reply
26-03-2015, 11:12
Post: #2
RE: Composer.displayRole={artist}
(26-03-2015 10:55)Fotospecht Wrote:  Hello,

I only want to see the Composer tag in the composer index, not the artist name.

I tried to remove this setting from the custom tag:
Composer.displayRole={artist}

and I also tried:
Composer.displayRole={}

but none of them worked. The control point stills shows the artists and composers.

I there a way to force the control point to only show the composer tag and ignore the artist ? I'm using 0.8.3 on a QNAP x86.

Which control point are you using?

Where exactly are you seeing the unwanted artist name in addition to the composer name?
Find all posts by this user
Quote this message in a reply
26-03-2015, 11:14
Post: #3
RE: Composer.displayRole={artist}
I'm using VLC and I'm seeing the artist name displayed as the composer.
Find all posts by this user
Quote this message in a reply
26-03-2015, 13:18
Post: #4
RE: Composer.displayRole={artist}
(26-03-2015 11:14)Fotospecht Wrote:  I'm using VLC and I'm seeing the artist name displayed as the composer.

Where exactly are you seeing this? Can you post a screenshot?

Which version of VLC are you using?
Find all posts by this user
Quote this message in a reply
26-03-2015, 13:39
Post: #5
RE: Composer.displayRole={artist}
I will check later when I'm at home.

What is the correct setting when only the composer name should be shown ?
Remove the setting Composer.displayRole={artist} completely from the custom tag ?
Find all posts by this user
Quote this message in a reply
26-03-2015, 14:51
Post: #6
RE: Composer.displayRole={artist}
(26-03-2015 13:39)Fotospecht Wrote:  I will check later when I'm at home.

What is the correct setting when only the composer name should be shown ?
Remove the setting Composer.displayRole={artist} completely from the custom tag ?

This setting doesn't do what you think it does. It affects how Composer information is sent to the control point, not how Artist information is sent.

If you want Composer information to be sent, this needs to be set to either Composer.displayRole={artist} or Composer.displayRole={author} depending on which control point you are using.
Find all posts by this user
Quote this message in a reply
26-03-2015, 15:36
Post: #7
RE: Composer.displayRole={artist}
(26-03-2015 14:51)simoncn Wrote:  
(26-03-2015 13:39)Fotospecht Wrote:  I will check later when I'm at home.

What is the correct setting when only the composer name should be shown ?
Remove the setting Composer.displayRole={artist} completely from the custom tag ?

This setting doesn't do what you think it does. It affects how Composer information is sent to the control point, not how Artist information is sent.

If you want Composer information to be sent, this needs to be set to either Composer.displayRole={artist} or Composer.displayRole={author} depending on which control point you are using.

I still don't understand this.

When I select the Composer on my control point, I just want to see items where the TCOM id3tag is set and not empty. I'm not interested in seeing any artists when selecting the Composer item.

So what is the correct setting for this behaviour ?
Find all posts by this user
Quote this message in a reply
26-03-2015, 20:05
Post: #8
RE: Composer.displayRole={artist}
I tested this with foobar2000 1.3.7 with the same results. The uPNP browser shows a mixture of composers and artists when I navigate to Composers in the main menu.
I'm just wondering why the composers are populated with artists - shouldn't itbe the default behaviour that only composers are displayed ?
Find all posts by this user
Quote this message in a reply
26-03-2015, 23:31
Post: #9
RE: Composer.displayRole={artist}
(26-03-2015 20:05)Fotospecht Wrote:  I tested this with foobar2000 1.3.7 with the same results. The uPNP browser shows a mixture of composers and artists when I navigate to Composers in the main menu.
I'm just wondering why the composers are populated with artists - shouldn't itbe the default behaviour that only composers are displayed ?

This shouldn't be happening and I have never seen it happen myself.

I'm not sure which main menu you mean. Please can you post a screenshot for either VLC or foobar2000 showing this incorrect display. Which version of VLC are you using?

This problem might be caused by an incorrect MinimServer configuration setting. Please post your complete settings for the following properties:

aliasTags
indexTags
itemTags
tagOptions
tagValue
tagCustom
Find all posts by this user
Quote this message in a reply
27-03-2015, 10:16
Post: #10
RE: Composer.displayRole={artist}
I did a full startup scan and the problem went away - probably this was a problem with the cache.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)