Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Music won't play on Roberts radio
24-03-2015, 10:07
Post: #11
RE: Music won't play on Roberts radio
(24-03-2015 09:00)Hungryhalibut Wrote:  Thanks Simon, I'll do it this evening. What I don't understand is how the Roberts will play happily using the Synology media server, as the files being served will still contain all the same metadata. Surely Minim can't be adding things in? As you can tell, I'm no IT expert!

The are likely to be variations in the DIDL-Lite metadata sent to the control point by different servers. I have some ideas about possible differences but I would prefer to wait for the full trace log rather than start guessing. Thanks very much for your help with this!
Find all posts by this user
Quote this message in a reply
24-03-2015, 20:05
Post: #12
RE: Music won't play on Roberts radio
Here we go. This time I was trying to listen 10cc's How Dare You.


Attached File(s)
.zip  Roberts log 24 03 15.zip (Size: 4.48 KB / Downloads: 1)
Find all posts by this user
Quote this message in a reply
24-03-2015, 20:25
Post: #13
RE: Music won't play on Roberts radio
(24-03-2015 20:05)Hungryhalibut Wrote:  Here we go. This time I was trying to listen 10cc's How Dare You.

Thanks! There aren't any obvious problems or potential problems here. Can you try removing the flac:wav transcoding setting to see if this helps? Also, do you have any tracks without album art that you could try?
Find all posts by this user
Quote this message in a reply
24-03-2015, 20:34
Post: #14
RE: Music won't play on Roberts radio
Ha ha. Turning the transcoding off makes it work perfectly. The thing is, WAV sounds better on the Naim and I want to use it. Both the Naim server I had previously, and the Synology, were sending transcoded flac to wav to the Roberts and it was fine.
Find all posts by this user
Quote this message in a reply
24-03-2015, 20:39
Post: #15
RE: Music won't play on Roberts radio
(24-03-2015 20:34)Hungryhalibut Wrote:  Ha ha. Turning the transcoding off makes it work perfectly. The thing is, WAV sounds better on the Naim and I want to use it. Both the Naim server I had previously, and the Synology, were sending transcoded flac to wav to the Roberts and it was fine.

Please try one more test. Can you convert a FLAC file to WAV offline using dBpoweramp and try playing this converted WAV file using MinimServer?
Find all posts by this user
Quote this message in a reply
24-03-2015, 20:57
Post: #16
RE: Music won't play on Roberts radio
OK, I've done that, and saved the single track as if it was a separate album, leaving transcoding switched off. The Roberts is now saying <EMPTY> again. Most confusing, as it will play native WAV from other servers. Am I doomed?
Find all posts by this user
Quote this message in a reply
24-03-2015, 21:16
Post: #17
RE: Music won't play on Roberts radio
(24-03-2015 20:57)Hungryhalibut Wrote:  OK, I've done that, and saved the single track as if it was a separate album, leaving transcoding switched off. The Roberts is now saying <EMPTY> again. Most confusing, as it will play native WAV from other servers. Am I doomed?

This is positive progress because it means that transcoding isn't the problem.

Can you try it with transcoding set to flac:L16 instead of flac:wav?
Find all posts by this user
Quote this message in a reply
24-03-2015, 21:35
Post: #18
RE: Music won't play on Roberts radio
My MinimServer is set to transcode from flac to 24-bit wav. When I first tried this my Roberts radios stopped working. I then added the '-' switch to the transcode setting which, if I remember correctly allows the control point (renderer?) to choose a stream that it can handle. Voila! My Linn gets Wav24 and the radios work again.

(Forgive the vagueness. I am writing this on my iPad and all PCs are switched off so I can't run MinimWatch to look up the exact transcode entry.)

(Whilst the Linn and the Robertss work just fine, I also have a Cambridge Audio Minx xi in the conservatory and this will not work with this transcode setting. It tries to render the 24-bit wavs but keeps choking. Tracks stop half way through. It seems to think that in can hande 24-bit when, in fact, it cannot. The only solution that I have found for this is to run a parallel installation of Twonky just for the Minx.)

Jim.
Find all posts by this user
Quote this message in a reply
24-03-2015, 22:24 (This post was last modified: 24-03-2015 22:24 by simoncn.)
Post: #19
RE: Music won't play on Roberts radio
(24-03-2015 21:35)JimR Wrote:  My MinimServer is set to transcode from flac to 24-bit wav. When I first tried this my Roberts radios stopped working. I then added the '-' switch to the transcode setting which, if I remember correctly allows the control point (renderer?) to choose a stream that it can handle. Voila! My Linn gets Wav24 and the radios work again.

(Forgive the vagueness. I am writing this on my iPad and all PCs are switched off so I can't run MinimWatch to look up the exact transcode entry.)

(Whilst the Linn and the Robertss work just fine, I also have a Cambridge Audio Minx xi in the conservatory and this will not work with this transcode setting. It tries to render the 24-bit wavs but keeps choking. Tracks stop half way through. It seems to think that in can hande 24-bit when, in fact, it cannot. The only solution that I have found for this is to run a parallel installation of Twonky just for the Minx.)

Jim.

You might be able to solve the Minx issue by using the transcoding setting 'flac:L16/wav24/-'. With this setting:

The Minx should choose the first it can handle (L16)

The Linn should choose the first it can handle (wav24)

The Roberts should choose the first it can handle (L16 or -)

Which control point do you use when playing to the Linn and the Minx?
Find all posts by this user
Quote this message in a reply
24-03-2015, 22:28 (This post was last modified: 24-03-2015 22:30 by simoncn.)
Post: #20
RE: Music won't play on Roberts radio
(24-03-2015 20:57)Hungryhalibut Wrote:  OK, I've done that, and saved the single track as if it was a separate album, leaving transcoding switched off. The Roberts is now saying <EMPTY> again. Most confusing, as it will play native WAV from other servers. Am I doomed?

I believe Synology Media Server uses an incorrect MIME type for WAV files (audio/wav instead of audio/x-wav). Perhaps the Roberts expects the same incorrect MIME type and this is why it can play WAV files served by Synology Media Server.

Transcoding to L16 instead of WAV should be a workaround for this issue.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)