Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Disable Minimserver logging
17-03-2015, 02:35
Post: #1
Disable Minimserver logging
Hi Simon,

Is there a way to disable Minimserver logging on Windows? I found that the ohnet log can be disabled by setting to none. However, there seems to be no option for the same on minimserver.

When set in it's fastest clock mode, my DAC often creates dropouts on disk I/O operations. As such, I am working to minimize any log entries.

Many thanks,

lmitche
Find all posts by this user
Quote this message in a reply
17-03-2015, 11:17 (This post was last modified: 22-03-2015 00:19 by simoncn.)
Post: #2
RE: Disable Minimserver logging
(17-03-2015 02:35)lmitche Wrote:  Hi Simon,

Is there a way to disable Minimserver logging on Windows? I found that the ohnet log can be disabled by setting to none. However, there seems to be no option for the same on minimserver.

When set in it's fastest clock mode, my DAC often creates dropouts on disk I/O operations. As such, I am working to minimize any log entries.

Many thanks,

lmitche

Setting the .logFile property to NUL: should completely disable disk logging. You will still see log messages in the log window.

Edit: This can cause problems and isn't a good idea. The correct setting to disable disk logging is the single character '-'.
Find all posts by this user
Quote this message in a reply
17-03-2015, 20:30
Post: #3
RE: Disable Minimserver logging
(17-03-2015 11:17)simoncn Wrote:  
(17-03-2015 02:35)lmitche Wrote:  Hi Simon,

Is there a way to disable Minimserver logging on Windows? I found that the ohnet log can be disabled by setting to none. However, there seems to be no option for the same on minimserver.

When set in it's fastest clock mode, my DAC often creates dropouts on disk I/O operations. As such, I am working to minimize any log entries.

Many thanks,

lmitche

Setting the .logFile property to NUL: should completely disable disk logging. You will still see log messages in the log window.

Simon,

This setting definitely improved the dropout issue. Many thanks.

lmitche
Find all posts by this user
Quote this message in a reply
22-03-2015, 00:19
Post: #4
RE: Disable Minimserver logging
(17-03-2015 20:30)lmitche Wrote:  Simon,

This setting definitely improved the dropout issue. Many thanks.

lmitche

I've discovered that setting .logFile to NUL: (or /dev/null on Linux) can cause problems and isn't a good idea. The correct setting to disable disk logging is the single character '-'. I will add a check to prevent setting .logFile to NUL: (Windows) or /dev/null (Linux).
Find all posts by this user
Quote this message in a reply
22-03-2015, 11:31
Post: #5
RE: Disable Minimserver logging
(22-03-2015 00:19)simoncn Wrote:  
(17-03-2015 20:30)lmitche Wrote:  Simon,

This setting definitely improved the dropout issue. Many thanks.

lmitche

I've discovered that setting .logFile to NUL: (or /dev/null on Linux) can cause problems and isn't a good idea. The correct setting to disable disk logging is the single character '-'. I will add a check to prevent setting .logFile to NUL: (Windows) or /dev/null (Linux).

Hi Simon,

Many thanks for this. I'll give it a try.

lmitche
Find all posts by this user
Quote this message in a reply
22-03-2015, 16:23
Post: #6
RE: Disable Minimserver logging
[/quote]

I've discovered that setting .logFile to NUL: (or /dev/null on Linux) can cause problems and isn't a good idea. The correct setting to disable disk logging is the single character '-'. I will add a check to prevent setting .logFile to NUL: (Windows) or /dev/null (Linux).
[/quote]

Hi Simon,

Many thanks for this. I'll give it a try.

lmitche
[/quote]

Hi Simon,

Yes, this is better by far. Dropouts aren't totally eliminated but they are improved. I suspect the continued dropouts are due to other reasons further down the chain. Also, there is an increase in SQ with this setting. Everything is more relaxed. Many thanks for your help and attention on this.

lmitche
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)