Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
minim on Slax linux
18-02-2015, 17:47
Post: #1
minim on Slax linux
I have just built a low power server based on Slax which is booted from a small usb stick. Installing standard Linux distribution Minimserver was not difficult after I had installed a standard Java 8 JRE distribution. (None of the SLAX pre-built java modules worked).

I did have some problems getting it to start automatically on boot up. I added the startd script to /etc/rc.d/rc.local where I already have a zfs storage pool imported and mounted.
It did not work because ( I suspect) the Java environment variables and PATH had not yet been established.

Looking more closely at the startd script I notice that an attempt is made to derive the java executable location from the file minimstart.conf and assign it to the variable JAVA . So I created this file and put this line in it:-
java=path to ...bin/java
This didn't work! Looking at the grep pattern used to read the conf file I couldn't fully understand it so I made a simpler version of the pattern that did work. I also have JAVA_HOME defined in rc.local.

This did the trick and started the minimserver daemon as required. But unfortunately it caused another problem. Somehow the X display initialisation was disrupted and the KDE desktop never appeared. I did try reducing the priority using the nice command but this was only partly successful and also left the daemon running with reduced priority. Eventually after further dissecting the startd script I added a 60 second delay ( sleep 60) right at the end to give KDE time to start up first. This seems to be working.

There is every chance that I have hacked the script about unnecessarily because of lack of understanding so feel free to tell me how it should be done.

Minim is working well, both server and streamer, so many thanks to the developers.
Find all posts by this user
Quote this message in a reply
20-02-2015, 10:46
Post: #2
RE: minim on Slax linux
(18-02-2015 17:47)roadster Wrote:  I have just built a low power server based on Slax which is booted from a small usb stick. Installing standard Linux distribution Minimserver was not difficult after I had installed a standard Java 8 JRE distribution. (None of the SLAX pre-built java modules worked).

I did have some problems getting it to start automatically on boot up. I added the startd script to /etc/rc.d/rc.local where I already have a zfs storage pool imported and mounted.
It did not work because ( I suspect) the Java environment variables and PATH had not yet been established.

Looking more closely at the startd script I notice that an attempt is made to derive the java executable location from the file minimstart.conf and assign it to the variable JAVA . So I created this file and put this line in it:-
java=path to ...bin/java
This didn't work! Looking at the grep pattern used to read the conf file I couldn't fully understand it so I made a simpler version of the pattern that did work. I also have JAVA_HOME defined in rc.local.

This did the trick and started the minimserver daemon as required. But unfortunately it caused another problem. Somehow the X display initialisation was disrupted and the KDE desktop never appeared. I did try reducing the priority using the nice command but this was only partly successful and also left the daemon running with reduced priority. Eventually after further dissecting the startd script I added a 60 second delay ( sleep 60) right at the end to give KDE time to start up first. This seems to be working.

There is every chance that I have hacked the script about unnecessarily because of lack of understanding so feel free to tell me how it should be done.

Minim is working well, both server and streamer, so many thanks to the developers.

The \s in the grep pattern is there to ignore any spaces between java and =. It seems that different versions of grep handle this differently. The ^ in the grep pattern is there to make sure java appears at the start of the line.

Did you try running minimserver/bin/setup and enabling automatic startup? Have you run minimserver/bin/setup and enabled desktop integration?

If you are adding automatic startup yourself (not via minimserver/bin/setup), it is important to use startd init rather than just startd.
Find all posts by this user
Quote this message in a reply
20-02-2015, 14:15
Post: #3
RE: minim on Slax linux
Thanks. I guessed that I didn't do it quite correctly. When I ran setup the automatic startup option did not seem to be available. I will add the init option to startd as you advise. As I am mostly running without a desktop I wont try desktop integration.
Find all posts by this user
Quote this message in a reply
20-02-2015, 18:16
Post: #4
RE: minim on Slax linux
(20-02-2015 14:15)roadster Wrote:  Thanks. I guessed that I didn't do it quite correctly. When I ran setup the automatic startup option did not seem to be available. I will add the init option to startd as you advise. As I am mostly running without a desktop I wont try desktop integration.

From your previous comment about the KDE desktop, I presumed you were using a desktop.

I'm not sure that adding init will fix the problem. If it doesn't, we can investigate further.
Find all posts by this user
Quote this message in a reply
21-02-2015, 10:25
Post: #5
RE: minim on Slax linux
Thanks. I appreciate your help but as everything is now working well I don't think its worth putting any further effort in. I'll leave my 60 second delay in place just before the final command in startd so that when I do boot in graphics mode I won't get any problems. I wouldn't be surprised if it was something to do with the use of a USB stick as the boot and configuration device. The X server startup is very slow with a lot of activity on the memory stick. Once underway things are pretty good because everything is happening in memory or on the VFS mounted hard drives.
Find all posts by this user
Quote this message in a reply
17-10-2016, 10:05
Post: #6
RE: minim on Slax linux
This is just an update to say that version 0.8.4 still needs the \s removing from startd script. SLAX Linux default shell running rc.local doesn't like it for some reason.
Find all posts by this user
Quote this message in a reply
17-10-2016, 11:06
Post: #7
RE: minim on Slax linux
(17-10-2016 10:05)roadster Wrote:  This is just an update to say that version 0.8.4 still needs the \s removing from startd script. SLAX Linux default shell running rc.local doesn't like it for some reason.

I've done some investigation and seems that a fix would be to change:

JAVA="$(grep "^java*\s=" "${MINIMDIR}/etc/minimstart.conf"

to:

JAVA="$(grep "^java[ $(printf '\t')]*=" "${MINIMDIR}/etc/minimstart.conf"

This matches any combination of optional spaces and tabs between 'java' and '=' and it should be portable to all Unix variants. Can you try this on your system?
Find all posts by this user
Quote this message in a reply
17-10-2016, 16:57
Post: #8
RE: minim on Slax linux
Thanks Simon I've put that in and it works fine. Minimserver is still working brilliantly as ever.
Find all posts by this user
Quote this message in a reply
17-10-2016, 17:24
Post: #9
RE: minim on Slax linux
(17-10-2016 16:57)roadster Wrote:  Thanks Simon I've put that in and it works fine. Minimserver is still working brilliantly as ever.

Thanks for letting me know. I will update the launch scripts and publish a new release soon.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)