Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MinimServer & Naim n-Stream
30-01-2015, 21:29
Post: #21
RE: MinimServer & Naim n-Stream
(30-01-2015 21:23)simoncn Wrote:  
(30-01-2015 19:38)RikkieB Wrote:  Unfortunately not.... All the devices also have fixed IP address. Should the minim server be visible ALL the time? Because after a few minutes it re-appears in the NAIM app.

I don't think it should make any difference that the devices have fixed IP addresses.

MinimServer should appear all the time. It sounds like the SSDP "alive" announcements that MinimServer sends out every few minutes are being received by the NAIM app but the SSDP M-SEARCH requests that the NAIM app is sending out aren't being received by MinimServer.

When MinimServer appears in the NAIM app after a few minutes, does it stay visible indefinitely or does it disappear after another few minutes?

It disappears after a few minutes and then reappears. this keeps going on.
Find all posts by this user
Quote this message in a reply
30-01-2015, 21:36
Post: #22
RE: MinimServer & Naim n-Stream
(30-01-2015 21:29)RikkieB Wrote:  
(30-01-2015 21:23)simoncn Wrote:  
(30-01-2015 19:38)RikkieB Wrote:  Unfortunately not.... All the devices also have fixed IP address. Should the minim server be visible ALL the time? Because after a few minutes it re-appears in the NAIM app.

I don't think it should make any difference that the devices have fixed IP addresses.

MinimServer should appear all the time. It sounds like the SSDP "alive" announcements that MinimServer sends out every few minutes are being received by the NAIM app but the SSDP M-SEARCH requests that the NAIM app is sending out aren't being received by MinimServer.

When MinimServer appears in the NAIM app after a few minutes, does it stay visible indefinitely or does it disappear after another few minutes?

It disappears after a few minutes and then reappears. this keeps going on.

Sometimes it does not come that quickly. Only when I stop and start the NAIM app
Find all posts by this user
Quote this message in a reply
30-01-2015, 21:38
Post: #23
RE: MinimServer & Naim n-Stream
(30-01-2015 21:29)RikkieB Wrote:  It disappears after a few minutes and then reappears. this keeps going on.

This probably means that UPnP subscription renewal messages aren't getting through your network for some reason.

Are you by any chance running a VPN server on the Synology NAS? This might cause the problems you are seeing.
Find all posts by this user
Quote this message in a reply
30-01-2015, 21:40
Post: #24
RE: MinimServer & Naim n-Stream
(30-01-2015 21:36)RikkieB Wrote:  Sometimes it does not come that quickly. Only when I stop and start the NAIM app

Do you mean it comes more quickly qhen you stop and restart the NAIM app? How long after stopping and starting the NAIM app does it appear?
Find all posts by this user
Quote this message in a reply
30-01-2015, 21:41
Post: #25
RE: MinimServer & Naim n-Stream
(30-01-2015 21:38)simoncn Wrote:  
(30-01-2015 21:29)RikkieB Wrote:  It disappears after a few minutes and then reappears. this keeps going on.

This probably means that UPnP subscription renewal messages aren't getting through your network for some reason.

Are you by any chance running a VPN server on the Synology NAS? This might cause the problems you are seeing.

Only VPN client. But I was running VPN server and stopping VPN server did not solve the problem. But just te be sure the VPN Server runs on a NAS off-site and my NAS is client.
Find all posts by this user
Quote this message in a reply
30-01-2015, 21:47
Post: #26
RE: MinimServer & Naim n-Stream
(30-01-2015 21:41)RikkieB Wrote:  
(30-01-2015 21:38)simoncn Wrote:  
(30-01-2015 21:29)RikkieB Wrote:  It disappears after a few minutes and then reappears. this keeps going on.

This probably means that UPnP subscription renewal messages aren't getting through your network for some reason.

Are you by any chance running a VPN server on the Synology NAS? This might cause the problems you are seeing.

Only VPN client. But I was running VPN server and stopping VPN server did not solve the problem. But just te be sure the VPN Server runs on a NAS off-site and my NAS is client.

I stopped the package VPN Server altogether. So not running now. No luck...
Find all posts by this user
Quote this message in a reply
30-01-2015, 21:56
Post: #27
RE: MinimServer & Naim n-Stream
(30-01-2015 21:47)RikkieB Wrote:  
(30-01-2015 21:41)RikkieB Wrote:  Only VPN client. But I was running VPN server and stopping VPN server did not solve the problem. But just te be sure the VPN Server runs on a NAS off-site and my NAS is client.

I stopped the package VPN Server altogether. So not running now. No luck...

After disabling all VPN, try powering everything off and on as described in my earlier post. This is a test, not the final solution.
Find all posts by this user
Quote this message in a reply
30-01-2015, 22:47
Post: #28
RE: MinimServer & Naim n-Stream
(30-01-2015 21:56)simoncn Wrote:  
(30-01-2015 21:47)RikkieB Wrote:  
(30-01-2015 21:41)RikkieB Wrote:  Only VPN client. But I was running VPN server and stopping VPN server did not solve the problem. But just te be sure the VPN Server runs on a NAS off-site and my NAS is client.

I stopped the package VPN Server altogether. So not running now. No luck...

After disabling all VPN, try powering everything off and on as described in my earlier post. This is a test, not the final solution.

I tried what you described. Still no luck.
Find all posts by this user
Quote this message in a reply
31-01-2015, 08:59
Post: #29
RE: MinimServer & Naim n-Stream
(30-01-2015 22:47)RikkieB Wrote:  I tried what you described. Still no luck.

The next step in diagnosing the problem is to capture a network trace. For this, you need to have MinimWatch running on another computer and do the following:

1) From the minim icon, select 'Show log'
2) In the log window, set the logging level to Debug
3) From the minim icon, select 'Properties' and set the ohnet.debug property on the System tab to All-Timer
4) Run MinimServer for long enough to show it appearing and disappearing in the NAIM app a few times.
5) Note the exact times when MinimServer appears and disappears
6) Using Synology File Station, navigate to the MinimServer/appData folder and copy the minimserver.log file to another computer
7) From the minim icon, select 'Show log' and set the logging level back to Info
8) Zip the minimserver.log file that you copied in step 6 and attach it to a post here, with details of the times that you noted in step 5

I will look at the minimserver.log file and let you know what I find.
Find all posts by this user
Quote this message in a reply
31-01-2015, 10:31
Post: #30
RE: MinimServer & Naim n-Stream
(31-01-2015 08:59)simoncn Wrote:  
(30-01-2015 22:47)RikkieB Wrote:  I tried what you described. Still no luck.

The next step in diagnosing the problem is to capture a network trace. For this, you need to have MinimWatch running on another computer and do the following:

1) From the minim icon, select 'Show log'
2) In the log window, set the logging level to Debug
3) From the minim icon, select 'Properties' and set the ohnet.debug property on the System tab to All-Timer
4) Run MinimServer for long enough to show it appearing and disappearing in the NAIM app a few times.
5) Note the exact times when MinimServer appears and disappears
6) Using Synology File Station, navigate to the MinimServer/appData folder and copy the minimserver.log file to another computer
7) From the minim icon, select 'Show log' and set the logging level back to Info
8) Zip the minimserver.log file that you copied in step 6 and attach it to a post here, with details of the times that you noted in step 5

I will look at the minimserver.log file and let you know what I find.

Open NAIM app: 9:59:00
Minimserver appear: 9:59:59
Close NAIM app: 10:05:30 (Minimserver still visible)
Open NAIM app: 10:05:56 (No minimserver visible)
Appear minimserver: 10:06:49
disappear minimserver: 10:12:49
Appeaar minimserver: 10:13:49
Close NAIM app: 10:21:04
Open NAIM app: 10:21:15 (Minimserver still visible)

It seems that it mostly occurs when closing the app and opening. However when I am in the folder view of the NAIM app and I want to choose another song it is not always possible, going back in the NAIM app to UPnP server shows then NO minimserver. So it does also disappear when playing music. Music keeps on playing however..

logging on the way....
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)