Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ignore tag not working
05-09-2014, 22:15 (This post was last modified: 05-09-2014 22:17 by bplexico.)
Post: #21
RE: Ignore tag not working
Thanks Simon much appreciated. If you need any more information from me let me know.

Barr
Find all posts by this user
Quote this message in a reply
05-09-2014, 22:20
Post: #22
RE: Ignore tag not working
(05-09-2014 22:10)simoncn Wrote:  I tried this and it looks like there is a problem with how MinimServer handles this for the Artist index. It works OK for the All Artists index. I'll investigate and post back here when I have more information.

To make this work correctly for the Artist index, you also need to specify

AlbumArtist.ignore.index.sort={The}

Without this setting, any album artists starting with 'The' will be sorted by T.
Find all posts by this user
Quote this message in a reply
05-09-2014, 22:26 (This post was last modified: 05-09-2014 22:32 by bplexico.)
Post: #23
RE: Ignore tag not working
So do I append this to my property? i.e. I currently have:

Album.sortTags={Album, Artist}, artist.ignore.index.sort={The}

Do I change it to :

Album.sortTags={Album, Artist}, artist.ignore.index.sort={The}, AlbumArtist.ignore.index.sort={The}

-- Barr
Find all posts by this user
Quote this message in a reply
05-09-2014, 22:33
Post: #24
RE: Ignore tag not working
(05-09-2014 22:26)bplexico Wrote:  So do I append this to my property? i.e. I currently have:

Album.sortTags={Album, Artist}, artist.ignore.index.sort={The}

Do I change it to :

Album.sortTags={Album, Artist}, artist.ignore.sort={The}, AlbumArtist.ignore.index.sort={The}

-- Barr

Almost. It should be:

Album.sortTags={Album, Artist}, Artist.ignore.index.sort={The}, AlbumArtist.ignore.index.sort={The}
Find all posts by this user
Quote this message in a reply
05-09-2014, 22:33
Post: #25
RE: Ignore tag not working
Yeah sorry I went back and corrected the missing "index", thanks, trying it now.
Find all posts by this user
Quote this message in a reply
05-09-2014, 22:54
Post: #26
RE: Ignore tag not working
Ok I tried using:

Album.sortTags={Album, Artist}, Artist.ignore.index.sort={The}, AlbumArtist.ignore.index.sort={The}


Unfortunately this took me back to correct sorting in Folder view on my control point but no longer sorting The Beatles by B in what is known as Library view on my controller. Also in folder view, the display name is "Beatles, The".

So reverting to previous:

Album.sortTags={Album, Artist}, artist.ignore.*={The}

This gives me almost all that I need, save the display shows "Beatles, The" but it sorts probably in all artists views on my control point.

Thanks for the suggestion.

BTW my control application is Lightning DS which works currently only on the iPad. Its a free download. Their are two main ways on viewing, one is called Library view and the other is called Folder view ( which is how I believe the Kinsky application always works in ).

The setting I am using above allows me to use Library view on the Lightning DS and thus when I select Artists it finds The Beatles under B ( and displays them as "Beatles, The".

Barr
Find all posts by this user
Quote this message in a reply
05-09-2014, 23:22
Post: #27
RE: Ignore tag not working
(05-09-2014 22:54)bplexico Wrote:  Ok I tried using:

Album.sortTags={Album, Artist}, Artist.ignore.index.sort={The}, AlbumArtist.ignore.index.sort={The}


Unfortunately this took me back to correct sorting in Folder view on my control point but no longer sorting The Beatles by B in what is known as Library view on my controller. Also in folder view, the display name is "Beatles, The".

So reverting to previous:

Album.sortTags={Album, Artist}, artist.ignore.*={The}

This gives me almost all that I need, save the display shows "Beatles, The" but it sorts probably in all artists views on my control point.

Thanks for the suggestion.

BTW my control application is Lightning DS which works currently only on the iPad. Its a free download. Their are two main ways on viewing, one is called Library view and the other is called Folder view ( which is how I believe the Kinsky application always works in ).

The setting I am using above allows me to use Library view on the Lightning DS and thus when I select Artists it finds The Beatles under B ( and displays them as "Beatles, The".

Barr

Thanks for trying this and letting me know. I can't try Lightning DS myself because I don't have an iPad, only an iPod.
Find all posts by this user
Quote this message in a reply
18-02-2015, 03:09
Post: #28
RE: Ignore tag not working
I'm a long time Asset user, so bear with me.

I'm using the following in the Properties-tagOptions field:

Album.sortTags={Album, Artist}, Artist.ignore.sort={The}, AlbumArtist.ignore.index.sort={The}

Which returns "Beatles, The" when browsing by Artist, but returns "The Beatles" when browsing by All Artists. It sorts under "B" either way. Is there any way to have it appear as "The Beatles" when browsing by Artist?
Find all posts by this user
Quote this message in a reply
18-02-2015, 03:40
Post: #29
RE: Ignore tag not working
I use the following, it handles albums tagged with both artist and/or album artist. But as a cautionary tale, depending on what control software you are using, your mileage may vary. In other words different control software interacts differently with Minimserver.

"Album.sortTags={Album, Artist}, Artist.ignore.*={The}, AlbumArtist.ignore.*={The}"

Also I noticed you have different parameters for Artist as opposed to AlbumArtist, why is that?

Which control software are you using? Lumia, Kinsky, Lighting DS, other?

Barr
Find all posts by this user
Quote this message in a reply
18-02-2015, 08:22
Post: #30
RE: Ignore tag not working
(18-02-2015 03:09)knirpslinn Wrote:  I'm a long time Asset user, so bear with me.

I'm using the following in the Properties-tagOptions field:

Album.sortTags={Album, Artist}, Artist.ignore.sort={The}, AlbumArtist.ignore.index.sort={The}

Which returns "Beatles, The" when browsing by Artist, but returns "The Beatles" when browsing by All Artists. It sorts under "B" either way. Is there any way to have it appear as "The Beatles" when browsing by Artist?

What do you have in the Artist and AlbumArtist tags in your files? Is it "The Beatles" or "Beatles, The".

If one or both of these values is tagged as "Beatles, The", you need to the reverseName option in tagOptions to see it as "The Beatles".
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)