Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ignore tag not working
01-05-2014, 10:16
Post: #11
RE: Ignore tag not working
(01-05-2014 09:17)simoncn Wrote:  
(30-04-2014 23:03)Hayden Wrote:  I see, I probably should have made myself clearer in the first place.
Thanks again Simon.
Hayden

This problem with alphaGroup and custom sort values is now fixed in update 27.

Excellent, it seems to be working fine now.
Thanks
Hayden
Find all posts by this user
Quote this message in a reply
29-08-2014, 17:06
Post: #12
RE: Ignore tag not working
Hello. I am running the most current version of Minimserver on a Synology NAS.


In MinimServer under tagOptions I have: Album.sortTags={Album, Artist},all.ignore.sort={The}

However I find that it is not ignoring the "The" in an artist name, for example "The Beatles" is found under T as opposed to B which is what I am trying to get it to do view the tagOptions noted above, any suggestions?

Thanks.

Barr
Find all posts by this user
Quote this message in a reply
29-08-2014, 17:24
Post: #13
RE: Ignore tag not working
(29-08-2014 17:06)bplexico Wrote:  Hello. I am running the most current version of Minimserver on a Synology NAS.


In MinimServer under tagOptions I have: Album.sortTags={Album, Artist},all.ignore.sort={The}

However I find that it is not ignoring the "The" in an artist name, for example "The Beatles" is found under T as opposed to B which is what I am trying to get it to do view the tagOptions noted above, any suggestions?

Thanks.

Barr

This is normally caused by using a control point that ignores the sort order sent by MinimServer and uses a strict alphabetical sort instead. For example, Naim n-Stream has this problem.
Find all posts by this user
Quote this message in a reply
29-08-2014, 18:11 (This post was last modified: 29-08-2014 18:15 by bplexico.)
Post: #14
RE: Ignore tag not working
Thanks for the response, I have used both the Lumin and Auralic Lightning DS control points. It works with neither, I will try the Kinsky.
Find all posts by this user
Quote this message in a reply
29-08-2014, 18:16 (This post was last modified: 29-08-2014 18:17 by simoncn.)
Post: #15
RE: Ignore tag not working
(29-08-2014 18:11)bplexico Wrote:  Thanks for the response, I have used both the Lumin and Auralic Lightning DS control points. It works with neither, I will try the Kinsky.

It should definitely work with Kinsky.

Edit: Did you restart MinimServer after changing this setting? This is required.
Find all posts by this user
Quote this message in a reply
30-08-2014, 07:57
Post: #16
RE: Ignore tag not working
(29-08-2014 18:16)simoncn Wrote:  
(29-08-2014 18:11)bplexico Wrote:  Thanks for the response, I have used both the Lumin and Auralic Lightning DS control points. It works with neither, I will try the Kinsky.

It should definitely work with Kinsky.

Edit: Did you restart MinimServer after changing this setting? This is required.

Hi, it works fine with the Kinsky application, so it is not an issue with my settings on Minimserver, but rather a lack of support from the Lumin and Lightning DS control applications, I appreciate the guidance.

Barr

p.s. I did a re-start of Minimserver after changing the settings.
Find all posts by this user
Quote this message in a reply
05-09-2014, 02:18 (This post was last modified: 05-09-2014 02:40 by bplexico.)
Post: #17
RE: Ignore tag not working
Update - I got this to work properly with my Lightning DS control point.

Turns out I needed to set tagOptions to "Album.sortTags={Album, Artist}, artist.ignore.*={The}"

With this change, "The Beatles" now sorts by "B"

With this change, "The Beatles" is now displayed as "Beatles, The"

Question, is there a way to modify the tagOptions such that "Beatles, The" shows up as "The Beatles" and yet still sorts under "B"?

I know I can use either a wildcard, display, sort or index. I am currently using the wildcard, if I use a combination of sort & index but not display would this do what I want?

ie

Album.sortTags={Album, Artist}, artist.ignore.display,sort={The}

or

Album.sortTags={Album, Artist}, artist.ignore.index,sort={The}
Find all posts by this user
Quote this message in a reply
05-09-2014, 07:57
Post: #18
RE: Ignore tag not working
(05-09-2014 02:18)bplexico Wrote:  Update - I got this to work properly with my Lightning DS control point.

Turns out I needed to set tagOptions to "Album.sortTags={Album, Artist}, artist.ignore.*={The}"

With this change, "The Beatles" now sorts by "B"

With this change, "The Beatles" is now displayed as "Beatles, The"

Question, is there a way to modify the tagOptions such that "Beatles, The" shows up as "The Beatles" and yet still sorts under "B"?

By doing this, you have worked around the problem of the control point ignoring the sort order sent by MinimServer. As you are now sending the index value of "The Beatles" to the control point as "Beatles, The", the control point is sorting it under its first letter B.

Quote:I know I can use either a wildcard, display, sort or index. I am currently using the wildcard, if I use a combination of sort & index but not display would this do what I want?

ie

Album.sortTags={Album, Artist}, artist.ignore.display,sort={The}

or

Album.sortTags={Album, Artist}, artist.ignore.index,sort={The}

The first won't work because it will send the index value as "The Beatles". I think the second would work if you fix the typo of having a comma instead of a period:

Album.sortTags={Album, Artist}, artist.ignore.index.sort={The}

This will send the index value as "Beatles, The", so you'll still see this in the index. It will send the display value as "The Beatles", so you will see this in the album list and on the Now Playing screen. Given the limitations of your control point, this is the best that can be achieved.
Find all posts by this user
Quote this message in a reply
05-09-2014, 21:37
Post: #19
RE: Ignore tag not working
Thanks Simon. I tried using the string:

Album.sortTags={Album, Artist}, artist.ignore.index.sort={The}

And I ended up with the artists sorting by "T" again, so i will stick with the prior setting that really did do what I intended other than displaying "The Beatles" as "Beatles, The". Good enough and appreciate the flexibility in Minimserver and the support. I realize the issue lies with my control point.

Barr
Find all posts by this user
Quote this message in a reply
05-09-2014, 22:10
Post: #20
RE: Ignore tag not working
(05-09-2014 21:37)bplexico Wrote:  Thanks Simon. I tried using the string:

Album.sortTags={Album, Artist}, artist.ignore.index.sort={The}

And I ended up with the artists sorting by "T" again, so i will stick with the prior setting that really did do what I intended other than displaying "The Beatles" as "Beatles, The". Good enough and appreciate the flexibility in Minimserver and the support. I realize the issue lies with my control point.

Barr

I tried this and it looks like there is a problem with how MinimServer handles this for the Artist index. It works OK for the All Artists index. I'll investigate and post back here when I have more information.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)