Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MinimServer & HDD Sleep
16-04-2014, 17:39
Post: #1
MinimServer & HDD Sleep
Hi, I use a QNAP 879-Pro and notice that, for a while now, my QNAP disks aren't sleeping. I've tracked this down (by stopping JRE and Minim whereby it does then sleep) to the MinimServer (possibly writing logs?) keeping the disk inactivity timer awake.

So, if you set the HDD's to sleep after 5 mins (the minimum) - every 4 mins or so Minim comes along and does something (write to a log in \public I suspect). This has the downside of re-activating the sleep time and, therefore, keeping QNAP awake.

http://wiki.qnap.com/wiki/Find_out_which...m_spindown

Can logs be disabled ? (note, these are not the ohNet logs).
Find all posts by this user
Quote this message in a reply
16-04-2014, 18:13
Post: #2
RE: MinimServer & HDD Sleep
(16-04-2014 17:39)MikeSpragg Wrote:  Hi, I use a QNAP 879-Pro and notice that, for a while now, my QNAP disks aren't sleeping. I've tracked this down (by stopping JRE and Minim whereby it does then sleep) to the MinimServer (possibly writing logs?) keeping the disk inactivity timer awake.

So, if you set the HDD's to sleep after 5 mins (the minimum) - every 4 mins or so Minim comes along and does something (write to a log in \public I suspect). This has the downside of re-activating the sleep time and, therefore, keeping QNAP awake.

http://wiki.qnap.com/wiki/Find_out_which...m_spindown

Can logs be disabled ? (note, these are not the ohNet logs).

What setting do you have for the logging level in the log window?

What setting do you have for the ohnet.debug property?
Find all posts by this user
Quote this message in a reply
17-04-2014, 15:04
Post: #3
RE: MinimServer & HDD Sleep
(16-04-2014 18:13)simoncn Wrote:  
(16-04-2014 17:39)MikeSpragg Wrote:  Hi, I use a QNAP 879-Pro and notice that, for a while now, my QNAP disks aren't sleeping. I've tracked this down (by stopping JRE and Minim whereby it does then sleep) to the MinimServer (possibly writing logs?) keeping the disk inactivity timer awake.

So, if you set the HDD's to sleep after 5 mins (the minimum) - every 4 mins or so Minim comes along and does something (write to a log in \public I suspect). This has the downside of re-activating the sleep time and, therefore, keeping QNAP awake.

http://wiki.qnap.com/wiki/Find_out_which...m_spindown

Can logs be disabled ? (note, these are not the ohNet logs).

What setting do you have for the logging level in the log window?

What setting do you have for the ohnet.debug property?

Logging level is Info (I don't think there is an option for Off) and ohNet I don't recall (whatever the default is, as I wouldn't have changed this).
Find all posts by this user
Quote this message in a reply
17-04-2014, 15:39 (This post was last modified: 17-04-2014 15:39 by simoncn.)
Post: #4
RE: MinimServer & HDD Sleep
(17-04-2014 15:04)MikeSpragg Wrote:  Logging level is Info (I don't think there is an option for Off) and ohNet I don't recall (whatever the default is, as I wouldn't have changed this).

The Info setting shouldn't write anything to the minimserver.log file while MinimServer is idle. Have you checked the minimserver.log file to confirm whether an entry is being written every 4 minutes? If this is happening, what is the entry that is being written?

The default location for the log file depends on which version of the MinimServer download you have installed. You can change this location by setting the .logFile property on the System tab to a new absolute location for the log file.
Find all posts by this user
Quote this message in a reply
17-04-2014, 16:33
Post: #5
RE: MinimServer & HDD Sleep
Hi Simon, the log file isn't being appended to (just assumed it was). If MinimServer is switched off as an app - disks go to sleep.

If MinimServer is running - just prior to the 5 min mark I then see:

============= 15/100 test, Thu Apr 17 16:23:19 BST 2014 ===============
<7>[198372.805457] smbd(21011): dirtied inode 1435 (smbXsrv_open_global.tdb) on md13
<7>[198372.805469] smbd(21011): dirtied inode 1435 (smbXsrv_open_global.tdb) on md13
<7>[198372.806268] smbd(21011): dirtied inode 1432 (locking.tdb) on md13
<7>[198372.806272] smbd(21011): dirtied inode 1432 (locking.tdb) on md13
<7>[198372.805457] smbd(21011): dirtied inode 1435 (smbXsrv_open_global.tdb) on md13
<7>[198372.805469] smbd(21011): dirtied inode 1435 (smbXsrv_open_global.tdb) on md13
<7>[198372.806268] smbd(21011): dirtied inode 1432 (locking.tdb) on md13
<7>[198372.806272] smbd(21011): dirtied inode 1432 (locking.tdb) on md13

or

<7>[198683.174209] setcfg(30734): dirtied inode 6930 (vg2.log) on md9
<7>[198683.174487] setcfg(30734): dirtied inode 6895 (vg2.log.bak) on md9
<7>[198683.177471] sed(30741): dirtied inode 6928 (vg2.logBIyp1j) on md9
<7>[198683.181313] setcfg(30749): dirtied inode 6895 (vg2.log.bak) on md9
<4>[198683.158135] lvdisplay(30693): READ block 0 on md9 (8 sectors)
<4>[198683.168377] lvs(30709): READ block 0 on md9 (8 sectors)
<4>[198683.158515] lvdisplay(30693): READ block 0 on md13 (8 sectors)
<4>[198683.168772] lvs(30709): READ block 0 on md13 (8 sectors)

============= 16/100 test, Thu Apr 17 16:24:54 BST 2014 ===============
<4>[198378.724501] kjournald(3809): WRITE block 282816 on md13 (8 sectors)
<4>[198378.725005] md13_raid1(366): WRITE block 7797308216 on sdg (8 sectors)
....

Then nothing happens - and just before disks are due to sleep (5 mins) - the above repeats:


<4>[198505.218966] md13_raid1(366): WRITE block 7797308208 on sdh (8 sectors)
<4>[198505.235114] md13_raid1(366): WRITE block 7796248680 on sdh (8 sectors)
<4>[198505.437023] md13_raid1(366): WRITE block 7797308216 on sdh (8 sectors)
<4>[198505.452094] md13_raid1(366): WRITE block 7797308208 on sdh (8 sectors)

As if it's continually writing to somewhere. The ohNet is set to Default for logs. The MinimServer log is Info.

It's odd - in that it started happening around the time you release a whole lot of updates for MinimServer 0.8.x - and the disks have never slept since! And, if I turn off Minim, it reverts to normal.
Something has to be keeping it awake and it must be from Minim (or linked modules - JRE?).
Find all posts by this user
Quote this message in a reply
17-04-2014, 17:12 (This post was last modified: 17-04-2014 17:12 by simoncn.)
Post: #6
RE: MinimServer & HDD Sleep
(17-04-2014 16:33)MikeSpragg Wrote:  It's odd - in that it started happening around the time you release a whole lot of updates for MinimServer 0.8.x - and the disks have never slept since! And, if I turn off Minim, it reverts to normal.
Something has to be keeping it awake and it must be from Minim (or linked modules - JRE?).

There is nothing in these messages to indicate that either MinimServer or Java is writing to the disk.

There are some references in the messages to SMB file sharing activity (smbd and locking.tdb). There are known issues with SMB activity preventing disks from spinning down.

I suspect that some other machine on your network is interacting with MinimServer when MinimServer is active, and this is causing the other machine to access an SMB network share on your QNAP NAS.

To identify which machine is doing this, you could power off the other machines on your network one by one until the QNAP disks spin down.
Find all posts by this user
Quote this message in a reply
17-04-2014, 17:17 (This post was last modified: 17-04-2014 17:29 by MikeSpragg.)
Post: #7
RE: MinimServer & HDD Sleep
(17-04-2014 17:12)simoncn Wrote:  
(17-04-2014 16:33)MikeSpragg Wrote:  It's odd - in that it started happening around the time you release a whole lot of updates for MinimServer 0.8.x - and the disks have never slept since! And, if I turn off Minim, it reverts to normal.
Something has to be keeping it awake and it must be from Minim (or linked modules - JRE?).

There is nothing in these messages to indicate that either MinimServer or Java is writing to the disk.

There are some references in the messages to SMB file sharing activity (smbd and locking.tdb). There are known issues with SMB activity preventing disks from spinning down.

I suspect that some other machine on your network is interacting with MinimServer when MinimServer is active, and this is causing the other machine to access an SMB network share on your QNAP NAS.

To identify which machine is doing this, you could power off the other machines on your network one by one until the QNAP disks spin down.

Hi, unfortunately, there are no other machines. If I physically disconnect the network cables - still occurs. So, with or without network - no spin down. I've just tested this a little more with disabling MinimServer and leaving JRE running. This works still - the disks spin down. If I re-enable Minim - back to square one... never shuts down.
Find all posts by this user
Quote this message in a reply
17-04-2014, 17:40
Post: #8
RE: MinimServer & HDD Sleep
(17-04-2014 17:17)MikeSpragg Wrote:  Hi, unfortunately, there are no other machines. If I physically disconnect the network cables - still occurs. So, with or without network - no spin down. I've just tested this a little more with disabling MinimServer and leaving JRE running. This works still - the disks spin down. If I re-enable Minim - back to square one... never shuts down.

Please set the MinimServer logging level to Trace and repeat this test. If MinimServer is doing something periodically when it is idle, there's a chance that this activity might show up in the minimserver.log file.
Find all posts by this user
Quote this message in a reply
17-04-2014, 18:09
Post: #9
RE: MinimServer & HDD Sleep
(17-04-2014 17:40)simoncn Wrote:  
(17-04-2014 17:17)MikeSpragg Wrote:  Hi, unfortunately, there are no other machines. If I physically disconnect the network cables - still occurs. So, with or without network - no spin down. I've just tested this a little more with disabling MinimServer and leaving JRE running. This works still - the disks spin down. If I re-enable Minim - back to square one... never shuts down.

Please set the MinimServer logging level to Trace and repeat this test. If MinimServer is doing something periodically when it is idle, there's a chance that this activity might show up in the minimserver.log file.

OK, here you go - if you skip to the end and look for >> *****GOES QUIET******** ---vvv Then awakens here you'll notice it mentions about ohNet - and repeats this at 17:52, 17:54, 17:57, 18:05

It looks like a device is accessing Minim - but I've checked all devices and nothing is running that would.


Attached File(s)
.zip  minimserver.zip (Size: 211.18 KB / Downloads: 2)
Find all posts by this user
Quote this message in a reply
17-04-2014, 18:32
Post: #10
RE: MinimServer & HDD Sleep
(17-04-2014 18:09)MikeSpragg Wrote:  
(17-04-2014 17:40)simoncn Wrote:  
(17-04-2014 17:17)MikeSpragg Wrote:  Hi, unfortunately, there are no other machines. If I physically disconnect the network cables - still occurs. So, with or without network - no spin down. I've just tested this a little more with disabling MinimServer and leaving JRE running. This works still - the disks spin down. If I re-enable Minim - back to square one... never shuts down.

Please set the MinimServer logging level to Trace and repeat this test. If MinimServer is doing something periodically when it is idle, there's a chance that this activity might show up in the minimserver.log file.

OK, here you go - if you skip to the end and look for >> *****GOES QUIET******** ---vvv Then awakens here you'll notice it mentions about ohNet - and repeats this at 17:52, 17:54, 17:57, 18:05

It looks like a device is accessing Minim - but I've checked all devices and nothing is running that would.

Aha, I set ohNet logging to "None" - that's fixed it by the seems of things !
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)