Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Configuring radio streams with minimwatch
14-04-2014, 14:25
Post: #31
RE: Configuring radio streams with minimwatch
(14-04-2014 10:15)simoncn Wrote:  
(13-04-2014 15:41)clio09 Wrote:  I am sorry but I misread your user guide instructions. My interpretation is that the stream.converter needed to be set to *:L16. That was where I was getting the error. I am able to set the stream.transcode to *:L16, but still cannot get the stream to play. I imagine my renderer does not support streaming at all unless there is something else we can try.

Streaming a radio station is very similar to streaming a local audio file from your NAS. If this works, your renderer supports streaming.

I think the next step should be to determine the streaming capabilities of your renderer.

1) Can you use PlugPlayer to play audio files on your renderer? If so, what kinds of files (e.g., FLAC, ALAC, AIFF, WAV, MP3, MP4) are you able to play?

I only have WAV and AIFF files and they play fine.

2) If you enable transcoding in MinimStreamer, what kinds of transcoded streams are you able to play? For example, if you are able to play FLAC files in step 1) and you set stream.transcode to flac:wav or flac:L16, do these play on your renderer?

Given I play just the files mentioned above I do not transcode. From what I read in the user guide you cannot transcode a WAV file. For example 16 bit WAV to 24 bit WAV. However, with the stream.transcode set to *:WAV, the AIFF and WAV files play but in their native format.

Note: After making any change to stream.transcode, you need to quit and restart PlugPlayer. This is because PlugPlayer caches the previous stream information until it is restarted. If you didn't do this in your previous test with *:L16, this might be the reason why the L16 stream wouldn't play.

How does one quit PlugPlayer? This morning when I started it the streams still would not play. I want to test *:L16 again but cannot find an exit or quit function.

I have posted my replies within your quoted post above.
Find all posts by this user
Quote this message in a reply
14-04-2014, 17:26
Post: #32
RE: Configuring radio streams with minimwatch
(14-04-2014 14:25)clio09 Wrote:  I only have WAV and AIFF files and they play fine.

OK, this means it should be possible to play a radio station as a transcoded WAV stream.

Quote:Given I play just the files mentioned above I do not transcode. From what I read in the user guide you cannot transcode a WAV file. For example 16 bit WAV to 24 bit WAV. However, with the stream.transcode set to *:WAV, the AIFF and WAV files play but in their native format.

You can't transcode AIFF or WAV files using MinimStreamer.

Quote:How does one quit PlugPlayer? This morning when I started it the streams still would not play. I want to test *:L16 again but cannot find an exit or quit function.

If you are running PlugPlayer on a Mac, there should be a Quit PlugPlayer option available from the menu bar when PlugPlayer is the foreground application. Alternatively, you can use the Mac's Force Quit option.

If you are running PlugPlayer on an iPhone or iPod, you can double-click from the home screen, hold the PliugPlayer icon until it starts shaking, then click the "No Entry" symbol in the top left corner. I presume the iPad has something similar, but I don't have one of those.
Find all posts by this user
Quote this message in a reply
14-04-2014, 21:06 (This post was last modified: 14-04-2014 21:10 by clio09.)
Post: #33
RE: Configuring radio streams with minimwatch
(14-04-2014 17:26)simoncn Wrote:  
(14-04-2014 14:25)clio09 Wrote:  I only have WAV and AIFF files and they play fine.

OK, this means it should be possible to play a radio station as a transcoded WAV stream.

Quote:Given I play just the files mentioned above I do not transcode. From what I read in the user guide you cannot transcode a WAV file. For example 16 bit WAV to 24 bit WAV. However, with the stream.transcode set to *:WAV, the AIFF and WAV files play but in their native format.

You can't transcode AIFF or WAV files using MinimStreamer.

Quote:How does one quit PlugPlayer? This morning when I started it the streams still would not play. I want to test *:L16 again but cannot find an exit or quit function.

If you are running PlugPlayer on a Mac, there should be a Quit PlugPlayer option available from the menu bar when PlugPlayer is the foreground application. Alternatively, you can use the Mac's Force Quit option.

If you are running PlugPlayer on an iPhone or iPod, you can double-click from the home screen, hold the PliugPlayer icon until it starts shaking, then click the "No Entry" symbol in the top left corner. I presume the iPad has something similar, but I don't have one of those.

Okay figured out how to quit PlugPlayer and tried again using 8:wav and *:L16. This time I also monitored the Cantata log. For one, it showed *:L16 is not a supported format. Second, it showed that WAV was started but the stopped. I attached a copy of the log for viewing. I also sent this to the Resolution Audio folks.


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
14-04-2014, 21:12 (This post was last modified: 14-04-2014 21:19 by simoncn.)
Post: #34
RE: Configuring radio streams with minimwatch
(14-04-2014 21:06)clio09 Wrote:  Okay figured out how to quit PlugPlayer and tried again using 8:wav and *:L16. This time I also monitored the Cantata log. For one, it showed *:L16 is not a supported format. Second, it showed that WAV was started but the stopped. I attached a copy of the log for viewing. I also sent this to the Resolution Audio folks.

I saw something similar (started and then stopped) in the MinimServer log that you sent previously. It seems there is something in the transcoded WAV file that the renderer doesn't like. At the moment, I don't know what this is.

One possibility is that the length of the transcoded stream (default 4GB) is too large for the renderer to handle. Can you try setting the stream.transcode property to *:wav-10MB to see whether this makes a difference?
Find all posts by this user
Quote this message in a reply
14-04-2014, 23:53 (This post was last modified: 15-04-2014 00:00 by clio09.)
Post: #35
RE: Configuring radio streams with minimwatch
(14-04-2014 21:12)simoncn Wrote:  
(14-04-2014 21:06)clio09 Wrote:  Okay figured out how to quit PlugPlayer and tried again using 8:wav and *:L16. This time I also monitored the Cantata log. For one, it showed *:L16 is not a supported format. Second, it showed that WAV was started but the stopped. I attached a copy of the log for viewing. I also sent this to the Resolution Audio folks.

I saw something similar (started and then stopped) in the MinimServer log that you sent previously. It seems there is something in the transcoded WAV file that the renderer doesn't like. At the moment, I don't know what this is.

One possibility is that the length of the transcoded stream (default 4GB) is too large for the renderer to handle. Can you try setting the stream.transcode property to *:wav-10MB to see whether this makes a difference?

Well we have semi success. This setting does result in the renderer playing music, but only in one minute chunks. At the end of a minute I have to hit the play button again and the song continues. If during that minute there is a transition to another song that song will play for the rest of that one minute chunk. Then it is time to hit the play button again. I have noticed that going from -10MB to -25MB gives me over 2 minutes of music. I guess I can play around with that until I get a decent number of minutes. If you have any other suggestions they would be appreciated.
Find all posts by this user
Quote this message in a reply
15-04-2014, 09:07
Post: #36
RE: Configuring radio streams with minimwatch
(14-04-2014 23:53)clio09 Wrote:  Well we have semi success. This setting does result in the renderer playing music, but only in one minute chunks. At the end of a minute I have to hit the play button again and the song continues. If during that minute there is a transition to another song that song will play for the rest of that one minute chunk. Then it is time to hit the play button again. I have noticed that going from -10MB to -25MB gives me over 2 minutes of music. I guess I can play around with that until I get a decent number of minutes. If you have any other suggestions they would be appreciated.

OK, this is positive progress. Please try two other settings:

*:wav-2GB
*:wav-0KB

The first setting (if it works with your renderer) will give you a fixed limit of about 3 hours. The second setting (if it works with your renderer) will give you unlimited time.
Find all posts by this user
Quote this message in a reply
18-04-2014, 15:55
Post: #37
RE: Configuring radio streams with minimwatch
(15-04-2014 09:07)simoncn Wrote:  
(14-04-2014 23:53)clio09 Wrote:  Well we have semi success. This setting does result in the renderer playing music, but only in one minute chunks. At the end of a minute I have to hit the play button again and the song continues. If during that minute there is a transition to another song that song will play for the rest of that one minute chunk. Then it is time to hit the play button again. I have noticed that going from -10MB to -25MB gives me over 2 minutes of music. I guess I can play around with that until I get a decent number of minutes. If you have any other suggestions they would be appreciated.

OK, this is positive progress. Please try two other settings:

*:wav-2GB
*:wav-0KB

The first setting (if it works with your renderer) will give you a fixed limit of about 3 hours. The second setting (if it works with your renderer) will give you unlimited time.

Sorry I have been out of town for a few days. I can report the -2GB setting works and provides just over 200 minutes of playing time. The -0KB setting does not work.

FWIW the Resolution Audio folks reported that the renderer does not support Internet radio streaming, but they were happy to know of this solution in MinimServer and will pass it on to their customers who wish to use this feature with their renderer.
Find all posts by this user
Quote this message in a reply
18-04-2014, 16:22 (This post was last modified: 18-04-2014 16:23 by simoncn.)
Post: #38
RE: Configuring radio streams with minimwatch
(18-04-2014 15:55)clio09 Wrote:  Sorry I have been out of town for a few days. I can report the -2GB setting works and provides just over 200 minutes of playing time. The -0KB setting does not work.

Thanks for checking this. This means there is a bug/limitation in the renderer's support for WAV files. The WAV spec allows a file size up to 4294967295 (2**32-1) but the renderer is only accepting a file size up to 2147483647 (2**31-1). This is presumably because the renderer is treating the file size field of the WAV header as a signed integer instead of an unsigned integer.

Quote:FWIW the Resolution Audio folks reported that the renderer does not support Internet radio streaming, but they were happy to know of this solution in MinimServer and will pass it on to their customers who wish to use this feature with their renderer.

It would be good if Resolution Audio could fix the renderer firmware to allow a maximum WAV file size of 2**32-1. If they can do this, it would allow the MinimServer *:wav transcode setting to work with this renderer. Also, the maximum playing time would be doubled to about 400 minutes.
Find all posts by this user
Quote this message in a reply
19-04-2014, 00:04
Post: #39
RE: Configuring radio streams with minimwatch
I sent the information you provided to Resolution Audio and they acknowledged the error on their end. They will provide a fix in a future firmware update.
Find all posts by this user
Quote this message in a reply
24-04-2014, 16:41
Post: #40
RE: Configuring radio streams with minimwatch
The fix was sent to me and I updated the firmware. Now *:wav works as the stream.transcode and when I play a stream I get a little over 400 minutes. Is this correct?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)