Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Configuring radio streams with minimwatch
11-04-2014, 23:44 (This post was last modified: 11-04-2014 23:46 by clio09.)
Post: #21
RE: Configuring radio streams with minimwatch
(11-04-2014 21:16)simoncn Wrote:  
(11-04-2014 20:45)clio09 Wrote:  No, I have a Resolution Audio Cantata as a renderer. I am thinking now that it may not support streaming but I also think I probably made some errors setting up the Linn Radio .m3u files.

There is some discussion of the Resolution Audio Cantata in this thread. It seems this device supports streaming but has a few issues with not being fully capable as a UPnP renderer.

Can you attach your .m3u files to a forum post?

I have read that thread before. PlugPlayer has no issues with the Cantata. Kinsky cannot find it, nor can eLyric. Bubble was fine but unstable. So for now I am sticking with PlugPlayer.

Attached are the three files I created. I see all three in the Playlists. However, only Linn Radio Jazz has the two files you mention should be there: [Linn] Linn Radio Jazz and Linn Radio Jazz. The other two are missing the [Linn] file. None will play but I think I need to do more configuration. Also, the MininServer log has an error message for the Linn Radio file indicating there is a duplicate file.


Attached File(s)
.txt  Linn Radio Jazz.txt (Size: 74 bytes / Downloads: 18)
.txt  Linn Radio Classical.txt (Size: 79 bytes / Downloads: 8)
.txt  Linn Radio.txt (Size: 69 bytes / Downloads: 7)
Find all posts by this user
Quote this message in a reply
12-04-2014, 01:36 (This post was last modified: 12-04-2014 11:57 by simoncn.)
Post: #22
RE: Configuring radio streams with minimwatch
(10-04-2014 23:51)largestgasman Wrote:  
(10-04-2014 22:24)simoncn Wrote:  
(09-04-2014 14:32)largestgasman Wrote:  Here is the log file as requested. With any luck I have managed to attach it properly this time!
Watching the log develop as I select items it was noticeable that nothing was added to the log as I pressed to select the radio stream.

Thanks for sending this.

Some of these URLs still contain '...'. This should be fixed, but it doesn't explain why the NDX isn't sending any requests to MinimServer to play these streams.

What setting do you have in n-Stream for UPnP compatibility mode? Can you try changing this to see if it makes any difference to what requests are sent by the NDX to MinimServer?

Hi there. Yes, I decided to not fix them up until I got the system working. I'll look into sorting them out to get rid of any errors.

I have UPnP compatibility mode turned off. I will flick it to on tonight when I get home and see if it makes a difference.
cheers

Hi.

Success!

I turned on compatibility mode and each of the stations now plays. I had some temporary issues with the Linn Stations that wouldn't play although the NDX display showed that the command was, at least, recognised.
I left it alone for a bit and it all seemed to fix up.

So, until Naim fix the design problem with their streamers to allow 320Kbps radio streams to play via wired network at least your software allows me to stream these stations via UPnP. Naim should pay you!

I have pasted in the m3u file that I am using in case others want to do this too. Thanks for all your guidance.

#EXTM3U
#EXTINF:-1,[LCl] Linn Radio Classical
http://radio.linnrecords.com/cast/tunein.php/linnclassical/playlist.pls
#EXTINF:-1,[LRa] Linn Radio
http://radio.linnrecords.com/cast/tunein.php/linnradio/playlist.pls
#EXTINF:-1,[LJR] Linn Radio Jazz
http://radio.linnrecords.com/cast/tunein.php/linnjazz/playlist.pls
#EXTINF:-1,[BBC1] BBC Radio 1
http://www.bbc.co.uk/radio/listen/live/r1_aaclca.pls
#EXTINF:-1,[BBC2] BBC Radio 2
http://www.bbc.co.uk/radio/listen/live/r2_aaclca.pls
#EXTINF:-1,[BBC3] BBC Radio 3
http://www.bbc.co.uk/radio/listen/live/r3_aaclca.pls
#EXTINF:-1,[BBC6] BBC 6 Music
http://www.bbc.co.uk/radio/listen/live/r6_aaclca.pls
#EXTINF:-1,[ARa] Absolute Radio
http://network.absoluteradio.co.uk/core/audio/mp3/live.pls?service=vrhq
#EXTINF:-1,[Cap] Capital Radio
http://ice-the.musicradio.com:80/CapitalMP3
#EXTINF:-1,[CFM] Classic FM
http://ice-the.musicradio.com:80/ClassicFMMP3
#EXTINF:-1,[RPA] Radio Paradise 320
http://stream-uk1.radioparadise.com:80/aac-320
#EXTINF:-1,[NAIM] Naim Radio
http://37.130.228.60:8090/

john

Note: this post was edited by simoncn to remove "..." from some of the URLs.
Find all posts by this user
Quote this message in a reply
12-04-2014, 12:03
Post: #23
RE: Configuring radio streams with minimwatch
(11-04-2014 23:44)clio09 Wrote:  I have read that thread before. PlugPlayer has no issues with the Cantata. Kinsky cannot find it, nor can eLyric. Bubble was fine but unstable. So for now I am sticking with PlugPlayer.

Attached are the three files I created. I see all three in the Playlists. However, only Linn Radio Jazz has the two files you mention should be there: [Linn] Linn Radio Jazz and Linn Radio Jazz. The other two are missing the [Linn] file. None will play but I think I need to do more configuration. Also, the MininServer log has an error message for the Linn Radio file indicating there is a duplicate file.

Each stream needs to have a unique stream ID, and you have given all three streams the same ID. You should see error messages in the log about this. This is why you are only seeing the double entry for one of these streams.

To get the streams to play, you could try adding *:wav to the stream.transcode property. This adds a file extension to the stream URL to indicate its audio format. Some renderers won't play a network stream unless this file extension is present.
Find all posts by this user
Quote this message in a reply
12-04-2014, 12:12
Post: #24
RE: Configuring radio streams with minimwatch
(12-04-2014 01:36)largestgasman Wrote:  Hi.

Success!

I turned on compatibility mode and each of the stations now plays. I had some temporary issues with the Linn Stations that wouldn't play although the NDX display showed that the command was, at least, recognised.
I left it alone for a bit and it all seemed to fix up.

So, until Naim fix the design problem with their streamers to allow 320Kbps radio streams to play via wired network at least your software allows me to stream these stations via UPnP. Naim should pay you!

I'm very pleased to hear this. Does the NDX require *:wav to be set in stream.transcode to make the streams play, or do they play without this?

I have a feeling that it's not very likely I'll be receiving a donation from Naim. Smile

Quote:I have pasted in the m3u file that I am using in case others want to do this too. Thanks for all your guidance.

Thanks very much! As you'll see, I have edited your post to override the automated replacement by the forum software of http: URLs with links that may contain "...".
Find all posts by this user
Quote this message in a reply
12-04-2014, 16:09 (This post was last modified: 12-04-2014 16:22 by clio09.)
Post: #25
RE: Configuring radio streams with minimwatch
(12-04-2014 12:03)simoncn Wrote:  
(11-04-2014 23:44)clio09 Wrote:  I have read that thread before. PlugPlayer has no issues with the Cantata. Kinsky cannot find it, nor can eLyric. Bubble was fine but unstable. So for now I am sticking with PlugPlayer.

Attached are the three files I created. I see all three in the Playlists. However, only Linn Radio Jazz has the two files you mention should be there: [Linn] Linn Radio Jazz and Linn Radio Jazz. The other two are missing the [Linn] file. None will play but I think I need to do more configuration. Also, the MininServer log has an error message for the Linn Radio file indicating there is a duplicate file.

Each stream needs to have a unique stream ID, and you have given all three streams the same ID. You should see error messages in the log about this. This is why you are only seeing the double entry for one of these streams.

To get the streams to play, you could try adding *:wav to the stream.transcode property. This adds a file extension to the stream URL to indicate its audio format. Some renderers won't play a network stream unless this file extension is present.

I fixed the error and now everything shows up correctly. Thanks for the help on that. However, even though I added *:wav to the stream.transcode nothing plays. Would you have any other suggestions? I generated a debug report and attached it here of that helps.

Also, the stream.converter is set to ffmpeg. Is this correct? I did try to add *:L16 but got an error that it was not supported.


Attached File(s)
.txt  Log 1.txt (Size: 25.85 KB / Downloads: 4)
Find all posts by this user
Quote this message in a reply
12-04-2014, 17:37
Post: #26
RE: Configuring radio streams with minimwatch
(12-04-2014 16:09)clio09 Wrote:  I fixed the error and now everything shows up correctly. Thanks for the help on that. However, even though I added *:wav to the stream.transcode nothing plays. Would you have any other suggestions? I generated a debug report and attached it here of that helps.

Also, the stream.converter is set to ffmpeg. Is this correct? I did try to add *:L16 but got an error that it was not supported.

From the debug log, ffmpeg is working fine. MinimServer is sending the WAV stream to the renderer, but the renderer is unable to handle it.

Which versions of MinimServer and MinimStreamer are you running? I am on the latest versions of both and *:L16 is working for me.

If you are on an older version, this could explain the problem. There was a fix in MinimStreamer 0.3.13 that might be needed to get the renderer to play the WAV stream.
Find all posts by this user
Quote this message in a reply
12-04-2014, 18:16
Post: #27
RE: Configuring radio streams with minimwatch
(12-04-2014 17:37)simoncn Wrote:  
(12-04-2014 16:09)clio09 Wrote:  I fixed the error and now everything shows up correctly. Thanks for the help on that. However, even though I added *:wav to the stream.transcode nothing plays. Would you have any other suggestions? I generated a debug report and attached it here of that helps.

Also, the stream.converter is set to ffmpeg. Is this correct? I did try to add *:L16 but got an error that it was not supported.

From the debug log, ffmpeg is working fine. MinimServer is sending the WAV stream to the renderer, but the renderer is unable to handle it.

Which versions of MinimServer and MinimStreamer are you running? I am on the latest versions of both and *:L16 is working for me.

If you are on an older version, this could explain the problem. There was a fix in MinimStreamer 0.3.13 that might be needed to get the renderer to play the WAV stream.

I am on MinimServer 0.8.1 update 24 and MinimStreamer 0.3.15.
Find all posts by this user
Quote this message in a reply
13-04-2014, 08:57
Post: #28
RE: Configuring radio streams with minimwatch
(12-04-2014 18:16)clio09 Wrote:  I am on MinimServer 0.8.1 update 24 and MinimStreamer 0.3.15.

It is possible that your renderer might not be able to handle WAV streams.

What error message do you get when you set the stream.transcode property to *:L16?

Do you get this error message as soon as you try to set this value, or when you next restart MinimServer?
Find all posts by this user
Quote this message in a reply
13-04-2014, 15:41
Post: #29
RE: Configuring radio streams with minimwatch
(13-04-2014 08:57)simoncn Wrote:  
(12-04-2014 18:16)clio09 Wrote:  I am on MinimServer 0.8.1 update 24 and MinimStreamer 0.3.15.

It is possible that your renderer might not be able to handle WAV streams.

What error message do you get when you set the stream.transcode property to *:L16?

Do you get this error message as soon as you try to set this value, or when you next restart MinimServer?

I am sorry but I misread your user guide instructions. My interpretation is that the stream.converter needed to be set to *:L16. That was where I was getting the error. I am able to set the stream.transcode to *:L16, but still cannot get the stream to play. I imagine my renderer does not support streaming at all unless there is something else we can try.
Find all posts by this user
Quote this message in a reply
14-04-2014, 10:15 (This post was last modified: 14-04-2014 10:40 by simoncn.)
Post: #30
RE: Configuring radio streams with minimwatch
(13-04-2014 15:41)clio09 Wrote:  I am sorry but I misread your user guide instructions. My interpretation is that the stream.converter needed to be set to *:L16. That was where I was getting the error. I am able to set the stream.transcode to *:L16, but still cannot get the stream to play. I imagine my renderer does not support streaming at all unless there is something else we can try.

Streaming a radio station is very similar to streaming a local audio file from your NAS. If this works, your renderer supports streaming.

I think the next step should be to determine the streaming capabilities of your renderer.

1) Can you use PlugPlayer to play audio files on your renderer? If so, what kinds of files (e.g., FLAC, ALAC, AIFF, WAV, MP3, MP4) are you able to play?

2) If you enable transcoding in MinimStreamer, what kinds of transcoded streams are you able to play? For example, if you are able to play FLAC files in step 1) and you set stream.transcode to flac:wav or flac:L16, do these play on your renderer?

Note: After making any change to stream.transcode, you need to quit and restart PlugPlayer. This is because PlugPlayer caches the previous stream information until it is restarted. If you didn't do this in your previous test with *:L16, this might be the reason why the L16 stream wouldn't play.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)