Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Transcoding on Windows pc
10-01-2014, 20:43
Post: #1
Transcoding on Windows pc
I couldn't find any guideline on how to install the transcoder hence my post...

I successfully installed the minimserver and minimstreamer on a windows pc but I didn't find how to get ffmpeg installed/working. I downloaded a version from 'Zeranoe FFmpeg builds' but have no idea where to unpack this to make it work.

In the system tab (Minimwatch), I added 'ffmpeg' as stream.convertor property. I also tried to copy the path to it...

Any suggestions ?
Find all posts by this user
Quote this message in a reply
10-01-2014, 21:29
Post: #2
RE: Transcoding on Windows pc
(10-01-2014 20:43)ppienter Wrote:  I couldn't find any guideline on how to install the transcoder hence my post...

I successfully installed the minimserver and minimstreamer on a windows pc but I didn't find how to get ffmpeg installed/working. I downloaded a version from 'Zeranoe FFmpeg builds' but have no idea where to unpack this to make it work.

In the system tab (Minimwatch), I added 'ffmpeg' as stream.convertor property. I also tried to copy the path to it...

Any suggestions ?

You can unpack the Zeranoe download into any folder. You then need to open Control Panel > System > Advanced system settings > Environment Variables > System variables and edit the Path variable to add the folder containing the ffmpeg.exe file (this folder is likely to end in \bin). After doing this, you can check your Path setting by opening a new command window and typing 'ffmpeg'. If your Path setting is correct, you should see something like this:

Code:
ffmpeg version N-59480-g8feaa83 Copyright (c) 2000-2014 the FFmpeg developers
  built on Jan  1 2014 22:04:31 with gcc 4.8.2 (GCC)
  configuration: --disable-static --enable-shared --enable-gpl --enable-version3 --disable
-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-
gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfree
type --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-lib
opencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-l
ibrtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --en
able-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable
-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-
libxvid --enable-zlib
  libavutil      52. 59.100 / 52. 59.100
  libavcodec     55. 47.100 / 55. 47.100
  libavformat    55. 22.102 / 55. 22.102
  libavdevice    55.  5.102 / 55.  5.102
  libavfilter     4.  0.103 /  4.  0.103
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

If you see this output, you should be able to set the stream.converter property to 'ffmpeg' without getting an error message,
Find all posts by this user
Quote this message in a reply
10-01-2014, 22:30
Post: #3
RE: Transcoding on Windows pc
(10-01-2014 21:29)simoncn Wrote:  
(10-01-2014 20:43)ppienter Wrote:  I couldn't find any guideline on how to install the transcoder hence my post...

I successfully installed the minimserver and minimstreamer on a windows pc but I didn't find how to get ffmpeg installed/working. I downloaded a version from 'Zeranoe FFmpeg builds' but have no idea where to unpack this to make it work.

In the system tab (Minimwatch), I added 'ffmpeg' as stream.convertor property. I also tried to copy the path to it...

Any suggestions ?

You can unpack the Zeranoe download into any folder. You then need to open Control Panel > System > Advanced system settings > Environment Variables > System variables and edit the Path variable to add the folder containing the ffmpeg.exe file (this folder is likely to end in \bin). After doing this, you can check your Path setting by opening a new command window and typing 'ffmpeg'. If your Path setting is correct, you should see something like this:

Code:
ffmpeg version N-59480-g8feaa83 Copyright (c) 2000-2014 the FFmpeg developers
  built on Jan  1 2014 22:04:31 with gcc 4.8.2 (GCC)
  configuration: --disable-static --enable-shared --enable-gpl --enable-version3 --disable
-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-
gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfree
type --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-lib
opencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-l
ibrtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --en
able-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable
-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-
libxvid --enable-zlib
  libavutil      52. 59.100 / 52. 59.100
  libavcodec     55. 47.100 / 55. 47.100
  libavformat    55. 22.102 / 55. 22.102
  libavdevice    55.  5.102 / 55.  5.102
  libavfilter     4.  0.103 /  4.  0.103
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

If you see this output, you should be able to set the stream.converter property to 'ffmpeg' without getting an error message,

I'm able to see the message when typing 'ffmpeg' into a command box but I'm still getting the error when filling in the property.

   
   
Find all posts by this user
Quote this message in a reply
10-01-2014, 23:00
Post: #4
RE: Transcoding on Windows pc
(10-01-2014 22:30)ppienter Wrote:  I'm able to see the message when typing 'ffmpeg' into a command box but I'm still getting the error when filling in the property.

Please try exiting MinimServer (by selecting Exit from the minim icon) and restarting it. After you have changed the Path value, MinimServer needs to be restarted to pick up the new value.
Find all posts by this user
Quote this message in a reply
10-01-2014, 23:44
Post: #5
RE: Transcoding on Windows pc
(10-01-2014 23:00)simoncn Wrote:  
(10-01-2014 22:30)ppienter Wrote:  I'm able to see the message when typing 'ffmpeg' into a command box but I'm still getting the error when filling in the property.

Please try exiting MinimServer (by selecting Exit from the minim icon) and restarting it. After you have changed the Path value, MinimServer needs to be restarted to pick up the new value.

This did the trick ! Thanks !
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)