Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cambridge CXN V2 functionality?
11-06-2021, 10:03
Post: #31
Update: Cambridge CXN V2 functionality?
(09-06-2021 10:35)MarmiteSandwich Wrote:  As suggested by @JohnT, I approached my local Richer Sounds, who were very amenable to a trial loan of their shop model CXNv2, on which I have carried out some preliminary tests. First impressions:-

The Good News.
- The analogue-out sound quality was very impressive and a big improvement on my existing setup, which is really a reflection of my existing DAC, not a digital issue.
- I did manage to play Internet radio, including BBC, from MinimStreamer, using the attached playlist. I can't vouch for all the stations but my regulars worked - R3, R4, KUVO, Verulam. I only managed this by either using the StreamMagic app, or by using the Windows control point UPPlay. Attempts to use BubbleUPnP, or the Bubble OpenHome server for radio were not successful.
- ALAC files (with a .m4a extension) play truly gaplessly.

The Bad News.
- Serious: m4a files containing lossy aac data play, but every track suffers from a small stutter within the first 5 seconds of starting. In addition, the gapless functionality is not good - there is an audible discontinuity at the transition. You can hear the join. Combined with the stutter, it means that albums with continuous playing music across track boundaries sound very bad. This is a deal breaker for me, and I have referred it to Cambridge Audio for their comments.
- Annoying: UPnP seems to be implemented in a minimalist way, and I'm not sure it is following all the rules. CA really want you to use their app, and I would say probably most CXN users do this. BubbleUPnP and UPPlay work in ways inconsistent with other renderers (well, upmpdcli on a Pi, anyway). I am having trouble getting the BubbleUPnP server to emulate OpenHome well, so that I can use multiple control points on different platforms. There are lots of detailed niggles I could report, but they may be fixable with some help from the developers of these 3rd party software products.

Update after some experimenting:-
I referred the problem of bad aac file experience to Cambridge Audio via their web site support page and got a very quick response. This included a suggestion to install the latest beta version of the firmware, which exists as an option in the device management. I did this and there were several improvements. The stutter at the beginning of files disappeared, but the bad gapless experience persisted. I reproduced this via the USB drive option which proved it was not an issue with my LAN. CA support then tested some files I uploaded and seemed to accept that there was an issue. At any rate it has been referred to their "engineering team", and the support ticket left open.

In addition to the aac file improvement, the beta firmware ("Early Updates" they call this option), seemed to interact with UPnP control points in a more stable way, which was encouraging.

On advice from Simon, I have updated the radio stream playlist file, which resolved the problem with radio via BubbleUPnP Server.

Outstanding issues:-
Unless I re-rip all albums which have gapless music into ALAC or FLAC, I will have annoying blips when tracks change on some albums, until the engineering team sort it out.

There is an irritating problem with BubbleUPnP Server, whereby the OpenHome version of the CXN does not always appear on all control points, in particular 2 different installations of Android BubbleUPnP. It comes and goes, although other OpenHome versions of renderers via the server appear constantly. This is probably not helped by the Chromecast Built-In function which advertises itself on the network with the same IP address and friendly name as the CXN UPnP renderer. If you change it in Google Home to something else, the CXN changes its name to the same as the Chromecast. I have enquired about a feature to name it something else (or just turn it off when not required), and I will investigate ways of making the OpenHome renderer appear more readily and consistently on BubbleUPnP control points.

The Windows UPPlay control point has a tendency to lose track of where the renderer is up to in the queue and current track. I have noticed this on other occasions with this control point and other Server/OH renderers and may be related to the BubbleUPnP Server issue above. If not, I can refer it to the developer.

Overall still not decided, since one of the reasons for opting for CA was to minimise technical faffing about and bodging to get things to work how I want/how they should. The Pi with upmpdcli/mpd is currently working fine! The devices suggested by Peter StreamMagic are still an option.

Marmite.

Server :: RaspberryPi3B+>Minimserver 2
Control : Android>BubbleUPnP / W10>Upplay / W10>Kazoo / iPhone>Kazoo
Renderer: Cambridge Audio CXN V2
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Update: Cambridge CXN V2 functionality? - MarmiteSandwich - 11-06-2021 10:03

Forum Jump:


User(s) browsing this thread: 1 Guest(s)