|
Synology backup: default.profile Permission denied
|
|
26-12-2022, 12:36
Post: #1
|
|||
|
|||
|
Synology backup: default.profile Permission denied
Hello,
I am using dirvish to backup my Synology NAS data to an external hard disc via my linux PC. Internally there is done a "rsync admin@mynas" command to sync the data. This works fine usually. But from time to time an error occurs when backing up the minimserver /volume1/MinimServer/etc/ directory: Code: rsync: send_files failed to open "/volume1/MinimServer/etc/profiles/default.profile": Permission denied (13)This is what the permissions do look like on the NAS: Code: admin@troken:~$ ls -l /volume1/MinimServer/etc/I had this permission problem with one (or more) of the recent files before two times and had to set permissions to "chmod a+r ..." for them. After this everything works fine again. (Now I wonder that they are writable, too, for everybody.) So I would like to ask if it is possible that minimserver could create all files readable for everybody? (But I think it was better to not make them writable for everybody? But I am not sure about this.) Thanks Gert |
|||
|
26-12-2022, 23:01
Post: #2
|
|||
|
|||
|
RE: Synology backup: default.profile Permission denied
The umask setting in Synology DSM is 0077. This is why the default.profile file is not readable by other groups and users when it is created by MinimServer. It should be possible for MinimServer to add the missing read permissions (without adding write permissions) after the file has been created. I will do some tests and post back here.
|
|||
|
27-12-2022, 08:11
Post: #3
|
|||
|
|||
|
RE: Synology backup: default.profile Permission denied
I have looked into this some more. Because of the umask issue, it would be a lot of work to make all files created by MinimServer readable by all users. Which files do you need to be made readable in this way for backup purposes? Would doing it for profiles and "recent" files be sufficient?
|
|||
|
27-12-2022, 10:16
Post: #4
|
|||
|
|||
|
RE: Synology backup: default.profile Permission denied
Hello Simon,
as I am only backing up the etc directory I think the profiles and recent files would be enough. At least these were the files with which I had the problem so far. Thank you very much Gert |
|||
|
03-01-2023, 21:54
Post: #5
|
|||
|
|||
|
RE: Synology backup: default.profile Permission denied
There is a fix for this in MinimServer update 232. On Synology, read permission for all users is now added for .profile files and recently added/played lists when these files are created or updated.
|
|||
|
03-01-2023, 22:17
(This post was last modified: 03-01-2023 22:18 by tarnkappe.)
Post: #6
|
|||
|
|||
|
RE: Synology backup: default.profile Permission denied
O, thank you. I have installed the update. (thumb up)
|
|||
|
« Next Oldest | Next Newest »
|
User(s) browsing this thread: 1 Guest(s)

Search
Member List
Calendar
Help




