MinimServer Forum
Updated to 2.2 but doesn't start - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Support (/forumdisplay.php?fid=4)
+--- Thread: Updated to 2.2 but doesn't start (/showthread.php?tid=6925)



Updated to 2.2 but doesn't start - Statto - 31-05-2023 09:01

I have downloaded the MinimServer 2.2 package and installed it on my QNAP (253D).

The package shows correctly as Minimserver 2.2 in the AppCenter but doesn't start when clicking the Start button. I was previously running 2.1.2.

Java RE version is 8.151.2.3

I tried rebooting the QNAP and afterwards MinimServer momentarily started (for about 30 seconds) before stopping and again failing to start.

Suggestions please


RE: Updated to 2.2 but doesn't start - simoncn - 31-05-2023 15:55

Please check the share/MinimServer/minimserver.log file for error messages. Also, does the share/MinimServer folder contain any recent files with names starting minimserver-crash?


RE: Updated to 2.2 but doesn't start - Statto - 01-06-2023 21:42

(31-05-2023 15:55)simoncn Wrote:  Please check the share/MinimServer/minimserver.log file for error messages. Also, does the share/MinimServer folder contain any recent files with names starting minimserver-crash?

Don't think there's anything in the .log file It was last modified on 5/8/2020

There are two other log files that have been amended yesterday when I was trying to start MinimServer - minimserver-out.log and minimserver-sh.log

I've copied the relevant text below. The folder does not contain any minimserver-crash files

Text from the -out.log file

java.lang.StringIndexOutOfBoundsException: String index out of range: 4
at java.lang.String.substring(String.java:1963)
at org.jminim.core.RuntimeImpl.formatDate(RuntimeImpl.java:1790)
at org.jminim.core.RuntimeImpl.checkStreamerLicenseExpiry(RuntimeImpl.java:1783)
at org.jminim.core.RuntimeImpl.initRuntime(RuntimeImpl.java:401)
at org.jminim.core.LauncherImpl.run(LauncherImpl.java:1172)
at org.jminim.core.LauncherImpl.launch(LauncherImpl.java:125)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.jav​a:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.jminim.mlaunch.MinimLaunch.doLaunch(MinimLaunch.java:525)
at org.jminim.mlaunch.MinimLaunch.launch(MinimLaunch.java:150)
at org.jminim.mlaunch.MinimLaunch.launch(MinimLaunch.java:90)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.jav​a:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.jminim.launch.Launcher.launch(Launcher.java:88)
at com.minimserver.launch.LaunchServer.main(LaunchServer.java:38)



Text from the -sh.log file

Wed 31 May 09:11:43 /share/MD0_DATA/.qpkg/MinimServer/minimserver.sh called by 4708
Wed 31 May 09:11:43 starting
Wed 31 May 09:11:43 /usr/local/nptl not found
Wed 31 May 09:11:43 starting MinimServer
Wed 31 May 09:11:43 started process 4743
Wed 31 May 09:11:44 MinimServer is stopped: to restart, use Stop and Start in the App Center
Wed 31 May 09:11:45 MinimServer start error: java.lang.StringIndexOutOfBoundsException: String index out of range: 4
java.lang.StringIndexOutOfBoundsException: String index out of range: 4
at java.lang.String.substring(String.java:1963)
at org.jminim.core.RuntimeImpl.formatDate(RuntimeImpl.java:1790)
at org.jminim.core.RuntimeImpl.checkStreamerLicenseExpiry(RuntimeImpl.java:1783)
at org.jminim.core.RuntimeImpl.initRuntime(RuntimeImpl.java:401)
at org.jminim.core.LauncherImpl.run(LauncherImpl.java:1172)
at org.jminim.core.LauncherImpl.launch(LauncherImpl.java:125)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.jav​a:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.jminim.mlaunch.MinimLaunch.doLaunch(MinimLaunch.java:525)
at org.jminim.mlaunch.MinimLaunch.launch(MinimLaunch.java:150)
at org.jminim.mlaunch.MinimLaunch.launch(MinimLaunch.java:90)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.jav​a:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.jminim.launch.Launcher.launch(Launcher.java:88)
at com.minimserver.launch.LaunchServer.main(LaunchServer.java:38)
Wed 31 May 09:12:00 MinimServer status set to disabled


RE: Updated to 2.2 but doesn't start - Statto - 01-06-2023 21:52

(01-06-2023 21:42)Statto Wrote:  [quote='simoncn' pid='47620' dateline='1685544945']
Please check the share/MinimServer/minimserver.log file for error messages. Also, does the share/MinimServer folder contain any recent files with names starting minimserver-crash?

This is what I'm seeing in the QNAP event log

MinimServer is stopped: to restart, use Stop and Start in the App Center
MinimServer start error: java.lang.StringIndexOutOfBoundsException: String index out of range: 4
MinimServer status set to disabled


RE: Updated to 2.2 but doesn't start - Statto - 01-06-2023 22:17

(01-06-2023 21:52)Statto Wrote:  [quote='Statto' pid='47623' dateline='1685652170']
[quote='simoncn' pid='47620' dateline='1685544945']
Please check the share/MinimServer/minimserver.log file for error messages. Also, does the share/MinimServer folder contain any recent files with names starting minimserver-crash?

PROBLEM SOLVEDSmile

I used this (plus re-entering my full license code)

1) In the minimserver/data folder, either delete or rename the files minimserver.config and minimserver.config.save
2) Use the startc command to start MinimServer
3) You will see an error message about MinimStreamer having been disabled
4) Open the MinimServer configuration web page and select the License tab
5) You should see a message telling you that your license has been updated from Starter to Full
6) Use the exit command to stop MinimServer
7) Use the startc command to start MinimServer
8) MinimServer and MinimStreamer should now be running normally