MinimServer Forum
Playlist offset by one track - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Digital Audio (/forumdisplay.php?fid=10)
+--- Thread: Playlist offset by one track (/showthread.php?tid=6571)



Playlist offset by one track - jamief - 02-04-2022 22:03

Hello

I'm having a consistent issue when I select a new track or stream for playback: my renderer plays the prior active track instead. I guess that this is most likely a renderer issue.

Renderer: RPi running Ropieee XL (upmpdcli) with Openhome disabled
Bridge: BubbleUPnPServer to make Ropieee an Openhome renderer
Controller: most of them (mainly Kazoo, Bubble, etc).
Server: Minimserver / Streamer on Synology Docker

Selecting play again on the requested track normally clears it. Does anyone else get this, or have any clues how to solve it?

Edit: actually it is not one track offset or the prior track played, just another track in the current playlist - maybe the first in the prior batch of tracks added.

Thanks!


RE: Playlist offset by one track - tarnkappe - 03-04-2022 13:49

Do you have random play activated somewhere in the renderer layers (renderer, bubble server)?


RE: Playlist offset by one track - jamief - 03-04-2022 16:16

(03-04-2022 13:49)tarnkappe Wrote:  Do you have random play activated somewhere in the renderer layers (renderer, bubble server)?

No, but it was a great clue. I saw that I had "Gapless playback" enabled for the renderer in Bubble Server. Turning this off seems to have fixed the problem. This of course made gapless playback not work.

I went to the Ropieee config and turned on Openhome support (which has been shaky in the past). Gapless seems to work. The renderer now isn't visible in BubbleUPnP Server - I guess I don't need this anyway if OH support in RopieeeXL is working ok.

At the moment, I think thinks are happier... let's see.

Thanks for your help.