MinimServer Forum
Palyback stop on DSD and HD files - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: General (/forumdisplay.php?fid=2)
+--- Thread: Palyback stop on DSD and HD files (/showthread.php?tid=6390)



Palyback stop on DSD and HD files - JPBARIOULET - 11-11-2021 23:43

I'm new on this forum and french (sorry for my bad english...)
This is my system; Old Synology NAS (DS109) with minimserver (starter Edition 2.0.18))> ethernet LAN > 3DLab Nano Player > Amp. > Speakers, Control with BubbleUPnP .
When I play DSD files or Flac high Resolution (from 24-96 and above), music can stop during playback. The music starts again by manually pressing the Play bar of BubbleUpnp. No WIFI connection problem
I deduced that the problem came from minimserver after several tries:
- I can play a DSD or HD file on BubbleUpnp's local library without a break
- I can play an HD file from the Diskstation library (Nas synologhy) or from my Windows PC without any cuts (also using BubbleUpnp)
Any ideas of what can be the cause of this problem?
Any help will be appreciated!
Thanks


RE: Palyback stop on DSD and HD files - simoncn - 12-11-2021 21:49

This usually means the server machine doesn't have enough CPU power to handle serving the file while doing transcoding. As you aren't doing transcoding (this isn't available with Starter Edition), I am surprised that MinimServer can't serve these files. I tried a 24/192 FLAC file on my DS211 (similar CPU to the DS109) and it is working fine.

Does Resource Monitor on your DS109 show a high CPU load when you are streaming hi-res files?


RE: Palyback stop on DSD and HD files - simoncn - 15-11-2021 12:03

I tried to reply to your email but my message was rejected by your email server. What error message did you receive when you tried to post here?


RE: Palyback stop on DSD and HD files - simoncn - 05-12-2021 07:55

This problem has been identified as a defect in Synology DSM 4.2 which causes problems with Java 9 or later.

The MinimServer package for Synology ARMv5 automatically installs Java 14 and this is not working correctly with DSM 4.2. The solution is to manually install Java 8 and configure MinimServer to use Java 8 instead of Java 14.

If anyone else is having this problem (files stopping playing with MinimServer and DSM 4.2), please post here and I will provide detailed instructions for how to install and configure Java 8.