MinimServer Forum
Unable to get Minimstreamer working - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: MinimStreamer (/forumdisplay.php?fid=11)
+--- Thread: Unable to get Minimstreamer working (/showthread.php?tid=6153)

Pages: 1 2


Unable to get Minimstreamer working - colin - 05-04-2021 17:53

I have Minimserver 2 running on my Synology NAS and have paid my subscription.
I have been running Minimserver for a few years and been very pleased with it.
I am interested in trying MinimStreamer but cannot seem to get it to work.
Minimstreamer 2.07 shown as installed in packages in Minimwatch but
You advise "If MinimStreamer is running, the properties stream.converter, stream.record and stream.transcode will appear in the System tab"
These things are not shown in system properties.
I have read through lots of stuff but cannot find the fix if these are missing.
I have done relaunch but nothing changes.
Thanks for your help


RE: Unable to get Minimstreamer working - simoncn - 05-04-2021 19:32

I have not encountered this problem before. The usual cause would be not doing a relaunch. What do you see if you select About from MinimWatch?


RE: Unable to get Minimstreamer working - colin - 06-04-2021 11:03

Thanks for reply

About shows:

Minimserver 2.0.18 update 191
MinimStreamer 2.0.7
Running on host and port 192.168.1.211:9791

Hope that helps
Colin


RE: Unable to get Minimstreamer working - simoncn - 06-04-2021 12:25

This looks fine. If you have the Properties window open in MinimWatch, close it and reopen it. If the Properties window isn't open, exit MinimWatch and relaunch it.


RE: Unable to get Minimstreamer working - colin - 06-04-2021 18:57

Hi
I reinstalled Minimwatch and the items are now there but there are no values next to them.

I then went on to look at how to set up minimstreamer and its all beyond me. I was hoping to be able to covert some DSD
files to Flac on the fly as I have no means of playing DSD.

I am very happy with Minimserver as it just works and is worth the subscription on its own.

Colin


RE: Unable to get Minimstreamer working - simoncn - 06-04-2021 19:35

You can't transcode DSF to FLAC but you can transcode DSF to WAV. For this, you need to have FFmpeg installed on the device you are using to run MinimServer. On a Synology NAS, this should be preinstalled with DSM. What do you see in the stream.converter property?


RE: Unable to get Minimstreamer working - Alandbush - 06-04-2021 20:11

(06-04-2021 18:57)colin Wrote:  I then went on to look at how to set up minimstreamer and its all beyond me.

Extracted from Minimwatch Package mgmt

The easiest way to install packages is from the graphical interface provided by MinimWatch.

1. Right click the MinimWatch icon and select the Properties option

2. Select the Packages tab of the Properties dialog
Nb -this tab shows you what packages you currently have installed and what packages are available for installation.

3. Select the package (I.e. Minimstreamer) in the 'Available packages' list

4. Select Install and follow the prompts

5. Select the Relaunch button on the Packages tab for the change to become effective


RE: Unable to get Minimstreamer working - colin - 07-04-2021 14:16

Alandbush - thanks for trying to help but its the next stage I am confused over.

Simoncn - FFmpeg is shown in stream convertor. I do not understand the instructions on where I have to make the entries to get it to work as converting DSD to WAV would be helpful.

I feel sorry for you having to deal with users like me!!

Colin


RE: Unable to get Minimstreamer working - simoncn - 07-04-2021 16:48

On the same page as stream.converter, there is a box named stream.transcode. In this box, type:

dsf:wav176;24

and click OK. This will transcode your DSF files to 24 bit / 176.4 kHz WAV. This resolution is suitable for most renderers but can be adjusted if necessary.


RE: Unable to get Minimstreamer working - colin - 08-04-2021 18:36

Simon

Tried entering details but it came up incorrect output type 176;24 - I also tried 96;24.

I did type in in exactly as shown!!

From your instructions I would never have thought to type entries in those boxes but I am old and
do like a picture to follow.

Colin