MinimServer Forum
Error message during scanning on Synology DS118 - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Support (/forumdisplay.php?fid=4)
+--- Thread: Error message during scanning on Synology DS118 (/showthread.php?tid=5613)



Error message during scanning on Synology DS118 - MojoBass - 13-04-2020 16:52

Have installed the Minim Server 0.8.5.3 from the Synology DSM Package Center on my DS118 (DSM 6.2.2-24922 Update 6) without problems. When I then start to scan my library I get (after approx 10 minutes) the following error message:
Unexpected exception java.lang.NoClassDefFoundError: Could not initialize class sun.nio.fs.UnixCopyFile
Anyone who has a idea what to do here?


RE: Error message during scanning on Synology DS118 - simoncn - 13-04-2020 17:43

You should have a minimserver-crash file in your MinimServer/appData folder. Please attach this file to a post here.


RE: Error message during scanning on Synology DS118 - MojoBass - 13-04-2020 19:07

Thanks for the hint! See minimserver-crash file attached.


RE: Error message during scanning on Synology DS118 - simoncn - 13-04-2020 21:40

Thanks for this. It is caused by an internal error inside the Java runtime and it happens when MinimServer tries to rename the newly created cache file at the end of its scan. I have a DS118 and I have never seen this error.

There are a number of reports on the web of similar problems but no-one has posted a solution. I suggest the following:

1) Power the NAS off and on and repeat the MinimServer scan.

2) If this produces the same error, download and install MinimServer 2.0.9 to see whether this fixes it. This uses a newer version of Java (JDK 14 instead of JDK 9). If you have customized your MinimServer property settings, you will need to activate a MinimServer 2 free trial license to use the same settings. For details of how to do this, see this page.


RE: Error message during scanning on Synology DS118 - MojoBass - 14-04-2020 06:09

(13-04-2020 21:40)simoncn Wrote:  1) Power the NAS off and on and repeat the MinimServer scan.
Restart the diskstation was the solutionSmile
Thanks very much, simoncn!!