MinimServer Forum
Room correction with convolution per sample rate - Printable Version

+- MinimServer Forum (
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: MinimStreamer (/forumdisplay.php?fid=11)
+--- Thread: Room correction with convolution per sample rate (/showthread.php?tid=5109)

Pages: 1 2 3 4 5 6

RE: Room correction with convolution per sample rate - digimuse - 12-01-2019 07:16

I changed the convolution setting for MinimServer on my Melco N1 server:

convOut=-i /mnt/disk1/share/MinimServer/convolution/Cor1S*.wav -lavfi afir=wet=10


I listened to a few tracks at each of the sample rates 16/44, 24/48/24/88, 24/96, 24/176, and 24/192 (FLAC files). I did not notice any problems.

I'll compare the convolution engine of JRiver with Melco/MinimServer, to see if there are any other problems with the Melco processor (I'll use JRiver as the Control Point, my DAC as the Renderer, and switch between JRiver as the server and Minimserver on the Melco as server).

I report back if I find anything unusual.

RE: Room correction with convolution per sample rate - simoncn - 12-01-2019 10:49

Thanks very much for all your help with this.

RE: Room correction with convolution per sample rate - digimuse - 16-01-2019 04:09

I've been comparing the JRiver convolution engine with MinimServer on the Melco. I have tried a variety of sample rates, and many different albums at a given sample rate.

I did not notice any unusual sounds with MinimServer/Melco. To me, the convolution operations on MinimServer/Melco sound slightly better than those on JRiver. MinimServer/Melco has more low-level detail, and more focused imaging. I'm guessing that this is mainly a function of the Melco server vs JRiver on a Mac (hopefully the convolution operations are identical in both systems).

I did find one album that MinimServer/Melco refused to play with convolution. The album is 24/192 version of the following:
Ernest Ansermet - Albeniz: Iberia/ Turina: Danzas Fantasticas

In the verbose logs I got the error:

Quote:Using convolution file /mnt/disk1/share/MinimServer/convolution/Cor1S192.wav for sample rate 192000
Converter program ended unexpectedly with exit value 1

MinimServer/Melco has no problem playing this album without convolution (stream.options and stream.transcode both blank).

JRiver also has no problem playing this album with/without convolution.

Perhaps there is something unusual about this album? I did not have problems with any other 24/192 album that I tried.

Simon - I've sent you a pm with details of the album

RE: Room correction with convolution per sample rate - simoncn - 16-01-2019 14:55

Thanks for letting me know about this. I tried the file that you uploaded and it played with no problems. This was on the Melco using FFmpeg 4.1 downloaded from the johnvansickle site. MinimStreamer selected the Cor1S192.wav convolution file that you uploaded earlier (dated 29/11/2018). I tried afir=gtype=gn and afir=wet=10 and both worked OK. My stream.transcode setting was 'flac:wav;'. Can you think of anything different in your setup that could account for this difference?

RE: Room correction with convolution per sample rate - digimuse - 16-01-2019 23:33

I think I may have identified the source of this problem.

I found that I could not play another album by Isaac Albéniz - this time with a 44 kHz sample rate.

Both the 192 kHz album and 44 kHz album were in the same parent folder named "Albéniz, Isaac" (without the quotes).

I changed the name of this folder to "Albeniz, Isaac" - and I was able to play the tracks with convolution processing.

It appears that there is something in ffmpeg (for armhf?) that does not like the special character "é" in folder names. I'm guessing you did not place my test file in such a folder.

There is no problem with MinimServer when not performing convolution with folder names with "é" in them. Also no problem with JRiver with such folders.

Just for reference, here are the details of my setup:

I am using the same convolution filters I posted on Nov 29, 2018.

MinimServer/Streamer on Melco N1:

Quote: minimjre-9.0.1
ffmpeg release 4.1 for armhf
downloaded from

convOut=-i /mnt/disk1/share/MinimServer/convolution/Cor1S*.wav -lavfi afir=wet=10


RE: Room correction with convolution per sample rate - simoncn - 17-01-2019 00:10

Thanks for clarifying the cause of the problem. This issue with accented characters in filenames is fixed in the latest version of MinimServer for Melco.

RE: Room correction with convolution per sample rate - digimuse - 17-01-2019 01:13

Thanks for the pointer.

Updating the Melco N1 to minimserver- fixed the problem with convolution on files whose path contains accent characters.

RE: Room correction with convolution per sample rate - simoncn - 20-01-2019 23:18

This support is now offically released in MinimStreamer 0.7.11 and MinimServer update 127. There are some minor changes from the previous test builds. Please let me know if you come across anything unexpected.

RE: Room correction with convolution per sample rate - digimuse - 23-01-2019 08:42

On the Melco N1 server, I updated the system to minimstreamer-0.7.11 and minimserver-0.8-update-127.

I tested FLAC files up to 384 kHz, and dsf files (DSD64 and DSD128). MinimStreamer/ffmpeg performed convolution on FLAC files with sample rates from 44.1 kHz to 192 kHz.

I did not observe anything unusual after two days of testing.

RE: Room correction with convolution per sample rate - simoncn - 04-02-2019 21:40

(11-01-2019 04:41)digimuse Wrote:  Thanks for trying to get the ffmpeg developers to come up with a fix for the Armada 370 problem. Too bad they weren't sympathetic.

Perhaps this is not a common problem, and if it does occur, it may be possible to use other convolution options, like "afir=wet=<0-10>" .

I have found a solution for this problem. This has required me to build a special version of ffmpeg for the Melco. To install this, you need to update MinimServer to update 128 and update MinimStreamer to 0.7.12, then install the ffmpeg-4.1-melco-0.1 package. After doing this and relaunching MinimServer, MinimStreamer should be using the special version of ffmpeg. You can confirm this by looking at the stream.converter property, which should have been set automatically to libext/*/ffmpeg.

As well as fixing the 48 kHz gtype=gn problem, the ffmpeg executable in this package is tailored to contain only the decoders and encoders used by MinimStreamer. This tailored ffmpeg executable is only available for the Melco. Please try this to confirm that it has fixed the 48 kHz gtype=gn problem. If you notice any other issues when using this version, please let me know. Many thanks!