MinimServer Forum
convolution with acourate fir filter - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: MinimStreamer (/forumdisplay.php?fid=11)
+--- Thread: convolution with acourate fir filter (/showthread.php?tid=4457)

Pages: 1 2 3 4 5 6 7 8


RE: convolution with acourate fir filter - SMSWAP - 14-01-2019 20:11

(14-01-2019 15:15)simoncn Wrote:  OK, so this would mean you need:

convOut={-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Cor1S44.wav -lavfi apad=pad_len=32768,afir,atrim=start_sample=32768}

This is because the Cor1S*.wav setting doesn't work when you use the above setting (starting apad...) for -lavfi. This will be fixed in the next test build.

Yes, you are right: When fixed to a sample rate, this works well. I am then awaiting the next update in order to take full use of both features...

Cheers, SMSWAP


RE: convolution with acourate fir filter - simoncn - 16-01-2019 00:51

There is a new test build with a fix for this. To install it, do the following:

1) Select the Packages tab in the Properties window
2) In the 'Other package' tab, type: minimstreamer-0.7.10.3
3) Click Install and follow the prompts to install the package
4) When installation has completed, click Relaunch to relaunch MinimServer and MinimStreamer

With this, you should be able to use the following convOut string:

convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Cor1S*.wav -lavfi "apad=pad_len=32768,afir,atrim=start_sample=32768"

The quotes are needed because the -lavfi option value contains commas.


RE: convolution with acourate fir filter - SMSWAP - 16-01-2019 07:39

(16-01-2019 00:51)simoncn Wrote:  There is a new test build with a fix for this. To install it, do the following:

1) Select the Packages tab in the Properties window
2) In the 'Other package' tab, type: minimstreamer-0.7.10.3
3) Click Install and follow the prompts to install the package
4) When installation has completed, click Relaunch to relaunch MinimServer and MinimStreamer

With this, you should be able to use the following convOut string:

convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Cor1S*.wav -lavfi "apad=pad_len=32768,afir,atrim=start_sample=32768"

The quotes are needed because the -lavfi option value contains commas.

That's it Simon: It works very well with varying sample rates/ filters!

Cool stuff: Many thanks to you!

Cheers, Ralf


RE: convolution with acourate fir filter - SMSWAP - 23-01-2019 07:34

Hi Simon,

I have installed the convolution options on a friend's NAS (type Synology). Since the last update on FFMPEG on the NAS, this command doesn't work anymore:

convOut=-i PATH/CorS44.wav -filter_complex [0]apad=pad_len=32768[2];[2][1]afir[3];[3]atrim=start_sample=32768

Only the simplified version convOut=-i PATH/Cor1S*.wav -lavfi afir works.

Are you aware of any changes to FFMPEG on the Synology platfrom which stop the advanced version from be used?

Cheers, SMSWAP


RE: convolution with acourate fir filter - simoncn - 23-01-2019 10:34

Is the convolution file named Cor1S44.wav or CorS44.wav? The setting that works is using the former and the setting that doesn't work is using the latter.

Also, the recommended setting is now

-lavfi "apad=pad_len=32768,afir,atrim=start_sample=32768"

instead of

-filter_complex [0]apad=pad_len=32768[2];[2][1]afir[3];[3]atrim=start_sample=32768

allthough the latter should still work if you are not using a wildcard pattern for the convolution file.


RE: convolution with acourate fir filter - SMSWAP - 23-01-2019 10:50

(23-01-2019 10:34)simoncn Wrote:  Is the convolution file named Cor1S44.wav or CorS44.wav? The setting that works is using the former and the setting that doesn't work is using the latter.

Also, the recommended setting is now

-lavfi "apad=pad_len=32768,afir,atrim=start_sample=32768"

instead of

-filter_complex [0]apad=pad_len=32768[2];[2][1]afir[3];[3]atrim=start_sample=32768

allthough the latter should still work if you are not using a wildcard pattern for the convolution file.

Sorry. That was just a typo. Of course I used Cor1S44!
Will try the modified string and get back to you.


RE: convolution with acourate fir filter - simoncn - 23-01-2019 11:31

(23-01-2019 10:50)SMSWAP Wrote:  Sorry. That was just a typo. Of course I used Cor1S44!
Will try the modified string and get back to you.

I have checked this and there is a problem with parsing some option strings. This will be fixed in the next version of MinimStreamer. For now, the modified string that I suggested should work.


RE: convolution with acourate fir filter - SMSWAP - 23-01-2019 13:49

(23-01-2019 11:31)simoncn Wrote:  
(23-01-2019 10:50)SMSWAP Wrote:  Sorry. That was just a typo. Of course I used Cor1S44!
Will try the modified string and get back to you.

I have checked this and there is a problem with parsing some option strings. This will be fixed in the next version of MinimStreamer. For now, the modified string that I suggested should work.

IT DOES! Thanks. Problem solved!


RE: convolution with acourate fir filter - SMSWAP - 23-01-2019 13:51

Hi Simon,

the solution works well on QNAP and Synology. What still disturbs me is a little click when switching tracks. Would there be a possiblity for Minim to have - in addition - a fast fade-out-fade-in function?

Cheers, SMSWAP


RE: convolution with acourate fir filter - simoncn - 23-01-2019 16:14

You can use the convOut setting to fade in and out. See the description of the afade filter in this section. For example, to fade in for the first 50 ms and fade out for the last 50 ms, you could use this setting:

-lavfi "apad=pad_len=32768,afir,atrim=start_sample=32768,afade=0.05"