MinimServer Forum
convolution with acourate fir filter - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: MinimStreamer (/forumdisplay.php?fid=11)
+--- Thread: convolution with acourate fir filter (/showthread.php?tid=4457)

Pages: 1 2 3 4 5 6 7 8


RE: convolution with acourate fir filter - simoncn - 10-11-2018 12:13

Is the file you are playing (not the filter file) an ALAC file, a DSF file or something else?


RE: convolution with acourate fir filter - simoncn - 11-11-2018 20:06

(20-06-2018 21:52)Alandbush Wrote:  Are you able to provide a way to invoke ffmpeg with a wav file?

This is now supported in MinimStreamer 0.7.8, which you can install from the Packages tab of the Properties window. If you specify wav:wav in the stream.transcode property, all WAV files will be processed by ffmpeg and any convOut options will be applied to these files.


RE: convolution with acourate fir filter - Alandbush - 12-11-2018 14:18

(11-11-2018 20:06)simoncn Wrote:  
(20-06-2018 21:52)Alandbush Wrote:  Are you able to provide a way to invoke ffmpeg with a wav file?

This is now supported in MinimStreamer 0.7.8, which you can install from the Packages tab of the Properties window. If you specify wav:wav in the stream.transcode property, all WAV files will be processed by ffmpeg and any convOut options will be applied to these files.

Thank you for this change. I am sure this will prove useful for others.

Personally, I have introduced a Windows pc into my system with which I am exploring its transcoding and VST plugin abilities.


RE: convolution with acourate fir filter - SMSWAP - 08-12-2018 15:39

Hi Simon,

I am trying to apply the string you suggested to the ConvOut. Whatever I add after the .wav file like "-lavfi afir" reports an error when I try to apply it.

In general: I can't find the user guide for all the convOut options...

Your help is highly appreciated!

Regards, SMSWAP


RE: convolution with acourate fir filter - simoncn - 08-12-2018 16:22

For -lavfi afir to work, you need to be using FFmpeg 3.4.0 or later (see this post). What platform (NAS or computer) are you using to run MinimServer?

The convOut setting is a string containing options for the ffmpeg command. There are a lot of these options and you would need to look in the FFmpeg documentation for a list of what the options are and what they do.

I am working on some improvements to how MinimStreamer supports -lavfi afir and this support will be documented in the MinimStreamer user guide when it is available.


RE: convolution with acourate fir filter - SMSWAP - 08-12-2018 16:23

Hi Simon,

I have tried to apply the above. However, I cannot add any commands after the *.wav file name. Whatever I add, produces an error message when applied.

A general question: Where do I find the synthax of the various possbile commands such as *-i", "-lavi" or "afir"?

Regards, SMSWAP


RE: convolution with acourate fir filter - simoncn - 08-12-2018 16:56

Are you sure you are using FFmpeg 3.4.0 or later? What platform (NAS or computer) are you using to run MinimServer?

The syntax of the options for the ffmpeg command is described on this page (it's the first page on the list if you use Google to search for ffmpeg options).


RE: convolution with acourate fir filter - SMSWAP - 08-12-2018 17:37

Hi Simon,

I am using a QNAP HS251+ with the default FFMPEG. Don't know which version this is or if the Minim installation has added another one. Do I need to upgrade?

Regards, Ralf


RE: convolution with acourate fir filter - simoncn - 08-12-2018 22:52

The default FFmpeg on QNAP is 3.3.6, which doesn't support the -lavfi option.

It is possible to download and install a newer version of FFmpeg but this requires some knowledge of Linux terminal commands. I am planning to provide a simpler way of doing this soon.


RE: convolution with acourate fir filter - SMSWAP - 09-12-2018 08:10

Hi Simon,

in the meantime, I have been able to install the ffmpeg_4.1.0_x86.qpkg and have rebooted the NAS. However, I still the the error message "convOut setting incorrect for converter" whenever I add any string like trailing the *.wav. It appears, that the wrong ffmpeg is used.

This is how stream.options currently looks like:
convOut=-i /share/CACHEDEV1_DATA/Music/ConvolutionFiles/Echo44.wav

Any idea how to ressolve this?

Cheers, SMSWAP