MinimServer Forum
Radio Streams stop playing after minutes playing - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: MinimStreamer (/forumdisplay.php?fid=11)
+--- Thread: Radio Streams stop playing after minutes playing (/showthread.php?tid=3619)

Pages: 1 2 3


Radio Streams stop playing after minutes playing - chip - 05-10-2016 11:03

Hello all,

My setup consist of:
Windows 10 64-bit desktop Build 1607
Intel i7-6700T CPU @ 2.80GHz, 32 GB Memory, 500 GB SSD
1 GB ethernet
100 MB internet subscription
MinimServer 0.8 update 88
MinimStreamer 0.5.25
Kinsky Desktop 4.4.5.0
Akurate DS software 4.50.110

I have followed the instructions for setting up the BBC HLS station list for international users. I am based in The Netherlands.
I can see the playlist in Kinsky and start playing all the stations.
Each station stops playing after 10 to 13 minutes of playback.

MinimServer logging is set to Verbose.
I do not see any messages in the log.

I have several other radio stream playlists that play without stopping.

Can anyone give me some ideas about how I can troubleshoot this problem?

Chip


RE: Radio Streams stop playing after minutes playing - simoncn - 05-10-2016 21:41

Are you using UK or non-UK URLs? Please post an example of one of the URLs that shows this problem.

Also, please enable Debug logging when you are playing the stream. After the stream stops playing, click 'Save as' in the log window to save a log file, then zip the saved log file and attach it to a post here.


RE: Radio Streams stop playing after minutes playing - chip - 05-10-2016 22:49

I am using the nonuk streams since I am streaming from The Netherlands.

I tried
#EXTINF:-1,[*R4 Int] BBC Radio 4 FM
http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/nonuk/sbr_low/ak/bbc_radio_fourfm.m3u8
just now

In Kinsky I can see the following details:
Type object object.item.audioItem.audioBroadcast
Title [R4 int] BBC Radio 4 FM
Mime Type *
Prorocol Info http-get*.*.*
Uri http://192.168.1.101:9790/minimserver/*R4*20Int
Artwork Uri http://192.168.1.101:9790/minimserver/*/Music*20Radio*20Playlist/BBC*20Radio*20

This stream played for about 13 minutes then Kinsky stopped playing the stream.
Kinsky says it is Subscribing now.

After 5 minutes it is still subscribing.
I closed Kinsky.
I then saved the Debug Log from MinimServer and attached it to this post.

I have attached a zip file containing the debug log and my m3u file to this post.
Does this give you any indication of the problem I have?

Thank you,
Chip


RE: Radio Streams stop playing after minutes playing - simoncn - 06-10-2016 19:34

Thanks for this. I have tried playing the same international stream on my KRDS/0 with the same level of Davaar and it has been playing for over 3 hours with no problems.

The debug log file shows a timeout problem with the HTTP connection between the renderer and MinimStreamer but it doesn't show why this happened. Please can you run the test again with the logging level set to Trace instead of Debug. This will produce a lot more output and I hope it will provide more clues. Many thanks!


RE: Radio Streams stop playing after minutes playing - chip - 07-10-2016 07:42

Hi Simon,
I cleared the log and reset the logging level to level to Trace and then ran a rescan to get everything started up again.

I started Kinsky and then started playing the same station again.
#EXTINF:-1,[*R4 Int] BBC Radio 4 FM
http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/nonuk/sbr_low/ak/bbc_radio_fourfm.m3u8

After 10:45 the stream stopped. I attached the Kinsky window after stopping to this post.
It does not show Subscribing as it did last time. I also attached a screen shot showing the subscribing icon from a couple of days ago.

Now that everything is stopped and the log is not adding more entries I have saved the log.

I have attached the two screen shots and log file as a zip to this post.

Thanks,
Chip


RE: Radio Streams stop playing after minutes playing - simoncn - 07-10-2016 11:28

Thanks for the trace log. It shows that the problem occurred when MinimStreamer was writing audio data to the DS. The DS did not receive the data successfully for some reason.

This might be an issue with the DS firmware (Davaar 50). Can you try reverting to Davaar 37 to see whether this works? I don't need any more log information.


RE: Radio Streams stop playing after minutes playing - chip - 07-10-2016 16:51

(07-10-2016 11:28)simoncn Wrote:  Thanks for the trace log. It shows that the problem occurred when MinimStreamer was writing audio data to the DS. The DS did not receive the data successfully for some reason.

This might be an issue with the DS firmware (Davaar 50). Can you try reverting to Davaar 37 to see whether this works? I don't need any more log information.

I have been looking for previous versions of firmware without any success.
Can you help me by telling me where I can find previous versions?


RE: Radio Streams stop playing after minutes playing - simoncn - 07-10-2016 17:21

(07-10-2016 16:51)chip Wrote:  I have been looking for previous versions of firmware without any success.
Can you help me by telling me where I can find previous versions?

See this page.


RE: Radio Streams stop playing after minutes playing - chip - 07-10-2016 17:38

OK, I see the page which has many versions.

I think you have asked me to install AkurateDs_4.37.1671.zip to go back one level.
Is this the correct file?

I open this zip file and find it also contains many folders.
AkurateDsMk1
AkurateDsMk2
AkurateDSMk2NoDig
AkurateDSMk3
AkurateRenewDsMk1 - I do not have a Renew so I do not think this one is for me.
AkurateRenewDsMk2 - I do not have a Renew so I do not think this one is for me.

I have an Akurate DS/1 according to Konfig.
Which folder should I use?

Thanks,
Chip


RE: Radio Streams stop playing after minutes playing - simoncn - 07-10-2016 18:52

You should not open the zip file. Just use Konfig to install it and Konfig will choose the correct firmware for your DS.