MinimServer Forum
XRDP - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Support (/forumdisplay.php?fid=4)
+--- Thread: XRDP (/showthread.php?tid=2830)



XRDP - Alan Robinson - 27-12-2015 16:32

The Minimserver installation guides suggests certain on screen functionality for the Minimserver configuration
When my Pi is connected via HDMI to a screen I can operate these features
However when attempting to go headless and use an XRDP connection from my Windows 10 laptop, I can not see the icon on the top tray and cannot therefore operate it
I have the green Minimserver icon on the desktop but no icon on the top taskbar


RE: XRDP - simoncn - 27-12-2015 23:43

(27-12-2015 16:32)Alan Robinson Wrote:  The Minimserver installation guides suggests certain on screen functionality for the Minimserver configuration
When my Pi is connected via HDMI to a screen I can operate these features
However when attempting to go headless and use an XRDP connection from my Windows 10 laptop, I can not see the icon on the top tray and cannot therefore operate it
I have the green Minimserver icon on the desktop but no icon on the top taskbar

I have just tried this on my RPi (running Raspbian with LXDE) and it is working OK for me. When I view the desktop from Windows, the minim icon appears on the bottom tray/taskbar in the same place as when I connect using HDMI.

Your reference to a top tray/taskbar seems to suggest that your environment might be different from mine. Which version of Linux and desktop manager are you running on your RPi?


RE: XRDP - Alan Robinson - 28-12-2015 18:22

(27-12-2015 23:43)simoncn Wrote:  
(27-12-2015 16:32)Alan Robinson Wrote:  The Minimserver installation guides suggests certain on screen functionality for the Minimserver configuration
When my Pi is connected via HDMI to a screen I can operate these features
However when attempting to go headless and use an XRDP connection from my Windows 10 laptop, I can not see the icon on the top tray and cannot therefore operate it
I have the green Minimserver icon on the desktop but no icon on the top taskbar

I have just tried this on my RPi (running Raspbian with LXDE) and it is working OK for me. When I view the desktop from Windows, the minim icon appears on the bottom tray/taskbar in the same place as when I connect using HDMI.

Your reference to a top tray/taskbar seems to suggest that your environment might be different from mine. Which version of Linux and desktop manager are you running on your RPi?

I am using Jessie2 from IQaudIO - I have attached a screenshot to illustrate


RE: XRDP - simoncn - 29-12-2015 19:15

I have installed Debian Jessie and I am seeing the same problem as you.

It appears the default behaviour of XRDP has changed between Debian Wheezy and Debian Jessie. In Wheezy, the default login connects to your console desktop session (session id 0). In Jessie, the default login connects to a new desktop session (session id 10). The MinimServer tray icon appears only on the console desktop session 0 and this is why you aren't seeing it when you login to Jessie using XRDP.

The solution is to install another package named x11vnc on the Pi. See this post for installation and setup instructions. No change is needed to your current XRDP installation. When you login to Remote Desktop Connection from Windows, you need to select 'console' from the drop-down list instead of 'sesman-Xvnc'.

While working on this, I noticed a problem with MinimServer being started as username 'root' when using automatic startup instead of username 'pi'. This problem is fixed in the new download minimserver-0.8.3f-linux-armhf.tar.gz.

There is also a problem with the size of the minim icon. This is fixed at 24 x 24 pixels and doesn't fill the default space of 36 x 36 pixels. This appears to be a Java issue and I am trying to find out if there is any way I can work around this. It looks ugly but doesn't seem to cause any functional problems.


RE: XRDP - Alan Robinson - 02-01-2016 11:12

Thanks (eversomuch), after installation and a reboot I now have access to my Minimserver icons.

Is there a way to get the Console full screen? At the moment it covers a top left quarter of my screen


RE: XRDP - simoncn - 02-01-2016 11:23

(02-01-2016 11:12)Alan Robinson Wrote:  Thanks (eversomuch), after installation and a reboot I now have access to my Minimserver icons.

Is there a way to get the Console full screen? At the moment it covers a top left quarter of my screen

I presume you are seeing the Pi desktop as a normal Windows window, as shown in the screenshot that you posted earlier. As with all Windows windows, you can click the maximise box at the top right of this window to make it full screen. Perhaps I have misunderstood your question.


RE: XRDP - Alan Robinson - 04-01-2016 16:04

(02-01-2016 11:23)simoncn Wrote:  
(02-01-2016 11:12)Alan Robinson Wrote:  Thanks (eversomuch), after installation and a reboot I now have access to my Minimserver icons.

Is there a way to get the Console full screen? At the moment it covers a top left quarter of my screen

I presume you are seeing the Pi desktop as a normal Windows window, as shown in the screenshot that you posted earlier. As with all Windows windows, you can click the maximise box at the top right of this window to make it full screen. Perhaps I have misunderstood your question.



RE: XRDP - Alan Robinson - 04-01-2016 16:13

No, you haven't misunderstood. If I maximise up it stays to quarter screen. I am using XRDP Console to connect

It is a normal windows window but the Pi graphic screen only takes up a quarter of the screen. I tried reducing the picture quality in XRDP options but to no avail, in options I have image size set to maximum too


RE: XRDP - simoncn - 04-01-2016 22:32

(04-01-2016 16:13)Alan Robinson Wrote:  No, you haven't misunderstood. If I maximise up it stays to quarter screen. I am using XRDP Console to connect

It is a normal windows window but the Pi graphic screen only takes up a quarter of the screen. I tried reducing the picture quality in XRDP options but to no avail, in options I have image size set to maximum too

When I use HDMI to view the Pi desktop, I get the full resolution of my monitor (1920 x 1200). I also get 1920 x 1200 when I login using XRDP and maximise the Remote Desktop window on my PC.