MinimServer Forum
“GROUPINGS” not appearing as groups - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Music Tagging (/forumdisplay.php?fid=9)
+--- Thread: “GROUPINGS” not appearing as groups (/showthread.php?tid=2066)



“GROUPINGS” not appearing as groups - JNS - 29-12-2014 18:37

I have been using MinimServer happily for some months and I decided that I would like to tag my classical works/compositions so that they would be “grouped” by MinimServer and appear so in Kazoo or Kinsky. I used Metadatics’ “Grouping” tag - I have Macs running Yosemite -and according to my writeAllTags file/output from MinimServer I have now over 100 “GROUPING” tags, but none of which render the tracks as groups in my control point.

I have, however, one Album of 10 tracks that contains 3 “CONTENTGROUP” tags and which is rendered as groups in the way I wished… (I do not know why this album should have different tagging from the others...)

After perusing an earlier thread on this forum I entered ContentGroup:Group in aliasTags and restarted MinimServer, but this makes no apparent difference.

I would be very grateful if someone could point out the (blindingly obvious?) thing that I have overlooked or misapplied.

With thanks in advance...


RE: “GROUPINGS” not appearing as groups - simoncn - 29-12-2014 19:29

(29-12-2014 18:37)JNS Wrote:  I have been using MinimServer happily for some months and I decided that I would like to tag my classical works/compositions so that they would be “grouped” by MinimServer and appear so in Kazoo or Kinsky. I used Metadatics’ “Grouping” tag - I have Macs running Yosemite -and according to my writeAllTags file/output from MinimServer I have now over 100 “GROUPING” tags, but none of which render the tracks as groups in my control point.

This shouldn't be happening. This output should show CONTENTGROUP, not GROUPING. What are the filetypes (e.g., FLAC, MP3, M4A) of the files that contain GROUPING tags?

Quote:I have, however, one Album of 10 tracks that contains 3 “CONTENTGROUP” tags and which is rendered as groups in the way I wished… (I do not know why this album should have different tagging from the others...)

After perusing an earlier thread on this forum I entered ContentGroup:Group in aliasTags and restarted MinimServer, but this makes no apparent difference.

I would be very grateful if someone could point out the (blindingly obvious?) thing that I have overlooked or misapplied.

With thanks in advance...

You are on the right track by using ContentGroup:Group in aliasTags. You should also add Grouping:Group as a workaround for the GROUPING tags in your writeAllTags output. Does this help?


RE: “GROUPINGS” not appearing as groups - JNS - 29-12-2014 20:09

(29-12-2014 19:29)simoncn Wrote:  
(29-12-2014 18:37)JNS Wrote:  I have been using MinimServer happily for some months and I decided that I would like to tag my classical works/compositions so that they would be “grouped” by MinimServer and appear so in Kazoo or Kinsky. I used Metadatics’ “Grouping” tag - I have Macs running Yosemite -and according to my writeAllTags file/output from MinimServer I have now over 100 “GROUPING” tags, but none of which render the tracks as groups in my control point.

This shouldn't be happening. This output should show CONTENTGROUP, not GROUPING. What are the filetypes (e.g., FLAC, MP3, M4A) of the files that contain GROUPING tags?

The GROUPING-tagged files all seem to be FLAC. (The CONTENTGROUP-tagged files were M4A)

Quote:I have, however, one Album of 10 tracks that contains 3 “CONTENTGROUP” tags and which is rendered as groups in the way I wished… (I do not know why this album should have different tagging from the others...)

After perusing an earlier thread on this forum I entered ContentGroup:Group in aliasTags and restarted MinimServer, but this makes no apparent difference.

I would be very grateful if someone could point out the (blindingly obvious?) thing that I have overlooked or misapplied.

With thanks in advance...

You are on the right track by using ContentGroup:Group in aliasTags. You should also add Grouping:Group as a workaround for the GROUPING tags in your writeAllTags output. Does this help?

That not only helps, it seems to have solved the problem entirely!

Thank you so very much!

J


RE: “GROUPINGS” not appearing as groups - simoncn - 30-12-2014 09:34

(29-12-2014 20:09)JNS Wrote:  The GROUPING-tagged files all seem to be FLAC. (The CONTENTGROUP-tagged files were M4A)

This means that Metadatics is writing GROUPING tags to FLAC files instead of CONTENTGROUP tags. As there is no standard for how tag names should be mapped between different file formats such as M4A and FLAC, this isn't unreasonable. THe aliasTags feature of MinimServer can be used to correct tag naming mismatches such as this.

Quote:That not only helps, it seems to have solved the problem entirely!

Thank you so very much!

J

I'm pleased to hear this. Smile


RE: “GROUPINGS” not appearing as groups - JohanJ - 13-05-2015 10:53

Maybe a little sidestep. I use minimserver on a synology and I do my tagging in Jriver for mac. I use the grouping tag for classical style periods like Baroque, Romantic etc. I noticed that only in dsf files the grouping didn't show in bubblepnp. When i checked those files in mp3tag jriver seemed to have written the grouping tags to contentgrouping. Easy to repair, so not a big issue. I find it rather strange though.