MinimServer Forum
MinimWatch does not reconnect after PC hibernate - Printable Version

+- MinimServer Forum (https://forum.minimserver.com)
+-- Forum: MinimServer (/forumdisplay.php?fid=1)
+--- Forum: Support (/forumdisplay.php?fid=4)
+--- Thread: MinimWatch does not reconnect after PC hibernate (/showthread.php?tid=1300)

Pages: 1 2 3 4


MinimWatch does not reconnect after PC hibernate - RSJ - 26-01-2014 12:41

I am using MinimWatch on a Windows 8.1 PC.

MW starts fine; however, if I hibernate the PC and then restart, the MW icon is blue/grey, and MW does not reconnected to MS on the Home Server PC. If I click on refresh, nothing changes. The only cure is to shut MW and then restart.

Anyone with any thoughts? Is this simply a Windows problem - that 'pipes' do not reconnect properly after hibernating a PC?


RE: MinimWatch does not reconnect after PC hibernate - DavidHB - 26-01-2014 15:50

This sounds like a pretty typical hibernation issue. They can be tricky to fix, as sometimes they are a 'feature' of particular computer models.

I tend to allow my machines to go into hibernation only after a long period of inactivity. The default power settings on your machine may not be what you want, so it may be useful to review them. Beyond that, having a MinimWatch icon on the desktop, start page or other handy location would probably take most of the hassle out of this problem.

On a separate point, Simon is somewhat insistent (for understandable reasons) that MS is not an approved abbreviation for MinimServer. As we depend on him for further development of our favourite music server, we like to keep him sweet ...

David


RE: MinimWatch does not reconnect after PC hibernate - simoncn - 26-01-2014 20:07

(26-01-2014 12:41)RSJ Wrote:  I am using MinimWatch on a Windows 8.1 PC.

MW starts fine; however, if I hibernate the PC and then restart, the MW icon is blue/grey, and MW does not reconnected to MS on the Home Server PC. If I click on refresh, nothing changes. The only cure is to shut MW and then restart.

Anyone with any thoughts? Is this simply a Windows problem - that 'pipes' do not reconnect properly after hibernating a PC?

This problem is related to Windows 8.1. MinimWatch reconnects successfully on Windows 7 after resuming from hibernation, but not on Windows 8.1.

The code to reconnect after network adapter changes is in the ohNet UPnP stack, which MinimWatch uses. It seems there is some incompatibility in this area between Windows 8.1 and ohNet. I'll report this to the ohNet developers.


RE: MinimWatch does not reconnect after PC hibernate - RSJ - 26-01-2014 20:52

Thank you, sinomcn, for your response, and also, DavidHB, for your observation. It would be useful for one of those all-too-normal annoyances to be fixed (on both fronts).


RE: MinimWatch does not reconnect after PC hibernate - simoncn - 27-01-2014 00:42

(26-01-2014 20:52)RSJ Wrote:  Thank you, sinomcn, for your response, and also, DavidHB, for your observation. It would be useful for one of those all-too-normal annoyances to be fixed (on both fronts).

I am getting inconsistent behaviour now. It works somethimes and it fails sometimes (all on Windows 8.1). Please can you try this a few times to see whether it works on some occasions. Please can you also try sleep and resume to see whether that works or fails.


RE: MinimWatch does not reconnect after PC hibernate - RSJ - 27-01-2014 12:36

Simon-cn

Thank you, but I am not sure how I would make the requisite changes to the ohNet UPnP stack...


RE: MinimWatch does not reconnect after PC hibernate - simoncn - 27-01-2014 14:01

(27-01-2014 12:36)RSJ Wrote:  Simon-cn

Thank you, but I am not sure how I would make the requisite changes to the ohNet UPnP stack...

I think there has been a misunderstanding. To clarify:

Please can you try hibernating and resuming with MinimWatch active a few times to see whether it works on some occasions.

Please can you also try sleep and resume with MinimWatch active a few times to see whether that works or fails.


RE: MinimWatch does not reconnect after PC hibernate - RSJ - 29-01-2014 08:12

I have tried the sleep-restart a number of time - MinimWatch never reconnects. (Sleep and hibernate are not separate options, and appear to be terms that are used interchangeably on my Vaio.)


RE: MinimWatch does not reconnect after PC hibernate - simoncn - 29-01-2014 09:13

(29-01-2014 08:12)RSJ Wrote:  I have tried the sleep-restart a number of time - MinimWatch never reconnects. (Sleep and hibernate are not separate options, and appear to be terms that are used interchangeably on my Vaio.)

On my laptop, sleep puts the machine into a low-power state (wiith a power light still illuminated), and hibernate writes the contents of RAM to disk and turns the power lights off completely. Which of these is happening on your Vaio?


RE: MinimWatch does not reconnect after PC hibernate - RSJ - 29-01-2014 15:43

OK... Sleep is a power option - the machine automatically sleeps after a certain period of time. Hibernate appear on the shutdown menu. They seem to function as you suggest. MinimWatch does not seem to restart after either process.