MinimServer Forum

Full Version: Minimwatch cannot see Minimserver
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
I have installed Minimserver on a NAS NV+ v2. Installation easy and quick.

I can see the Minimserver on control points and in the network places in Windows Explorer. However, for some reason Minimwatch can't connect to the server. All I have is the greyed-out icon and no access to configure the server.

Any thoughts? Looking forward to trying this server out.

R
(23-10-2013 22:35)rweten Wrote: [ -> ]I have installed Minimserver on a NAS NV+ v2. Installation easy and quick.

I can see the Minimserver on control points and in the network places in Windows Explorer. However, for some reason Minimwatch can't connect to the server. All I have is the greyed-out icon and no access to configure the server.

Any thoughts? Looking forward to trying this server out.

R

Did you install MinimWatch on Windows? Assuming you did, this sounds like a problem with the firewall on the Windows machine. You can confirm this by disabling the firewall completely to see if this fixes the problem. If so, you need to set up firewall rules to allow the Java executable to listen on network ports.
Simon, thanks.

I am running Minimwatch in Win 7. I have tried various changes (I had the wrong version of Java installed) but to no avail.

I tried turning off the firewall but it made no difference. When I started up Minimwatch for the first time I did get the normal Windows Firewall message saying that it had blocked the programme and asking me to give it permissions. It is set to have permissions on Private networks.

To be clear, I am running Win 64-bit, but using the 32-bit browsers and thus 32-bit Java. I installed the 32-bit version of Minimwatch. The NAS NV+ is running RAIDiator 5.3.8 and that all seems fine, as the Minimserver has started and I can see the music server in my control points and in Windows Explorer.

Richard
(24-10-2013 07:46)rweten Wrote: [ -> ]Simon, thanks.

I am running Minimwatch in Win 7. I have tried various changes (I had the wrong version of Java installed) but to no avail.

I tried turning off the firewall but it made no difference. When I started up Minimwatch for the first time I did get the normal Windows Firewall message saying that it had blocked the programme and asking me to give it permissions. It is set to have permissions on Private networks.

To be clear, I am running Win 64-bit, but using the 32-bit browsers and thus 32-bit Java. I installed the 32-bit version of Minimwatch. The NAS NV+ is running RAIDiator 5.3.8 and that all seems fine, as the Minimserver has started and I can see the music server in my control points and in Windows Explorer.

Richard

When you unblocked Java in the Windows Firewall, was this the 64-bit version of Java? If so, it's possible that the 64-bit Java executable is unblocked and the 32-bit Java executable is blocked.

However, this doesn't explain why you are getting the problem with the Windows Firewall disabled. The page to disable the Windows Firewall can be quite confusing, and you might have disabled some parts of the firewall but not all of it.

Before we we go further down this path, there is something else to check. Does your PC have two network adapters on different subnets? If so, it's possible that MinimWatch is listening on the wrong network interface. For confirmation of this, please try disabling the "other" network interface and stopping and restarting MinimWatch.

If this turns out to be the problem, I'll explain how to configure MinimWatch to solve it.
Got it. Not the Firewall but it was the 'Leaf Networks Adapter' that was the other network device it was listening on, I guess.

I now have a green Minimwatch light - how can I make that permanent again when I restart the Leaf Networks Adapter (assuming I need to?).

Richard
(24-10-2013 21:31)rweten Wrote: [ -> ]Got it. Not the Firewall but it was the 'Leaf Networks Adapter' that was the other network device it was listening on, I guess.

I now have a green Minimwatch light - how can I make that permanent again when I restart the Leaf Networks Adapter (assuming I need to?).

Richard

You need to manually edit the minimwatch.config file in the C:\Users\<your-user-name>\AppData\Roaming\MinimWatch\data folder and add the line

ohnet.subnet = x.x.x.x

where the x.x.x.x value is the IP address of the correct adapter combined with its network mask (using a binary 'and' operation). For example, an IP address of 192.168.1.25 and a network mask of 255.255.255.0 would require the x.x.x.x value to be 192.168.1.0.
(24-10-2013 22:12)simoncn Wrote: [ -> ]
(24-10-2013 21:31)rweten Wrote: [ -> ]Got it. Not the Firewall but it was the 'Leaf Networks Adapter' that was the other network device it was listening on, I guess.

I now have a green Minimwatch light - how can I make that permanent again when I restart the Leaf Networks Adapter (assuming I need to?).

Richard

You need to manually edit the minimwatch.config file in the C:\Users\<your-user-name>\AppData\Roaming\MinimWatch\data folder and add the line

ohnet.subnet = x.x.x.x

where the x.x.x.x value is the IP address of the correct adapter combined with its network mask (using a binary 'and' operation). For example, an IP address of 192.168.1.25 and a network mask of 255.255.255.0 would require the x.x.x.x value to be 192.168.1.0.

Got it - only problem is that I can't navigate to that file as it doesn't exist on my system. Windows 7, 64 bit Ultimate edition. I get to <my-user-name> but after that there's no AppData folder.
UPDATE: Sorted - hidden file problem. Now amended and PROBLEM SOLVED.

Richard

Richard
(24-10-2013 22:29)rweten Wrote: [ -> ]Got it - only problem is that I can't navigate to that file as it doesn't exist on my system. Windows 7, 64 bit Ultimate edition. I get to <my-user-name> but after that there's no AppData folder.
UPDATE: Sorted - hidden file problem. Now amended and PROBLEM SOLVED.

Richard

Sorry, I forgot to mention that complication. This manual editing of a hidden file is awkward, so the next release of MinimWatch will have support in the GUI for setting this value.
On my Win7 machine, with an old version of VMWare installed, the virtual network adapters of VMWare block minim when they are enabled. Will try tonight whether setting ohnet.subnet makes a difference here. Would be great.
I have a similar problem with minimwatch on my Windows 7 PC. All was working beautifully, and it accurately represented the state of minimserver on my Raspberry Pi, and allowed me to adjust settings. However, I changed my old Netgear router for a brand new model yesterday and now minimwatch cannot see minimserver. The Pi is visible to my control points, so I can still select and play music, but am no longer able to see the state on my desktop PC. Any ideas why a new router would block access for minimwatch?
Pages: 1 2 3 4
Reference URL's